Sign in to follow this  
Followers 0
Steven P.

Why doesn't IE10 Metro work when it's not default browser?

10 posts in this topic

This seems dumb, for it to even work it has to be the default browser in Windows 8. My default is Firefox.

Share this post


Link to post
Share on other sites

Default is Chrome and working fine here

Share this post


Link to post
Share on other sites

I remember it disappeared from the start screen when I set another browser as default. Maybe you could just pin it again? Unfortunately I've only got it on the MBP, so can't find out right now.

Share this post


Link to post
Share on other sites

Apparently, MS has some stupid stipulation where you can only access the metro version of a browser if it's the default.

Share this post


Link to post
Share on other sites

Apparently, MS has some stupid stipulation where you can only access the metro version of a browser if it's the default.

yup. It isn't stupid at all though. It's there to ensure a consistent experience. Only 1 browser for any link that you may want to open.

Share this post


Link to post
Share on other sites

It's just out for public BETA.

your suggestions and bugs are most welcomed by Microsoft unlike Apple.

So if no one likes it, they will change it or atleast they offer you choice. :D

Share this post


Link to post
Share on other sites

My default is firefox nightly and metro IE10 works perfectly for me.

It would appear to be hit and miss whether it does work for people.

Share this post


Link to post
Share on other sites

It's just out for public BETA.

your suggestions and bugs are most welcomed by Microsoft unlike Apple.

So if no one likes it, they will change it or atleast they offer you choice. :D

Except you're wrong. http://www.apple.com/feedback/

Share this post


Link to post
Share on other sites

It's just out for public BETA.

your suggestions and bugs are most welcomed by Microsoft unlike Apple.

If that were true there would be no metro at all for the desktop.

Share this post


Link to post
Share on other sites

I have worked a lil with the settings and found that when you choose ur non ie browser as default , IE metro doesn't work then. However by choosing it as default for "Few things" , metro ie works. Sorry for so complicated language :p

All i mean is , just go default programs > select defaults > click ur non ie browser > click choose defaults > untick the protocols , boom u have Metro IE (which obviously mean that for protocols metro ie would run...)

post-293012-0-46889800-1331794694_thumb.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.