Jump to content



Photo

Win 8 with Elantech touchpad - Config app crashes

windows 8 elantech touchpad

  • Please log in to reply
3 replies to this topic

#1 Isaac Dontje Lindell

Isaac Dontje Lindell

    Neowinian

  • Joined: 18-March 10

Posted 04 June 2012 - 03:37

I'm having issues with the Elantech touchpad config program in Windows 8 RP x64. The driver for the touchpad works fine, and I can use 2 finger scrolling as expected. However, when I try to go to the Elantech options (Mouse control Panel Applet - "Elan" tab - "Options" button), I get the error message:

Windows Shell Common Dll has stopped working.
A problem caused the program to stop working correctly. Windows will close the program and notify you if a solution is available.

I should say that I encountered this problem in the Consumer Preview also. I'm trying to get into the config options to set up 2 finger tap to middle click. Obviously this is an incompatibility due to an unsupported, prerelease OS, but I was wondering if anybody else had encountered and maybe solved this issue, or at least found a workaround. Is there any way to manually configure the actions for various buttons, a la synclient for Linux? Or perhaps some registry keys? I've poked around a little bit, but I haven't been able to find the any keys that look promising. I've also tried setting the ETDCtrl.exe program (the driver utility program) to Windows 7 compatibility mode, and also to always run as administrator.

Any ideas?


#2 Hernaner28

Hernaner28

    Resident One Post Wonder

  • Joined: 12-August 12

Posted 12 August 2012 - 17:09

I've got exactly the same problem. Please help us!

#3 Glenn Verbruggen

Glenn Verbruggen

    Resident One Post Wonder

  • Joined: 27-August 12

Posted 27 August 2012 - 13:24

I took me a while to find it, but you can download a compatible driver from x-driver website. Google "elan 10.6.9.9"
Good luck!

#4 Link_of_Hyrule

Link_of_Hyrule

    Neowinian

  • Joined: 16-October 06

Posted 29 September 2012 - 19:45

I made a thread about this a while ago. http://www.neowin.ne...s-in-windows-8/