Question

Posted

Do to a temporary rearanging of things in the house, I've got two PCs connected with an eithernet cable sharing internet. One of them has a wireless card to connect to the router and it is sharing the connection with the other PC.

At first, it wouldn't work. Both PCs said the local area connection was unidentified. I noticed that they were on a different subnet. After some research, I learned that the unidentifed network issue is usually due to them not having a common gateway. I manually entered the IPv4 settings to put them on the same subnet and pointed one at the other as their gateway. Still didn't fix it. I then set everthing to defaults and magically after all the reboots and everthing, it started working.

Today, I wasn't getting a good enough signal to download some files quickly enough, so I ran a temporary line from PC2 (PC without wireless card), down the hallway to the router. After, when I hooked PC2 back up to PC1, I was back to having the original problem again. Now I can't get it working again.

Both are running Win7 Pro.

PC #1

[CODE]Windows IP Configuration

Host Name . . . . . . . . . . . . : Upstairs
Primary Dns Suffix . . . . . . . :
Node Type . . . . . . . . . . . . : Mixed
IP Routing Enabled. . . . . . . . : No
WINS Proxy Enabled. . . . . . . . : No

Ethernet adapter Local Area Connection:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Realtek PCIe GBE Family Controller
Physical Address. . . . . . . . . : 00-13-8F-89-79-2B
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
Link-local IPv6 Address . . . . . : fe80::c16d:9d2e:b442:e59e%11(Preferred)
Autoconfiguration IPv4 Address. . : 169.254.229.158(Preferred)
Subnet Mask . . . . . . . . . . . : 255.255.0.0
Default Gateway . . . . . . . . . :
DHCPv6 IAID . . . . . . . . . . . : 234886031
DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-17-B2-88-D2-00-13-8F-89-79-2B

DNS Servers . . . . . . . . . . . : fec0:0:0:ffff::1%1
fec0:0:0:ffff::2%1
fec0:0:0:ffff::3%1
NetBIOS over Tcpip. . . . . . . . : Enabled

Tunnel adapter isatap.{5CE07A93-112E-4335-BBCB-ADC9A493A2B4}:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Microsoft ISATAP Adapter
Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes

Tunnel adapter Teredo Tunneling Pseudo-Interface:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface
Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes
[/CODE]

PC #2 - the Linksys LNE100TX card is unused at the moment. Only using the interface on the mobo.

[CODE]Windows IP Configuration

Host Name . . . . . . . . . . . . : Downstairs
Primary Dns Suffix . . . . . . . :
Node Type . . . . . . . . . . . . : Hybrid
IP Routing Enabled. . . . . . . . : No
WINS Proxy Enabled. . . . . . . . : No

Ethernet adapter Local Area Connection 2:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Linksys LNE100TX(v5) Fast Ethernet Adapter
Physical Address. . . . . . . . . : 00-14-BF-5C-73-54
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes

Ethernet adapter Network Bridge:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : MAC Bridge Miniport
Physical Address. . . . . . . . . : 02-0F-EA-47-1B-CA
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
Link-local IPv6 Address . . . . . : fe80::c04c:2715:c4e1:92c3%18(Preferred)
IPv4 Address. . . . . . . . . . . : 192.168.2.100(Preferred)
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Lease Obtained. . . . . . . . . . : Wednesday, August 15, 2012 6:27:59 AM
Lease Expires . . . . . . . . . . : Saturday, September 21, 2148 5:46:35 PM
Default Gateway . . . . . . . . . : 192.168.2.1
DHCP Server . . . . . . . . . . . : 192.168.2.1
DHCPv6 IAID . . . . . . . . . . . : 318902250
DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-16-29-2B-DB-00-0F-EA-47-1B-CA

DNS Servers . . . . . . . . . . . : 192.168.2.1
NetBIOS over Tcpip. . . . . . . . : Enabled

Tunnel adapter isatap.{4C5EA07A-652B-48B9-97D5-7B6019F18CEC}:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Microsoft ISATAP Adapter
Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes

Tunnel adapter Local Area Connection* 12:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface
Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes
IPv6 Address. . . . . . . . . . . : 2001:0:4137:9e76:3c32:2710:e7f0:6bd8(Preferred)
Link-local IPv6 Address . . . . . : fe80::3c32:2710:e7f0:6bd8%20(Preferred)
Default Gateway . . . . . . . . . : ::
NetBIOS over Tcpip. . . . . . . . : Disabled

Tunnel adapter isatap.{611A51AC-4BA0-4DF5-85E1-A0D4C314AD19}:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Microsoft ISATAP Adapter #3
Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes

Tunnel adapter Local Area Connection* 13:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Microsoft ISATAP Adapter #4
Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes
[/CODE]

Share this post


Link to post
Share on other sites

35 answers to this question

  • 0

Posted

Your really using Bridge not ICS.

So PC #2 is the Bridge with two NIC with one NIC to your router the other NIC to PC #1 with the Bridge having having 192.168.2.100 and internet access.

Right so far?

Share this post


Link to post
Share on other sites
  • 0

Posted

Right. PC #1 (named downstairs) has it's wired NIC and wireless NIC bridged. I've set the router to give it the static IP 192.168.2.100. It's always been that way, and I haven't messed with the router settings since way before this.

When things were miraculaouly working yesterday, PC #1 gave PC #2 the IP 192.168.2.114. With all NICs set to default settings to obtain IPs automatically.

Share this post


Link to post
Share on other sites
  • 0

Posted

[quote name='unknownsoldierX' timestamp='1345053373' post='595092265']
Right. PC #1 (named downstairs)
[/quote]
Look at your post again PC #2 is listed as Downstairs in your post

Share this post


Link to post
Share on other sites
  • 0

Posted

"PC #1 gave PC #2 the IP 192.168.2.114. With all NICs set to default settings to obtain IPs automatically."

NO -- if you were bridged, then the Router your pc#1 is connected to would give the pc#2 its address and other dhcp info like mask and gateway and dns.

There is HUGE difference between ICS and Bridged interfaces.

So you have router --- wireless ---- PC#1 --- wired --- PC#2
dhcp scope on your router is

192.168.1.100 to 150
mask 255.255.255.0 or /24
gateway (itself) 192.168.1.1
dns (itself again or say opendns, googledns - whatever lets call it itself) 192.168.1.1

router is say 192.168.1.1, pc1 gets 192.168.1.100, pc2 would be 192.168.1.101

In a bridge (pc1) He sees packets on his interface 1, he sends it out interface 2, he sees packets on interface 2 he sends it out 1 - that is what a bridge does.

In ICS, your PC1 would be like a ROUTER, and doing NAT on the network he created on his 2nd interface. They are 2 different methods to accomplish pretty much the same thing. with ICS you would have something like this

router (192.168.2.1) ---- (192.168.2.100)PC1(192.168.1.1) ----(192.168.1.100)PC2

In that sort of setup PC1 would be the gateway for PC2, and the dhcp server and the DNS, just like your router is for PC1 -- where you can run into problems with ICS, is if you have duplicated networks on both interfaces of PC1. Depending on your OS version you would have to look up what the default IP of the ICS interface would be. In XP for example the ICS interface would have an IP address of 192.168.0.1. Not sure what it is in vista or w7 to be honest - might be the same.

I really don't play with ICS very often because a router cost like $20, there really is NO sort of configuration where ICS would be the desired setup.

If you need to extend a connection for example to another machine, like your setup where you have a wired connection to pc2 from pc1 and you want to share pc1 wireless interfaces network connection (internet) then sure bridging works just fine as a temp sort of solution until you can correctly setup your network where pc2 has its own actual connection to the network.

Share this post


Link to post
Share on other sites
  • 0

Posted

[s]Delete the bridge and setup a ad-hoc between the two PC's to test the wireless you will need to setup the IP's manually.[/s]

Ok so the bridge is connected by wireless to your router with the bridge wired to the other PC...

Damaged cable maybe?

Share this post


Link to post
Share on other sites
  • 0

Posted

Like I said, this is a temporary situation. Normally everything is hooked up to the router. And I assumed since the machine was sharing it's connection with another, it was called ICS. I get the difference now. Thanks.

I still don't get why PC#1 isn't getting an address from the router.

Share this post


Link to post
Share on other sites
  • 0

Posted

This thread is good as any other to have a quick discussion on why you might pick ICS over Bridging or vice vesa, etc.

When you would want bridging:
Lets say you wanted to be able to do port forwarding to your devices that don't have their own connection to the network and are going to be connected via the bridging PC. What if you wanted to be able to see broadcast traffic on other devices directly connected to the routers network via wired or wireless. A bridge would put the clients all on the same network(broadcast domain) So your router could forward ports to them, your devices behind the bridge would be able to use UPnP to your gateway router, etc.

When would you want to use ICS over bridging.
Let say you had lots of devices that don't have a method to connect to the router - say no wireless interfaces. Or maybe your wireless device in the PC you were going to use to bridge does not like bridging and just doesn't work. If you wanted to isolate broadcast traffic from these 2 network, maybe you are going to have lots of traffic between clients, and don't want that traffic being sent onto the wireless network because it would eat up the wireless bandwidth. But your ok with just these clients internet traffic. And you only have a HUB to connect these other devices not a switch

For example in the above setup with PC1 bridging to his wireless network to a PC2, what if you had 5 other PCs that you wanted to have internet connectivity behind this PC1. And you stream say video or move large files between PC3 and PC5. You would not want PC1 sending all those packets onto the wireless network. And you were going to connect these other PCs to PC1 with a HUB. So PC1 bridge interface would see all this traffic and send it out his wireless interface.

Maybe you don't want broadcast traffic from these PCs behind PC1 to go out to the wireless network, maybe you don't want these PCs to be able to use UPnP on the router. Maybe you don't want PCs connect to the routers network to be able to access the other PCs behind PC1

In those types of cases then turning PC1 into a NAT router would make sense. You would have 2 different networks, you would have 2 different broadcast domains. There would be a NAT between network 1 and network 2, so that PCs connected to the router could not access PCs behind the NAT.

There lots of different reasons you might want to use ICS vs Bridging in a temp type of configuration to get something to work while you work out the final/correct setup.

But normally if its only 1 or 2 machines you need to connect to your routers network - and there is a PC that is connected then sure quick bridge of that PCs interface would be the fastest easiest method of getting these other PCs on the network and internet.

Share this post


Link to post
Share on other sites
  • 0

Posted

As to why PC1 isnt getting an IP?? Did you try doing a release and renew on it?

if you showing lights on the interface on your PC2 (bridge PC) - you could try setting static on PC1

give it say 192.168.2.101, 255.255.255.0, gateway 192.168.2.1, dns 192.168.2.1

Can you ping 192.168.2.100? Can you ping 192.168.2.1 ?? If not, what do you show in PC1 arp table after you try and ping

arp -a in cmd prompt on PC1

Maybe your wireless card just doesn't like bridging? Maybe you have a firewall on PC1 blocking DHCP?? There are **** load of reasons what you might be doing wrong.

edit: BTW to make your ipconfig /all easier to read - your clearly not using IPv6, so why don't just fully disable it so we don't see all that teredo/tunnel ****

from elevated cmd prompt
reg add hklm\system\currentcontrolset\services\tcpip6\parameters /v DisabledComponents /t REG_DWORD /d 255

Above will fully disable IPv6, if you want to put it back to the way it is now - just delete the regkey with

reg delete hklm\system\currentcontrolset\services\tcpip6\parameters\ /v DisabledComponents /f

Then your output will look much cleaner. Here is my Box - even using IPv6 and its a lot cleaner looking ;)


[attachment=317029:cleanipconfig.jpg]

Share this post


Link to post
Share on other sites
  • 0

Posted

Reduce the variables:
Disconnect pc2 and get a stable connection on pc 1, then try reconnecting pc2

Share this post


Link to post
Share on other sites
  • 0

Posted

I can ping both 192.168.2.1 and 192.168.2.100. Here is what I get when I run arp -a on PC1.

[CODE]
Interface: 192.168.2.105 --- 0xb
Internet Address Physical Address Type
192.168.2.1 bc-ae-c5-e7-d0-ce dynamic
192.168.2.100 00-18-39-0e-ec-a7 dynamic
192.168.2.255 ff-ff-ff-ff-ff-ff static
224.0.0.22 01-00-5e-00-00-16 static
224.0.0.252 01-00-5e-00-00-fc static
239.255.255.250 01-00-5e-7f-ff-fa static
255.255.255.255 ff-ff-ff-ff-ff-ff static
[/CODE]

Firewalls haven't changed. It was working for a few days. All I did was plug the cable into the router temporarily and then it wasn't working when I switched it back.

Changed PC1 to static
192.168.2.105
255.255.255.0
192.168.2.1 for gateway & dns

Could no longer ping 192.168.2.1 or 192.168.2.100. Destination host unreachable.

Arp table
[CODE]
Interface: 192.168.2.105 --- 0xb
Internet Address Physical Address Type
192.168.2.255 ff-ff-ff-ff-ff-ff static
224.0.0.22 01-00-5e-00-00-16 static
224.0.0.252 01-00-5e-00-00-fc static
[/CODE]

Share this post


Link to post
Share on other sites
  • 0

Posted

[quote]
Interface: 192.168.2.105 --- 0xb
Internet Address Physical Address Type
192.168.2.255 ff-ff-ff-ff-ff-ff static
224.0.0.22 01-00-5e-00-00-16 static
224.0.0.252 01-00-5e-00-00-fc static
[/quote]

Well its never ever in a million years going to work if you don't have mac address of IPs in your table.

Lets be clear here on PC#
you say PC1 is Upstairs
and PC2 (bridge box) is Downstairs.
So its going to be a given that your bridge box PC2 can ping itself and gateway (router 192.168.2.1)

But your PC1 (non bridged box) Is not showing mac for router or even the mac for the interface the bridgebox its directly connected too.
So you got a bad cable? Its not doing autocross, or its not crossover - but until you can see the mac your never going to get to the router.

Share this post


Link to post
Share on other sites
  • 0

Posted

You said you were bridging the built in interface on the MB? I show 2.100 Mac
00-18-39 as [b]Cisco-Linksys, [/b]and

bc-ae-c5 as [b]ASUSTek COMPUTER INC[/b] <--- This is your router.
I dont think I have ever seen a cisco-linksys built in nic before? You sure you have the correct interfaces bridged?

Can you output your bridge setup using netsh

from cmd line do

netsh

you should then see
netsh>

then type bridge then show adapter and we should see your bridge configuration.

I can setup one real quick to show you the commands I am talking about in an example -- give me a few minutes

edit: Break your bridge, then output ipconfig /all then recreate your bridge and show the output of your netsh bridge show adapter command -- I will post example her in a minute or 2, my vm is booting.

edit2: ok here is before bridge - forget the ips for now

[code]

Ethernet adapter Local Area Connection 2:

Connection-specific DNS Suffix . : local.lan
Description . . . . . . . . . . . : vmxnet3 Ethernet Adapter #2
Physical Address. . . . . . . . . : 00-0C-29-53-2C-03
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
IPv4 Address. . . . . . . . . . . : 192.168.1.210(Preferred)
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Lease Obtained. . . . . . . . . . : Wednesday, August 15, 2012 3:48:34 PM
Lease Expires . . . . . . . . . . : Thursday, August 16, 2012 3:48:33 PM
Default Gateway . . . . . . . . . : 192.168.1.253
DHCP Server . . . . . . . . . . . : 192.168.1.253
DNS Servers . . . . . . . . . . . : 192.168.1.253
NetBIOS over Tcpip. . . . . . . . : Enabled

Ethernet adapter Local Area Connection:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Intel(R) PRO/1000 MT Network Connection
Physical Address. . . . . . . . . : 00-0C-29-53-2C-0D
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes
IPv4 Address. . . . . . . . . . . : 192.168.1.41(Preferred)
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Default Gateway . . . . . . . . . : 192.168.1.253
DNS Servers . . . . . . . . . . . : 192.168.1.253
NetBIOS over Tcpip. . . . . . . . : Enabled

[/code]

now in bridge
[code]
C:\Windows\system32>ipconfig /all

Windows IP Configuration

Host Name . . . . . . . . . . . . : W7X64-VM
Primary Dns Suffix . . . . . . . : local.lan
Node Type . . . . . . . . . . . . : Broadcast
IP Routing Enabled. . . . . . . . : No
WINS Proxy Enabled. . . . . . . . : No
DNS Suffix Search List. . . . . . : local.lan

Ethernet adapter Network Bridge:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : MAC Bridge Miniport
Physical Address. . . . . . . . . : 02-0C-29-53-2C-03
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
Autoconfiguration IPv4 Address. . : 169.254.212.136(Preferred)
Subnet Mask . . . . . . . . . . . : 255.255.0.0
Default Gateway . . . . . . . . . :
NetBIOS over Tcpip. . . . . . . . : Enabled

C:\Windows\system32>netsh
netsh>bridge
netsh bridge>show adapter

----------------------------------------------------------------------
ID AdapterFriendlyName ForceCompatibilityMode
----------------------------------------------------------------------
1 Local Area Connection 2 unknown
2 Local Area Connection unknown
----------------------------------------------------------------------
[/code]

edit: as I mentioned before some wireless cards don't like bridge mode, they need to support Promiscuous Mode

http://support.microsoft.com/kb/302348/en-us
Bridge May Not Work With a Non-Promiscuous Mode Network Adapter

Share this post


Link to post
Share on other sites
  • 0

Posted

[quote name='BudMan' timestamp='1345063289' post='595092865']
You said you were bridging the built in interface on the MB? I show 2.100 Mac
00-18-39 as [b]Cisco-Linksys, [/b]and

bc-ae-c5 as [b]ASUSTek COMPUTER INC[/b] <--- This is your router.
I dont think I have ever seen a cisco-linksys built in nic before? You sure you have the correct interfaces bridged?
[/quote]

00-18-39 is the wireless on PC2, which is a Linksys. That's what I want, right? The PC1 connected to the LAN on PC2, and the LAN and wireless on PC2 bridged so that PC1 gets internet.

Share this post


Link to post
Share on other sites
  • 0

Posted

And can please break the bridge and show us ipconfig /all

Then create the bridge and show us the netsh bridge show adapter output.

Share this post


Link to post
Share on other sites
  • 0

Posted

Broke bridge. PC2 config:

[CODE]
Windows IP Configuration
Host Name . . . . . . . . . . . . : Downstairs
Primary Dns Suffix . . . . . . . :
Node Type . . . . . . . . . . . . : Hybrid
IP Routing Enabled. . . . . . . . : No
WINS Proxy Enabled. . . . . . . . : No
Ethernet adapter Local Area Connection 2:
Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Linksys LNE100TX(v5) Fast Ethernet Adapter
Physical Address. . . . . . . . . : 00-14-BF-5C-73-54
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
Ethernet adapter Network Bridge:
Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : MAC Bridge Miniport
Physical Address. . . . . . . . . : 02-0F-EA-47-1B-CA
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
Wireless LAN adapter Wireless Network Connection:
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Broadcom 802.11n Network Adapter
Physical Address. . . . . . . . . : 00-18-39-0E-EC-A7
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
IPv4 Address. . . . . . . . . . . : 192.168.2.114(Preferred)
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Lease Obtained. . . . . . . . . . : Wednesday, August 15, 2012 7:41:42 PM
Lease Expires . . . . . . . . . . : Sunday, September 22, 2148 2:15:23 AM
Default Gateway . . . . . . . . . : 192.168.2.1
DHCP Server . . . . . . . . . . . : 192.168.2.1
DNS Servers . . . . . . . . . . . : 192.168.2.1
NetBIOS over Tcpip. . . . . . . . : Enabled
Ethernet adapter Local Area Connection:
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : VIA Rhine II Fast Ethernet Adapter
Physical Address. . . . . . . . . : 00-0F-EA-47-1B-CA
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes
IPv4 Address. . . . . . . . . . . : 169.254.229.101(Preferred)
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Default Gateway . . . . . . . . . : 169.254.229.100
NetBIOS over Tcpip. . . . . . . . : Enabled
[/CODE]

Recreated bridge.

[CODE]
netsh>bridge
netsh bridge>show adapter
----------------------------------------------------------------------
ID AdapterFriendlyName ForceCompatibilityMode
----------------------------------------------------------------------
1 Wireless Network Connection unknown
2 Local Area Connection unknown
----------------------------------------------------------------------
[/CODE]

Share this post


Link to post
Share on other sites
  • 0

Posted

How is that bridge broken?? What is this??

"[b]Ethernet adapter Network Bridge[/b]:
Media State . . . . . . . . . . . : Media disconnected

Share this post


Link to post
Share on other sites
  • 0

Posted

Thought you wanted me to break the bridge, and then do ipconfig? That's what I did.

Share this post


Link to post
Share on other sites
  • 0

Posted

Then how do you still have a Bridge listed in your output? Did you create multiple bridges? Delete all bridges shown in Control Panel\Network and Internet\Network Connections

Then recreate it, and I would put your wireless adapter
netsh bridge set adapter X forcecompatmode=enable

http://support.microsoft.com/kb/302348/en-us

Share this post


Link to post
Share on other sites
  • 0

Posted

[quote name='BudMan' timestamp='1345063289' post='595092865']
edit: Break your bridge, then output ipconfig /all then recreate your bridge and show the output of your netsh bridge show adapter command -- I will post example her in a minute or 2, my vm is booting.
[/quote]

That's what I did. The bridge is showing enabled because I enabled it before doing the netsh bridge show adapter.

Share this post


Link to post
Share on other sites
  • 0

Posted

Dude in your output where you said you broke/deleted the bridge there is a BRIDGE LISTED

[attachment=317077:bridgelisted.jpg]

Share this post


Link to post
Share on other sites
  • 0

Posted

You said to "break the bridge", so I removed the two adapters from the bridge. You didn't say "delete" the bridge.

Share this post


Link to post
Share on other sites
  • 0

Posted

Odd that a bridge would stay with no members - easy way to break a bridge is to just delete it, that would of been my method. But sure ok, my bad.

So set the forcecompatmode=enable on your wireless interface and see if that helps. Again some wireless just do not like to bridge, they have to support promiscuous mode, etc.

its hard for me to do remote, but I can recreate what your trying to do when I get back to the house. But tonight is BEER night, so not sure when that will be ;)

If you can not get the bridge mode to work, then go the ICS route - that should work even if your wireless does not support bridge mode.

Share this post


Link to post
Share on other sites
  • 0

Posted

Deleted bridge

[CODE]
Wireless LAN adapter Wireless Network Connection:
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Broadcom 802.11n Network Adapter
Physical Address. . . . . . . . . : 00-18-39-0E-EC-A7
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
IPv4 Address. . . . . . . . . . . : 192.168.2.100(Preferred)
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Lease Obtained. . . . . . . . . . : Thursday, August 16, 2012 10:16:05 AM
Lease Expires . . . . . . . . . . : Sunday, September 22, 2148 4:50:40 PM
Default Gateway . . . . . . . . . : 192.168.2.1
DHCP Server . . . . . . . . . . . : 192.168.2.1
DNS Servers . . . . . . . . . . . : 192.168.2.1
NetBIOS over Tcpip. . . . . . . . : Enabled
Ethernet adapter Local Area Connection:
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : VIA Rhine II Fast Ethernet Adapter
Physical Address. . . . . . . . . : 00-0F-EA-47-1B-CA
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes
IPv4 Address. . . . . . . . . . . : 169.254.229.101(Preferred)
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Default Gateway . . . . . . . . . : 169.254.229.100
NetBIOS over Tcpip. . . . . . . . : Enabled
[/CODE]

Recreated bridge

[CODE]
----------------------------------------------------------------------
ID AdapterFriendlyName ForceCompatibilityMode
----------------------------------------------------------------------
1 Wireless Network Connection unknown
2 Local Area Connection unknown
----------------------------------------------------------------------
[/CODE]

I don't see how my wireless adapter would have a problem with bridge when it worked flawlessly for the few days until I unplugged the cable.

Also did forcecompatmode=enable, but nothing has changed.

Share this post


Link to post
Share on other sites
  • 0

Posted

I don't know either, for all we know you were using ICS before?? I can not troubleshoot what I can not see, the heading of this thread is ICS, but your talking bridging. So to be frank - I have no idea what you were doing before

But what I can tell you is the wireless card does need to support promiscuous mode - and from your bridge output, its not known if its in that mode or not? So you could try setting it.

If that does not work - then use ICS mode. Unless you have a NEED to port forward traffic from your router to the box behind your PC connected to your netework the box behind the bridge or the ICS would have little difference in accessing normal stuff on the internet.

But it was never ever going to work from what you posted before with the box behind not showing MAC for the gateway IP.

Share this post


Link to post
Share on other sites
  • 0

Posted

I definitely was not using ICS before. I had the same setup like I'm trying to do now. Like I said before, I was confused as to what ICS meant, but now I understand the difference.

I do need ports forwarded from the router to the box behind the bridge. So ICS is out?

Also, like I said originally, this did work for the few days I had it set up, though it took me a long time of doing random things and eventually setting everything back to defaults for it to magically start working.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.