Question

Posted

Hi Guys,
I really need some help with this one.
I purchased a new PC, with a Gigabyte GA-H61MA-D2V motherboard that has on board realtek audio, I also purchased a nvidia geforce GT630 graphics card which has a built in audio processor and hdmi connection which is going to my LG 42PL6010 tv.

I've installed drivers for chipset, audio, graphics, but I'm unable to get any sound out of the HDMI port. I've set the default play back device as as the tv in control panel - sound. Choosing to test shows the audio bars moving but no sound comes out.
I've checked bios settings, tried with only audio drivers, or only graphics drivers, no joy.

I've tested the cable and tv with a hdmi equipped laptop, so can rule those out as a possible cause.

many thanks

Share this post


Link to post
Share on other sites

16 answers to this question

  • 0

Posted

I read on another forum- about - going into the sound options and selecting the other option instead of the speakers... Also you might check for the audio input settings in your TV. Just two thoughts

Share this post


Link to post
Share on other sites
  • 0

Posted

yea have already done both but no joy.

Share this post


Link to post
Share on other sites
  • 0

Posted

In the Nvidia control panel, inside the "Display" section there should be "Set up digital audio". Make sure that the HDMI port is set to the TV and neither of the two DVI ports.

Share this post


Link to post
Share on other sites
  • 0

Posted

Ive had the same issue before. You must set the hdmi audio as default then when you disconnect it the cable it will be back to normal. I dont know why it does that. But just go to sound properties right click hdmi and set as default that should then fix it? Worked for me anyway.

Share this post


Link to post
Share on other sites
  • 0

Posted

Done that guys. Still no joy.

see attachment. :)

Share this post


Link to post
Share on other sites
  • 0

Posted

perhaps you must enable sound in the actual graphics card settings? check within nvidia application.

Share this post


Link to post
Share on other sites
  • 0

Posted

[quote name='Soldiers33' timestamp='1349781980' post='595235209']
perhaps you must enable sound in the actual graphics card settings? check within nvidia application.
[/quote]

That's what I said above... Attaching a picture so you can see exactly what I'm talking about....

[img]http://notyour.sytes.net/nvidiaaudio.jpg[/img]

Also beyond that, if you double click on the sound device that you had open in your screenshot, and click on the advanced tab, try a lower setting. some TV's can't understand the super high settings such as 24 bit / 192000 Hz. 16 bit / 48000 Hz is pretty much industry standard though.

Share this post


Link to post
Share on other sites
  • 0

Posted

done that one too, it detects the TV under "Set up digital audio".

Share this post


Link to post
Share on other sites
  • 0

Posted

If you click on your sound icon in the taskbar, and click on mixer, are any of those muted?

Share this post


Link to post
Share on other sites
  • 0

Posted

For me to get mine working, i have to have the HDMI Cable plugged in to the TV + Graphics Card, turn my PC on when its all connected and make sure the TV in on the HDMI Channel.

If i plug the HDMI in while the PC is turned on, i get no sound. Always have to reboot.

Share this post


Link to post
Share on other sites
  • 0

Posted

Thinking back.... I think I had issues also, and my solution was to have a tuner between the TV and my computer (which gives me a hell of a lot better sound anyways) and passing the video through to the TV.

Share this post


Link to post
Share on other sites
  • 0

Posted

[quote name='Ecion' timestamp='1349779492' post='595235167']
Done that guys. Still no joy.

see attachment. :)
[/quote]

Looking at your screenshot, it doesn't actually mention HDMI on the audio device you have selected, it looks like you might have the boards digital out selected and not the cards HDMI

See mine:
[img]http://localhostr.com/files/0G1JogX/Capture.PNG[/img]



Could be you need to install the cards driver again to get the audio working / enable something in the cards settings

EDIT - Just noticed that the name of the device you have selected for Audio is the TV Model number, is it possible that the machine thinks the TV is the sound card rather than the speakers? If you look at mine, it shows that the sound device is the AMD Card, it doesnt mention my TV that is connected to it

Share this post


Link to post
Share on other sites
  • 0

Posted

I'm not sure where it got the name from, but its configurable anyway so don't think thats related. I've currently renamed it to HDMI anyway.
I've also asked the question to Palit (brand of nvidia card) and they've sent step by step pictures detailing the same setup as mine, so I think the way devices are listed etc is okay.

I've tried many reboots, and in certain orders to no avail. Also updated the mobo bios just in case, but again no joy.

One thing I have noticed though, is that the TV's hdmi channel is dimmed as if its not available - even though selecting brings up the picture. Its almost as if the TV has told the PC it can do sound, but the PC isnt telling the TV know sound is coming down the cable. The HDMI channel icon lights up again when using another machine (laptop, xbox, etc).

Share this post


Link to post
Share on other sites
  • 0

Posted

[quote name='Ecion' timestamp='1349787539' post='595235345']
I'm not sure where it got the name from, but its configurable anyway so don't think thats related. I've currently renamed it to HDMI anyway.
I've also asked the question to Palit (brand of nvidia card) and they've sent step by step pictures detailing the same setup as mine, so I think the way devices are listed etc is okay.

I've tried many reboots, and in certain orders to no avail. Also updated the mobo bios just in case, but again no joy.

One thing I have noticed though, is that the TV's hdmi channel is dimmed as if its not available - even though selecting brings up the picture. Its almost as if the TV has told the PC it can do sound, but the PC isnt telling the TV know sound is coming down the cable. The HDMI channel icon lights up again when using another machine (laptop, xbox, etc).
[/quote]

I had a quick look through the thread here but didn't notice if you had tried a different HDMI cable or not ?

EDIT - I see you tested that cable with another machine, still wouldn't hurt to try a new cable with this machine

Share this post


Link to post
Share on other sites
  • 0

Posted

Ok thats weird. I tried another cable, worked fine, went back to the original cable and now thats working, that makes no sense! I'm worried that it'll stop again, but for now its working! Many thanks to you guys.

Share this post


Link to post
Share on other sites
  • 0

Posted

[quote name='Ecion' timestamp='1349790479' post='595235493']
Ok thats weird. I tried another cable, worked fine, went back to the original cable and now thats working, that makes no sense! I'm worried that it'll stop again, but for now its working! Many thanks to you guys.
[/quote]

Heh, strange, maybe just the whole removing and reinserting of the cable cleaned a contact on the cards port

Great news :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.