Sign in to follow this  
Followers 0

ubuntu Weird Ubuntu 12.10 Window Lag


6 posts in this topic

Posted

Hello everybody.

I just took a spare HDD and installed Ubuntu 12.10 Beta 2 on it. I have a PNY NVIDIA 250, If it matters. I installed my drivers (NVIDIA-Current-Updates) if I remember right, and I installed my updates as well. I rebooted, logged in, and for the first 30 seconds, window dragging and animation is buttery smooth, but then lags and locks up. I have tried every driver with the same results. I have nothing installed or modded anything. What's up? Is it just typical beta glitches? Anyone else having this issue?

I have googled it and they told me to delete my .confg (I think) and my .compiz folder. This unfortunately, did not help.

Thanks Guys! I appreciate any and all help!

Share this post


Link to post
Share on other sites

Posted

Sounds to me like when you install the nVidia driver it's not enabling hardware acceleration. Try

 glxinfo | grep render
does it say yes? also I would try
 glxinfo |grep vendor

and see what it says as well.

1 person likes this

Share this post


Link to post
Share on other sites

Posted

Sounds like Compiz window decorations getting bugged out again. Ubuntu 11.10 was terrible with this and I had to use a special patched version from one of the Compiz devs.

As Beta 2 was released before this was committed, then I guess its related https://bugs.launchpad.net/ubuntu/+source/compiz/+bug/1050610 though they reported after a few days... but still.

1 person likes this

Share this post


Link to post
Share on other sites

Posted

Sounds to me like when you install the nVidia driver it's not enabling hardware acceleration. Try

 glxinfo | grep render
does it say yes? also I would try
 glxinfo |grep vendor

and see what it says as well.

I'll try that when I get home and let you know. :) Thanks!

Sounds like Compiz window decorations getting bugged out again. Ubuntu 11.10 was terrible with this and I had to use a special patched version from one of the Compiz devs.

As Beta 2 was released before this was committed, then I guess its related https://bugs.launchp...iz/+bug/1050610 though they reported after a few days... but still.

Yeah, Compiz defiantly needs some work. I really hope they make the jump to Wayland in 13.04. Maybe It'll fix a lot of Ubuntu's graphical niggles. I looked at the link you sent me and it is a "High-Priority" bug, with any luck, an update might fix it...hopefully.

Share this post


Link to post
Share on other sites

Posted

Compiz will still be used as the system compositor even when Wayland support comes about. Though it'll probably force a major re-write that will hopefully fix a lot of fundamental issues that can be seen with X11. However, it'll also introduce a whole lot of regressions as well.

I don't think Wayland will be introduced in 13.04 though. They really need to concentrate with getting performance up with Compiz/Unity when Valve's Linux Steam client should hit public release.

1 person likes this

Share this post


Link to post
Share on other sites

Posted

I think I fixed it. LOL. I installed the Nouveiew FOSS driver instead of the NVIDIA one. It still kinda lags, but it's do-able at least. I hope this gets fixed before the release. Thanks again all!!!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.