Jump to content



Photo

Broken layout in IE9 Mobile?

bug

  • Please log in to reply
6 replies to this topic

#1 Cuteness Overload

Cuteness Overload

    Neowinian

  • Joined: 17-July 12

Posted 19 November 2012 - 12:38

Posted Image

This is what I got when I browsed Neowin's mobile front page earlier this morning. What happened? (I figured that this is a different kind of mobile site problem.)


#2 Timan

Timan

    Fade Away...

  • Tech Issues Solved: 8
  • Joined: 21-October 01
  • Location: Virginia, USA

Posted 19 November 2012 - 13:07

Now this is the only thing that changed on mobile this morning (still ranting about the other thread here). I had to remove the compatibility mode for wp8, but will look into fixing this for wp7 users. Seems neowin is on a compatibility view list, so its forcing the site to render in ie7 mode. Thus that happens

#3 tsupersonic

tsupersonic

    Neowinian Senior

  • Tech Issues Solved: 1
  • Joined: 30-September 06
  • Location: New York
  • OS: Win. 8.1 Pro. x64
  • Phone: Nexus 5 16 GB

Posted 19 November 2012 - 13:18

Yep, I can confirm this. I busted out the good ol' WP7.5 Trophy, and Neowin looked just like that on the device. Works fine on Galaxy Nexus running JB 4.1.2

#4 stoo2000

stoo2000

    Neowinian

  • Joined: 21-June 12
  • OS: Windows 8.1 Pro
  • Phone: Nokia Lumia 900

Posted 19 November 2012 - 13:27

No problem with rendering on my Lumia 900.

#5 OP Cuteness Overload

Cuteness Overload

    Neowinian

  • Joined: 17-July 12

Posted 19 November 2012 - 14:02

Now this is the only thing that changed on mobile this morning (still ranting about the other thread here). I had to remove the compatibility mode for wp8, but will look into fixing this for wp7 users. Seems neowin is on a compatibility view list, so its forcing the site to render in ie7 mode. Thus that happens


<meta http-equiv="X-UA-Compatible" content="IE=edge" />, anyone?

(Or setting the server to send out the equivalent HTTP header)

Or maybe <meta http-equiv="X-UA-Compatible" content="IE=EmulateIE9" />

#6 Timan

Timan

    Fade Away...

  • Tech Issues Solved: 8
  • Joined: 21-October 01
  • Location: Virginia, USA

Posted 19 November 2012 - 14:11

<meta http-equiv="X-UA-Compatible" content="IE=edge" />, anyone?

(Or setting the server to send out the equivalent HTTP header)

Or maybe <meta http-equiv="X-UA-Compatible" content="IE=EmulateIE9" />


Yes, I had to remove this. We'll have to add it for wp7 users tho it seems. Stupid ms :( only does this on the neowin.net domain

#7 Timan

Timan

    Fade Away...

  • Tech Issues Solved: 8
  • Joined: 21-October 01
  • Location: Virginia, USA

Posted 19 November 2012 - 14:16

Should be fixed now. Will most likely be broken when 7.8 comes out, so will worry about that then.



Click here to login or here to register to remove this ad, it's free!