Jump to content



Photo

MySQL Database Move


  • Please log in to reply
1 reply to this topic

#1 Sikh

Sikh

    Neowin Addict!

  • Tech Issues Solved: 2
  • Joined: 11-March 07
  • Location: localhost
  • OS: Windows 7 / 10.8 / Ubuntu Server
  • Phone: Nexus 5 PA 4.4.2 / iPhone 5

Posted 25 November 2012 - 14:48

I'm trying to move some big production databases from mysql server 5.0.51b to the latest 5.5 release.

I properly dumped the databases on the old server and I moved then to the new server. Every time I run "mysql -u root -p (database) < (database_SQL.sql)"

It gives me an error saying its at line 1. Line 1 is the dump information from the old server. I'll remove it and then it says "can't create table blah blah blah".

What do I do!? This has been driving me crazy at work. Good thing is we are moving to a new server. So if I can't get it today I'll be able to throw up the old machine but bad thing is its been the biggest bottleneck in our network. Finally got a machine specd out perfectly for a replacement and now mysqls being a bitch.

Any help is appreciated guys.

Thanks,
Sikh


#2 Faks

Faks

    Neowinian

  • Joined: 01-May 09
  • Location: Europe
  • OS: Windows 7 Ultimate
  • Phone: Samsung Crap

Posted 25 November 2012 - 14:56

first of all what error exactly appears !