Jump to content



Photo

Linux Distros not loading with LiveCD/DVD/USB?


  • Please log in to reply
7 replies to this topic

#1 Nothing Here

Nothing Here

    Neowinian Senior

  • Joined: 23-February 08
  • Location: California, U.S.A.
  • OS: Windows 8 Pro / Kororaa 17

Posted 15 January 2013 - 18:12

Then try going into your BIOS and find the IOMMU Mode - IOMMU is supported on LINUX based systems to convert 32bit I/O to 64bit MMIO. Set it to Enabled.
Since changing this option every boot has been successful.


#2 Mindovermaster

Mindovermaster

    Neowinian Senior

  • Tech Issues Solved: 13
  • Joined: 25-January 07
  • Location: /USA/Wisconsin/
  • OS: Debian Jessie
  • Phone: Samsung Galaxy SIII

Posted 15 January 2013 - 18:31

What is your problem? :huh:

#3 OP Nothing Here

Nothing Here

    Neowinian Senior

  • Joined: 23-February 08
  • Location: California, U.S.A.
  • OS: Windows 8 Pro / Kororaa 17

Posted 15 January 2013 - 18:52

What is my problem? What's yours?

#4 Mindovermaster

Mindovermaster

    Neowinian Senior

  • Tech Issues Solved: 13
  • Joined: 25-January 07
  • Location: /USA/Wisconsin/
  • OS: Debian Jessie
  • Phone: Samsung Galaxy SIII

Posted 15 January 2013 - 18:56

It sounds like your telling us about half of what you posted.

What is your problem/issue? I don't think anyone can give you support with that information.

#5 OP Nothing Here

Nothing Here

    Neowinian Senior

  • Joined: 23-February 08
  • Location: California, U.S.A.
  • OS: Windows 8 Pro / Kororaa 17

Posted 15 January 2013 - 19:37

Ok. In the past I and others here, have had issues loading distros normally. Some of us have to use nomodeset to load, others just get a black screen. Not sure why. But I and alot of others, have never got a good answer from anyone regarding this. I don't need support. I was actually posting how to get them to load. I meant to post this as a mini-tut.

Guess I failed in that. Sorry for the confusion.

#6 Haggis

Haggis

    Neowinian Senior

  • Tech Issues Solved: 13
  • Joined: 13-June 07
  • Location: Near Stirling, Scotland
  • OS: Debian 7
  • Phone: Samsung Galaxy S3 LTE (i9305)

Posted 15 January 2013 - 19:50

the reason they need to use nomodeset is because the graphics driver is not there and needs to be installed manually

#7 OP Nothing Here

Nothing Here

    Neowinian Senior

  • Joined: 23-February 08
  • Location: California, U.S.A.
  • OS: Windows 8 Pro / Kororaa 17

Posted 15 January 2013 - 20:03

the reason they need to use nomodeset is because the graphics driver is not there and needs to be installed manually


Not for me anymore. Now distros I had to use nomodeset before with, just load up.

#8 +Karl L.

Karl L.

    xorangekiller

  • Tech Issues Solved: 15
  • Joined: 24-January 09
  • Location: Virginia, USA
  • OS: Debian Testing

Posted 16 January 2013 - 04:32

Then try going into your BIOS and find the IOMMU Mode - IOMMU is supported on LINUX based systems to convert 32bit I/O to 64bit MMIO. Set it to Enabled.
Since changing this option every boot has been successful.


I was a little confused by this post at first too, just like Mindovermaster, but I understood your meaning after reading it carefully a few times. I didn't know that changing that setting helped, or, to be honest, that it even exists on some machines. Thanks for the tip!

the reason they need to use nomodeset is because the graphics driver is not there and needs to be installed manually


Technically, that's not quite right, but you have the right idea. You need to pass the nomodeset switch to the Linux kernel because the graphics driver (usually the framebuffer) tries to use a resolution your video card (or, at least, your monitor) can't handle. Since you don't have the hardware to support that resolution, the screen goes black. That switch hints to the graphics driver that it should keep the current resolution (which is normally 640x480 or 800x600, depending on what your bootloader set) instead of trying to automatically determine the native resolution for your monitor. Installing the proper video driver (or, more often, the DFSG non-free firmware for your video card) resolves the issue because the video driver can properly probe your video card and monitor for supported resolutions and make a sane resolution choice.