Jump to content



Photo

Android Texting problem


  • Please log in to reply
6 replies to this topic

#1 +patseguin

patseguin

    Neowin Addict

  • Tech Issues Solved: 1
  • Joined: 21-May 02
  • Location: Buffalo, NY
  • OS: Windows 8.1
  • Phone: iPhone 5s

Posted 17 January 2013 - 17:01

I converted from iphone to the Nexus 4 about 6-7 months ago and love it. However, I have a texting problem. I hope this is the right forum for some insight. I can text people and they can text me back EXCEPT for iOS users. When I text my Dad and Brother who have iPhones, their texts go to my iPad and not my Nexus phone. I went to AT&T and they told me I had to disable iMessage on the iPad, so I did and their texts still don't go to my phone. Am I missing something? Is there a setting on the Nexus? I find it so odd that I can't get someone with an iOS device to text me.


#2 Geoffrey B.

Geoffrey B.

    LittleNeutrino

  • Tech Issues Solved: 11
  • Joined: 25-July 05
  • Location: Ohio
  • OS: Windows 8.1u1
  • Phone: Nokia Lumia 928 WP8.1u1

Posted 17 January 2013 - 17:09

are they using iMessage, if they have the contacts tied together it might reply using iMessage rather than as a text message.

#3 OP +patseguin

patseguin

    Neowin Addict

  • Tech Issues Solved: 1
  • Joined: 21-May 02
  • Location: Buffalo, NY
  • OS: Windows 8.1
  • Phone: iPhone 5s

Posted 17 January 2013 - 17:11

hmm maybe. if iMessage doesn't get a delivery confirmation isn't it supposed to go to SMS?

#4 McKay

McKay

    Neowinian Stallion

  • Joined: 29-August 10
  • Location: 308 Negra Arroyo Lane
  • OS: Windows 8.1
  • Phone: LG G3

Posted 17 January 2013 - 17:11

Have you tried removing your email completely from the iMessages option instead of just disabling it?

#5 Yusuf M.

Yusuf M.

  • Tech Issues Solved: 1
  • Joined: 25-May 04
  • Location: Toronto, ON
  • OS: Windows 8.1 Pro
  • Phone: OnePlus One 64GB

Posted 17 January 2013 - 17:12

My guess is they're still messaging your Apple ID rather than your number. Tell them to enable the "Send as SMS" feature. It sends a SMS when iMessage isn't available. If that doesn't work, then they should remove your Apple ID from your contact information.

#6 Shadrack

Shadrack

    Neowinian Senior

  • Tech Issues Solved: 3
  • Joined: 20-December 01

Posted 17 January 2013 - 18:54

If possible do the following:
* Move your Micro SIM back to your iPhone
* Send an iMessage to one of your relatives with an iOS device
* Go to Settings->Messages and toggle iMessage to "Off"
* Send an SMS to one of your relatives with an iOS device. Make sure that it is "green" and not the iMessage "blue".
* Place the Micro SIM back in your Nexus 4

Apple should now have removed your Phone Number as being a usable iMessage address for you.

If you don't have an iPhone available anymore you will need to contact Apple over the issue as the issue is with their servers. Their servers are telling your relatives with other iOS devices to that your phone number is valid for iMessaging. Disabling it while active in an iPhone will tell the Apple servers to stop using that phone number for iMessages.

#7 StandingInAlley

StandingInAlley

    Neowinian Senior

  • Tech Issues Solved: 1
  • Joined: 27-November 05
  • Location: India
  • OS: Mac OSX Lion
  • Phone: Nokia Lumia 920

Posted 17 January 2013 - 18:57

This is a know issue and Apple is not fixing it. I had the same issue where i sold my iPhone 4S and hence couldn't disable iMessages completely on my phone number and email address. After a few weeks, it got fixed automatically.

Check Apple Support forum btw, they have provided a few fixes for it.