Sign in to follow this  
Followers 0

The upgrade to 3.4

39 posts in this topic

Posted

We've started the work for it. We've also identified a number of issues with some of our mods (we have a lot) that will work a lot better in 3.4, plus we're also hoping that the Subscriptions (IPB team unofficial mod/hack) will be updated, but aren't ruling out just making it compatible ourselves so we can upgrade, but obviously we don't want to add more work to an already huge task :p

From what I hear most of our common mod hacks have already been worked into our testing area and I'll also be doing some work there tomorrow and the coming week (mainly testing etc).

I hope we can do it in February, so hold off on the feature requests for the current board atm.

Shortly before the upgrade we may also want some feedback on a few things, mainly to do with off topic forum presentation and permissions.

Neowin will also return with a new theme, either with the upgrade, or shortly after it. The main thing is ensuring everything works properly.
6 people like this

Share this post


Link to post
Share on other sites

Posted

Sounds nice. Good luck with the upgrade!

Share this post


Link to post
Share on other sites

Posted

Awesome, keep up the great work guys.
The site has been so much better for me lately.

Share this post


Link to post
Share on other sites

Posted

Great stuff. I've just moved one of my clients over to IPB 3.4 and I have to say it's a solid release :)

Share this post


Link to post
Share on other sites

Posted

Sounds like quite a trial. Good luck!

Share this post


Link to post
Share on other sites

Posted

BTW, in the [url="http://www.neowin.net/credits"]http://www.neowin.net/credits[/url] section, you guys dont talk much about IPB (and the mods you use) and the software/OS you run. Would be nice.

[url="http://community.invisionpower.com/blog/1174/entry-8192-ipboard-34-dev-update-best-answer-feature/"]http://community.invisionpower.com/blog/1174/entry-8192-ipboard-34-dev-update-best-answer-feature/[/url]

This feature is much needed on Neowin :)

Share this post


Link to post
Share on other sites

Posted

[quote name='pes2013' timestamp='1359847888' post='595497610']
BTW, in the [url="http://www.neowin.net/credits"]http://www.neowin.net/credits[/url] section, you guys dont talk much about IPB (and the mods you use) and the software/OS you run. Would be nice.
[/quote]Actually it does say the latest stable RHEL/CentOS, MySQL, Apache, PHP.

That said I thought there was discussion about upgrade MySQL and PHP for performance... will that be happening or has it already happened? (not that you want to add work to the current work :p)

Share this post


Link to post
Share on other sites

Posted

Looking forward to the upgrade (Y)

Share this post


Link to post
Share on other sites

Posted

Good luck. There have been lots of editor issues and please also keep in mind there may be some theme wonkies. There have been some MAJOR theme revamps from 3.2 to 3.4 so please keep that in mind.

stuff is smoother when you upgrade a X.X.x to an X.X.y release but if you upgrade from a X.X.x release to a X.Y.x release that's when stuff gets wonky.

my theme transition from 3.3 to 3.4 was very drastic and me, and lots of people had to redo our themes as a result and that was a pain because I had to wait for my theme author to fix it so I had to stick with a visual skin for a while... but then the visual editor skin grew on me and I ended up keeping it... however the friend and the client didn't want to do that so they waited and it took 2 weeks.

For those with template issues post-upgrade:

Please run the template merge tool from the following ACP area:
Look & Feel > Look & Feel > Template Merge

Then run the report on it

Then go to:
Look & Feel > Template Merge Reports > Choose your skin

After you've done that go to the following ACP area:
System>Tools and Settings>Cache mgmt>and scroll down and re-cache the skinsets

Also you may want to rebuild the templates as well from the following ACP area:
Look & Feel > Template Tools

Run the following:
Recache Skin Sets
Rebuild Master Skin Data
Clean Up Tools




I wish the best for your custom forum software though and It would be cool if you released that and got into offering it to people. I would love to help with it too... . I'm really curious about it.
1 person likes this

Share this post


Link to post
Share on other sites

Posted

The skin is the least of our worries, it's more supporting the mods we have installed, they're so extensive it's ridiculous! :p

Share this post


Link to post
Share on other sites

Posted

[quote name='cybertimber2008' timestamp='1359848703' post='595497642']
Actually it does say the latest stable RHEL/CentOS, MySQL, Apache, PHP.
[/quote]
Thats things we dont see; We want to know about the IPB......

Share this post


Link to post
Share on other sites

Posted

[quote name='pes2013' timestamp='1359893343' post='595498344']
Thats things we dont see; We want to know about the IPB......
[/quote]

We don't use mods that people have up for download at ipb's website if thats what people are thinking.

Share this post


Link to post
Share on other sites

Posted

I hope that you keep the current skins that are available now.
1 person likes this

Share this post


Link to post
Share on other sites

Posted

[quote name='Gary7' timestamp='1359916751' post='595498982']
I hope that you keep the current skins that are available now.
[/quote]

All the current skins will be gone, including mobile. They'll have to be recreated on 3.4, whenever that happens. Blame IPB for their god awful skinning system on that one.
2 people like this

Share this post


Link to post
Share on other sites

Posted

Will there be dark ones I hope?

Share this post


Link to post
Share on other sites

Posted

I hope you bring NeoGamr's theme to the forum as the new Pro theme :)
1 person likes this

Share this post


Link to post
Share on other sites

Posted

[quote name='Timan' timestamp='1359920106' post='595499116']
All the current skins will be gone, including mobile. They'll have to be recreated on 3.4, whenever that happens. Blame IPB for their god awful skinning system on that one.
[/quote]

So that means being stuck with a bright white theme for months. So much for the forums having any use...

Share this post


Link to post
Share on other sites

Posted

[quote name='Blackhearted' timestamp='1359922365' post='595499186']
So that means being stuck with a bright white theme for months. So much for the forums having any use...
[/quote]nope, no bright white default theme like in times past. what is now known as midnight will be the default theme used when they upgrade

this was decided shortly after the last major upgrade took place

Share this post


Link to post
Share on other sites

Posted

[quote name='Brando212' timestamp='1359922765' post='595499212']
nope, no bright white default theme like in times past. what is now known as midnight will be the default theme used when they upgrade

this was decided shortly after the last major upgrade took place
[/quote]


Eh, it will be a white bright default theme most likely. We may have a dark alternative, but it won't be like what we have now.
1 person likes this

Share this post


Link to post
Share on other sites

Posted

I am using Darkside , I hope some theme close to that will be used. Bright themes bother my old eyes. :)
2 people like this

Share this post


Link to post
Share on other sites

Posted

[quote name='Timan' timestamp='1359926494' post='595499300']
Eh, it will be a white bright default theme most likely. We may have a dark alternative, but it won't be like what we have now.
[/quote]
Nice! I missed the bright version of Pegasus.

Share this post


Link to post
Share on other sites

Posted

Sweet! Can't wait to see what comes out of this!

Share this post


Link to post
Share on other sites

Posted

Very excited for the update, eager to give it a test if they do a Subscriber test again.
1 person likes this

Share this post


Link to post
Share on other sites

Posted

[quote name='Gary7' timestamp='1359927521' post='595499318']
I am using Darkside , I hope some theme close to that will be used. Bright themes bother my old eyes. :)
[/quote]

Same here.... I got sensitive eyes.

Share this post


Link to post
Share on other sites

Posted

Looking forward to the upgrade, I guess. Not really sure.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.