Jump to content



Photo
no sleep

  • Please log in to reply
16 replies to this topic

#1 IceBreakerG

IceBreakerG

    Local Ninja! Code Ninja That Is.

  • Tech Issues Solved: 1
  • Joined: 27-August 06
  • Location: Cordova, TN

Posted 12 November 2013 - 23:59

A few weeks ago I built a new system using the following parts:

  • Motherboard: ASRock Z87E-ITX
  • CPU: Intel Core i7-4770
  • RAM: 16GB G.Skill Ares 2133MHz
  • PSU: 750W Corsair HX750
  • CPU Cooler: Cooler Master Seidon 120XL
  • SSD: 250GB Samsung 840 Evo
  • Case: Cooler Master Elite 130
  • Blu-Ray: Asus 12X BD-ROM
  • OS: Windows 8.1 Enterprise (from work, MSDN)
  • My Youtube HTPC Build Series: http://www.youtube.c...7Bk8ztWgbgSvsQx

The system runs great and is extremely fast and quiet (other than the hum from the water pump).  The only issue I've really had was installing the network drivers from ASRock's website basically killed my networking all together, and the the system will not stay asleep.  I formatted and reinstalled Windows and re-installed all of the drivers (minus the network drivers), but the system still will not stay asleep.  What happens is it goes to sleep and stays asleep for about 20-30 seconds, then it wakes up again.  I've checked everything I can think of (disabled the Intel smart connect stuff, disabled wake-on-lan and went into the power settings to allow the system to sleep when sharing media).  Has anyone else had this problem (possibly with this board)?  Since the system reaches the log in screen from being powered off in about 10-11secs, it's not an issue that it takes a long time to boot, because it boots up insanely fast (I never even see the Windows loading screen), but not sleeping is bugging me.  Does anyone have any ideas?




#2 thejohnnyq

thejohnnyq

    Neowinian

  • Joined: 13-March 03
  • Location: North of Cincy, to the Left

Posted 13 November 2013 - 00:09

Skip the drivers from ASRock.  Use the drivers from the NIC manufacturer - http://www.intel.com...ontrollers.html .

 

Personally I never use drivers provided the motherboard manufacture.  They are normally old or limited.

 

Otherwise nice board, I am looking at building a server with one of those with 32gb ram and no water cooling.



#3 +Anarkii

Anarkii

    Member N° 1,455

  • Joined: 02-October 01
  • Location: Sydney, Australia
  • OS: Windows 8.2 Pro (8.1 Update 1)
  • Phone: iPhone 5, iOS 8

Posted 13 November 2013 - 00:10

I dont have the same setup but I do have the same problem. Computer wont sleep. I have to shutdown the PC when im done with it for the night. 
A solution would be great for this :)



#4 MindTrickz

MindTrickz

    That's no way to treat a lady!

  • Tech Issues Solved: 1
  • Joined: 18-September 03
  • Location: Europe:

Posted 13 November 2013 - 01:13

It sounds like the issue might be with the network driver. Network cards are the most common source of wake-up problems. Go into power management and disable the network card being able to wake up the computer and see if that fixes it.



#5 OP IceBreakerG

IceBreakerG

    Local Ninja! Code Ninja That Is.

  • Tech Issues Solved: 1
  • Joined: 27-August 06
  • Location: Cordova, TN

Posted 13 November 2013 - 03:55

I tried checking some settings in the power manager but the only setting related to networking I have is for the wireless (I'm not using ethernet on this system right now).  I also checked the event log, and there's definitely something causing it to wake up that seems to be networking related, but I'm not sure what it is as it says the wake up source is unknown.  It's also possible that it could be related to the onboard bluetooth module too.  At this point I'm kind of lost on what to do next.  I'm nervous about screwing with the network drivers again because the last time I was unable to get it working and had to format and reinstall Windows again (this was on a new drive, so it wasn't that big of an issue, but now Windows is activated, and I'd rather not reinstall again).



#6 MindTrickz

MindTrickz

    That's no way to treat a lady!

  • Tech Issues Solved: 1
  • Joined: 18-September 03
  • Location: Europe:

Posted 13 November 2013 - 05:28

You can do it from bios/UEFi.

 

Or inside Windows:

 

5768d1364873750-a75m-hvs-wake-lan-not-wo

 

Yours might look something more like this:

cbEis9g.png



#7 Praetor

Praetor

    ASCii / ANSi Designer

  • Tech Issues Solved: 3
  • Joined: 05-June 02
  • Location: Lisbon
  • OS: Windows Eight dot One dot One 1!one

Posted 13 November 2013 - 06:16

when the PC is asleep do you move the mouse or it just wakes up all by it self after a couple of seconds? If it's the latter then could be some C state that's on; check the UEFI for power management or C states and disable them all, put 1 minute to sleep and see if it sleeps. Also in Windows check the power option "allow wake timers" and set to disable; it can be a schedulled task that wakes up your PC.

 

also try in cmd shell: powercfg lastwake

post the result here.



#8 Jason S.

Jason S.

    Neowinian Senior

  • Tech Issues Solved: 4
  • Joined: 01-September 03
  • Location: Cleveland, Ohio

Posted 13 November 2013 - 16:18

i also have this same problem. The system will sleep for 30-60 seconds then automatically wake up.

 

Changing the NIC wake options didnt help either. i'm at a loss. glad to hear im not the only one though!



#9 Lord Method Man

Lord Method Man

    Neowinian Senior

  • Tech Issues Solved: 1
  • Joined: 18-September 12
  • OS: Windows 8.1 Pro
  • Phone: Nokia Lumia 1520

Posted 13 November 2013 - 16:23

i also have this same problem. The system will sleep for 30-60 seconds then automatically wake up.

 

Changing the NIC wake options didnt help either. i'm at a loss. glad to hear im not the only one though!

 

What is causing it to wake? Did you run powercfg -lastwake ?



#10 OP IceBreakerG

IceBreakerG

    Local Ninja! Code Ninja That Is.

  • Tech Issues Solved: 1
  • Joined: 27-August 06
  • Location: Cordova, TN

Posted 14 November 2013 - 00:07

@MindTrickz: I just checked those settings and no dice.  I don't have anything plugged into the ethernet port as I'm just using wireless.  I checked the settings in power management that you have selected as well.  For the 2 Bluetooth Devices in device manager, they're using the standard Microsoft driver.  Also, the drivers from ASRock's website seem to be the manufacturer's drivers as well, they're just hosting them, and when I built the system a few weeks ago they were current (or appeared to be at least).  Here's a couple of screenshots from the event viewer, device manager and from running the powercfg command.

 

Edit: Also, in the UEFI menu, CPU C3, C6 and C7 State Support are all set to Auto.  Intel Rapid Start Technology is disabled, Intel Smart Connect Technology is enabled (it was previously disabled), Wake From Onboard LAN is disabled and Suspend to RAM is set to Auto.

 

EventAndDeviceMgr.png

 

EventViewer.PNG



#11 xendrome

xendrome

    In God We Trust; All Others We Monitor

  • Tech Issues Solved: 9
  • Joined: 05-December 01
  • OS: Windows 8.1 Pro x64

Posted 14 November 2013 - 00:16

Could be an issue with USB3, can you disable any USB3 options in the bios. If that fixes it, it's a BIOS update that needs to resolve it.

#12 tsupersonic

tsupersonic

    Neowinian Senior

  • Tech Issues Solved: 2
  • Joined: 30-September 06
  • Location: USA
  • OS: Win. 8.1 Pro. x64/Mac OS X
  • Phone: iPhone 5S/Nexus 5

Posted 14 November 2013 - 03:45

I had the same problem and it turned out to be Windows Media Center waking up the PC to to updates.  I know WMC is optional in Windows 8, but Something worth checking



#13 daorbed9

daorbed9

    Neowinian

  • Joined: 10-May 13
  • Location: NC

Posted 14 November 2013 - 04:07

Disable all startup and non-ms services and see if it still happens.  Also you are installing a bit of software from you ss.  If this doesnt fix it, try reinstall, and then sleep immediately inside windows, if it works add 1 driver at a time.  Keep internet unplugged or it will dl from windows update.

 

edit:  guys this is almost always software/driver related.



#14 Jason S.

Jason S.

    Neowinian Senior

  • Tech Issues Solved: 4
  • Joined: 01-September 03
  • Location: Cleveland, Ohio

Posted 14 November 2013 - 15:06

What is causing it to wake? Did you run powercfg -lastwake ?

didnt know that existed. i'll try to remember.



#15 Lord Method Man

Lord Method Man

    Neowinian Senior

  • Tech Issues Solved: 1
  • Joined: 18-September 12
  • OS: Windows 8.1 Pro
  • Phone: Nokia Lumia 1520

Posted 14 November 2013 - 15:24

Make sure to run it elevated.





Click here to login or here to register to remove this ad, it's free!