Jump to content



Photo

Surface 2 problem

winrt

  • Please log in to reply
6 replies to this topic

#1 Lord Method Man

Lord Method Man

    Neowinian Senior

  • Tech Issues Solved: 1
  • Joined: 18-September 12
  • OS: Windows 8.1 Pro
  • Phone: Nokia Lumia 1520

Posted 01 January 2014 - 01:34

My WiFi connection had Network Access, but not Internet Access, though all my other devices worked. I disconnected from my wireless network on the Surface 2 and after that there was no networks listed to connect to, and the wireless adapter was no longer listed in Device Manager.

 

I restarted. The "Restarting..." screen was up for about 10 minutes, until eventually I just had a black screen and no response to anything. I did a hard reset. Upon starting up I was given a BitLocker Recovery prompt and had to go to windows.microsoft.com/recoverykey and enter a very long string of digits in order to start my tablet. That was about a half hour ago, ever since then the screen has been stuck here:

 

28bgthw.png

 

PS: Neowin, IE11 has been out for how long now? Still can't paste anything into your text editor?




#2 Barney T.

Barney T.

    Debian Linux: I'm Loving It!

  • Tech Issues Solved: 3
  • Joined: 30-August 03
  • Location: Williamsburg, Virginia

Posted 01 January 2014 - 01:40

Per Technet:

 

PAGE_FAULT_IN_NONPAGED_AREA

Explanation:

This Stop message occurs when requested data is not found in memory. The system generates a fault, which normally indicates that the system looks for data in the paging file. In this circumstance, however, the missing data is identified as being located within an area of memory that cannot be paged out to disk. The system faults, but cannot find, the data and is unable to recover. Faulty hardware, a buggy system service, antivirus software, and a corrupted NTFS volume can all generate this type of error.

User Action:

This Stop message usually occurs after the installation of faulty hardware or in the event of failure of installed hardware (usually related to defective RAM, either main memory, L2 RAM cache, or video RAM). If hardware has been added to the system recently, remove it to see if the error recurs. If existing hardware has failed, remove or replace the faulty component. Run hardware diagnostics supplied by the system manufacturer. For details on these procedures, see the owners manual for your computer. Another cause of this Stop message is the installation of a buggy system service. Disable the service and determine if this resolves the error. If so, contact the manufacturer of the system service about a possible update. If the error occurs during system startup, restart your computer, and press F8 at the character-mode menu that displays the operating system choices. At the resulting Advanced Options menu, choose the Last Known Good Configuration option. This option is most effective when only one driver or service is added at a time. Antivirus software can also trigger this Stop message. Disable the program and determine if this resolves the error. If it does, contact the manufacturer of the program about a possible update. A corrupted NTFS volume can also generate this Stop message. Run Chkdsk /f /r to detect and repair disk errors. Restart the system before the disk scan begins on a system partition. If the hard disk is SCSI, check for problems between the SCSI controller and the disk. Finally, check the System Log in Event Viewer for additional error messages that might help pinpoint the device or driver causing the error. Disabling memory caching of the BIOS might also resolve it. For more troubleshooting information about this Stop message, refer to the Microsoft Knowledge Base at http://support.microsoft.com/support.

 

 

From the above, it seems that your memory is faulty and not addressing or paging properly. Your Surface can not load your OS properly from the SSD or other bootable device into memory and you are not booting up Windows normally. That would be my guess.



#3 jakem1

jakem1

    Neowinian Senior

  • Tech Issues Solved: 2
  • Joined: 17-November 06

Posted 01 January 2014 - 02:22

I've had this as well and seen reports of other people experiencing the same bsod on their surfaces. Apparently it's a firmware issue that MS are working on.

#4 OP Lord Method Man

Lord Method Man

    Neowinian Senior

  • Tech Issues Solved: 1
  • Joined: 18-September 12
  • OS: Windows 8.1 Pro
  • Phone: Nokia Lumia 1520

Posted 01 January 2014 - 02:52

After about an hour of 0% progress I did another hard reset and its back to normal now - using it to post this.



#5 psionicinversion

psionicinversion

    Neowinian Senior

  • Tech Issues Solved: 2
  • Joined: 16-June 05

Posted 01 January 2014 - 03:46

it could be an SSD problem if its the pro version not sure but i kniw its kind of unrelkated ive got 1 SSD and 2x HDD;s in my PC some times it boots up and says there no recogiseable drive/OS or whatveer, so i unplug my 2 HDD;s from the sata (dont do unplug the power just the data cabkles) so thr SSD is the only recognisable drive in system it boots up i plug the other 2 drives in recgnises and is all fine for a while. Prolly some sort of weird driver problem... thr ssd isnt faulty i think its the ability of the OS to recgnises it quick enough sometiumes

 

well or the bios, mines x58 and updated to latest bios ages ago dont exspect any mjore upgrades cus its old but works good so far, only thing that grinds my gears is unscrewing thre 1 screw out of my back case plate to expose the wires (had 2 but managed to lose 1 somewhere) take it off unplug it them and reattatch and then try manage to somehow pop em back in near enough place to close my case with out horizontalling it i can ususally do it soemtimes half assed efforf though



#6 OP Lord Method Man

Lord Method Man

    Neowinian Senior

  • Tech Issues Solved: 1
  • Joined: 18-September 12
  • OS: Windows 8.1 Pro
  • Phone: Nokia Lumia 1520

Posted 03 January 2014 - 21:37

Just happened again. I got home from work and tried to use my Surface 2. Black screen, wouldn't respond, Windows button gave vibration feedback when I touched it indicating it was in fact turned on, but no other response.

 

Did a hard reset, had to log in and get my Bitlocker recovery key again, then unlock the Surface, then get the :( bluescreen which never moved past 0%, then do another hard reset before being able to use it.

 

Not very impressed with this thing so far.



#7 +snaphat (Myles Landwehr)

snaphat (Myles Landwehr)

    Electrical & Computer Engineer

  • Tech Issues Solved: 29
  • Joined: 23-August 05
  • OS: Win/Lin/Bsd/Osx
  • Phone: dumb phone

Posted 04 January 2014 - 02:56

I had an internal usb wifi/bluetooth dongle that came with my Intel Mobo that would do that (same error) years ago. It seemed to be a hardware issue to me. I eventually just removed it. The fact that it is disappearing from being detected pretty much indicates either a firmware or hardware issue. I'd lean toward the latter.

 

EDIT:

 

That's to say it probably isn't memory, ssd, etc. I'm fairly sure it's the wifi chip if that's dropping from the system. You basically see the error when the adapter suddenly dropped and the driver is still trying to access now-not-available memory. To explain: drivers use memory mapped I/O which is mapped like so: virtual address->physical address of the device. The physical address should always be available and as such a page fault should never occur. When the adapter drops from the system and then the driver accesses the memory mapped I/O it would generate a page fault in that case. Since it is in a location that should never have page faults, Windows knows something is horribly wrong and BSODs.

 

In general, the same thing can occur for any sort of memory mapped I/O.





Click here to login or here to register to remove this ad, it's free!