Sign in to follow this  
Followers 0
jon86

Problem with RSS 'main page' feed

3 posts in this topic

I am trying to use an adesklet called newsfeed (which uses an RSS parser called feedparser) to show Neowin's main page RSS feed. When I try and display the feed, I get the following message from feedparser through the adesklet...

Error: document declared as us-ascii, but parsed as iso-8859-1

I posted the problem on the adesklets Forum and received a response from one of the core developers & desklet authors. He wrote a response containing the following...

This feed is ill-published; there is a RFC for specifying the interaction between HTTP and the encoding attribute of XML declaration within the document (RFC 3023). In this case, the MIME returned is text/xml, thus the encoding attribute of the XML declaration within the document is to be ignored completely. Since there is no encoding given in the charset parameter of the Content-Type HTTP header, the rule requires us to set the encoding to the default us-ascii, which is not compatible with the real content of the feed.

The original question and response can be found here...

http://adesklets.sourceforge.net/forum/vie...php?p=1134#1134

Is it possible to rectify this issue on Neowin's end?

Many thanks,

Jon

Share this post


Link to post
Share on other sites

We will probably have a fix for this soon :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.