Jump to content



Photo

Problem with RSS 'main page' feed


  • Please log in to reply
2 replies to this topic

#1 jon86

jon86

    Neowinian

  • Joined: 26-January 05

Posted 07 August 2005 - 19:47

I am trying to use an adesklet called newsfeed (which uses an RSS parser called feedparser) to show Neowin's main page RSS feed. When I try and display the feed, I get the following message from feedparser through the adesklet...

Error: document declared as us-ascii, but parsed as iso-8859-1


I posted the problem on the adesklets Forum and received a response from one of the core developers & desklet authors. He wrote a response containing the following...

This feed is ill-published; there is a RFC for specifying the interaction between HTTP and the encoding attribute of XML declaration within the document (RFC 3023). In this case, the MIME returned is text/xml, thus the encoding attribute of the XML declaration within the document is to be ignored completely. Since there is no encoding given in the charset parameter of the Content-Type HTTP header, the rule requires us to set the encoding to the default us-ascii, which is not compatible with the real content of the feed.


The original question and response can be found here...
http://adesklets.sou...php?p=1134#1134


Is it possible to rectify this issue on Neowin's end?

Many thanks,
Jon


#2 vetTim Dorr

Tim Dorr

    -1^0.5 of 53

  • Joined: 03-December 01
  • Location: Atlanta, GA

Posted 07 August 2005 - 19:57

We will probably have a fix for this soon :)

#3 OP jon86

jon86

    Neowinian

  • Joined: 26-January 05

Posted 07 August 2005 - 19:59

Great. Thanks. :D



Click here to login or here to register to remove this ad, it's free!