Jump to content



Photo

Windows XP x64 Uxtheme Patch


  • Please log in to reply
31 replies to this topic

#16 Xahid

Xahid

    Anokha Neowinian

  • Tech Issues Solved: 1
  • Joined: 04-November 01
  • OS: Windows 7 Ultimate

Posted 27 February 2006 - 09:10

Does themes also requred to be 64bit ?
sorry, after applying patch, all themes just show black n white, except Windows default theme!


#17 vetL3thal

L3thal

    Honor, Duty, Fidelity

  • Joined: 30-May 04
  • Location: New Jersey

Posted 27 February 2006 - 16:47

No, all themes done for XP SP2 work for me.

#18 jackc1990

jackc1990

    Neowinian

  • Joined: 27-February 06

Posted 15 April 2006 - 15:48

cant download it?

corrupt file.. any ideas.. need a new download link

#19 cyraxeon

cyraxeon

    Neowinian

  • Joined: 19-April 06
  • Location: Livin' on the Beach in CA

Posted 19 April 2006 - 03:01

i tried uxpatcher 5.0, neowin uxpatcher 4.0, and everything else i could find, i didnt want to run stylexp because i like to keep unneccesary software to a minimum (and its interface is just plain ugly). after nothing worked i installed stylexp, copied the uxtheme.dll from the system32 and syswow64 folders, uninstalled it and replaced the files with the ones i had copied.

Seems to be working for now.

heres my version of x64
Posted Image

feel free to try the files i have and let me know if it works:
x64uxTheme.zip

#20 cyraxeon

cyraxeon

    Neowinian

  • Joined: 19-April 06
  • Location: Livin' on the Beach in CA

Posted 19 April 2006 - 04:33

i tried uxpatcher 5.0, neowin uxpatcher 4.0, and everything else i could find, i didnt want to run stylexp because i like to keep unneccesary software to a minimum (and its interface is just plain ugly). after nothing worked i installed stylexp, copied the uxtheme.dll from the system32 and syswow64 folders, uninstalled it and replaced the files with the ones i had copied.

Seems to be working for now.

heres my version of x64
Posted Image

feel free to try the files i have and let me know if it works:
x64uxTheme.zip

ok so that didnt work after i restarted...

but i did get it to work eventually, i replaced the file on my webserver with the new one x64uxTheme.zip
YOU HAVE TO DO IT IN SAFE MODE!!! or it wont work... theres also a utility to disable file protection (not sure if its required... but i turned it off anyway)

#21 Fry.

Fry.

    Neowinian

  • Joined: 05-March 06

Posted 19 May 2006 - 04:53

Hey i have a question, how do you get to that "about windows" window, i've been searching for it but can't find it.

#22 r5a

r5a

    Neowinian

  • Joined: 06-October 05
  • Location: Toronto Ontario, Canada

Posted 13 February 2007 - 18:38

go to start > run.

type winver. hit okay.

#23 fiziks

fiziks

    Neowinian

  • Joined: 09-March 07

Posted 09 March 2007 - 14:07

I gather that this installer doesn't quite work.. to install uxtheme (modified, for x64):

1. reboot in safe mode
2. rename C:\WINDOWS\system32\uxtheme.dll to C:\WINDOWS\system32\uxtheme.old
3. copy modified uxtheme.dll (just extract the dll from this archive, ditch the installer) to system32 (there's also a uxtheme.dll in C:\WINDOWS\syswow64\, I don't think it's a good idea to touch this one)
4. restart normally and viola, navigate to deviantart.com visual styles and hack that shell

(one should know already but, to add visual styles; one must copy a .msstyles/.theme file to C:\WINDOWS\resources\themes\ and double click the .msstyle or .theme to activate it after files are placed in ...\themes\ ..don't forget to install the required fonts and such also)

theres also a utility to disable file protection (not sure if its required... but i turned it off anyway)

I left the file protection utility untouched, in safe mode it appears windows won't complain

Edited by fiziks, 09 March 2007 - 14:17.


#24 Slimy

Slimy

    Ars + Neowin

  • Joined: 04-April 04

Posted 19 March 2007 - 22:46

Since this is only for XP, anyone have a Vista one?

#25 TinFoil

TinFoil

    Resident One Post Wonder

  • Joined: 10-February 07

Posted 24 March 2007 - 18:59

It looks like XP x64 Service Pack 2 broke this one. Right now I'm stuck with Luna :(

#26 LVirus

LVirus

    Neowinian

  • Joined: 17-December 01

Posted 26 May 2007 - 21:41

I would like to know if there is patch for X64 SP2 OS .. please? :p

#27 saivert

saivert

    Resident One Post Wonder

  • Joined: 02-September 06

Posted 12 August 2007 - 01:11

Please update the batch script to reflect this:
@echo Installing patched uxtheme.dll 
ren %windir%\system32\uxtheme.dll uxtheme.old
del %windir%\ServicePackFiles\i386\uxtheme.dll
copy /b /y uxtheme.dll %windir%\system32\uxtheme.dll
copy /b /y uxtheme.dll %windir%\system32\dllcache\uxtheme.dll
pause

This works on all systems, even systems where windows is not installed in c:\windows.
Try to write proper batch scripts and clean them of all your personal **** like "rem deltree..." etc..
I know the /b option for copy isn't really necessary but it's the proper way to do it when you are handling binary files.

Tip: For far better installers try NSIS

Another tip: If you just want something else that looks more decent than the standard **** of a theme Microsoft bundles with their fat OS, fetch Royale Noir theme and unpack in %windir%\resources\themes (see the %windir% thing I just did there? I think you get it). Oh and you need something that can unpack 7z archives. 7-zip will do that just fine (and bonus: It's a really nice and fast archive program).

Edited by saivert, 12 August 2007 - 01:18.


#28 NiceCarpet

NiceCarpet

    <3 !_! ##

  • Joined: 22-April 04
  • Location: Auckland, New Zealand
  • OS: Windows 7
  • Phone: Samsung Galaxy SII

Posted 06 January 2008 - 03:02

Thanks : D

Just moved to 64bit XP
(It feels really sad when shutting down your 32bit OS from the last time its like moving day : < )

#29 swarfega

swarfega

    da cleaner

  • Joined: 26-June 06
  • Location: UK

Posted 12 July 2008 - 21:03

Is this just for XP?

#30 InsaneDP

InsaneDP

    Neowinian

  • Joined: 11-April 09

Posted 11 April 2009 - 08:57

Has anybody found a working patch for XP x64 SP2?

Right now Im stuck using Zune. :x