Jump to content



Photo

Why all folders Read Only (greyed)?


  • Please log in to reply
6 replies to this topic

#1 terrypin

terrypin

    Neowinian

  • Joined: 18-October 04

Posted 20 October 2006 - 08:44

Why do all my folders have a grey check mark in the Read Only box of Properties please? And when I remove it, and apply it to all files/subfolders, why does it return to that state?

It doesn't make sense to me anyway, because I can delete files from these folders, and add files to them!

Hope someone can explain please?

--
Terry, West Sussex, UK


#2 +allan

allan

    Neowinian Senior

  • Joined: 01-February 04
  • Location: New Jersey, USA

Posted 20 October 2006 - 11:41

That grey blob is - well - it's just a grey blob. I've been dealing with this question since XP was first released and there doesn't seem to be any intelligent explanation. Regardless, the folders are not read only and that blob doesn't seem to mean anything. Don't worry about it.

#3 +BudMan

BudMan

    Neowinian Senior

  • Tech Issues Solved: 92
  • Joined: 04-July 02
  • Location: Schaumburg, IL
  • OS: Win7, Vista, 2k3, 2k8, XP, Linux, FreeBSD, OSX, etc. etc.

Posted 20 October 2006 - 12:24

No intelligent explanation?

http://support.microsoft.com/kb/326549
You Cannot View or Change the Read-Only or System Attribute of Folders

Unlike the Read-only attribute for a file, the Read-only attribute for a folder is typically ignored by Windows, Windows components and accessories, and other programs. For example, you can delete, rename, and change a folder with the Read-only attribute by using Windows Explorer.

A simple google for this finds LOADS of info about it.. A green square is normal what explorer shows for folders Read Only attrib..

readonly.png

If you have changed your theme, why sure it might be different.. In a nutshell - windows does not use the read only attribute for folders.. That green square is explorers way of telling you that, and is normal.

Or what SP/ OS are you using?? Is this what your seeing?
trimode.png

That is the tri-mode flag, again lots of explanations of this from a simple google.. Again - normal operations.

As I was saying -- they changed the tri-mode flag to be a green square.. Because people were confused about the gray checkmark.. Windows does not use the read only attrib on folders.. and will show the green sqaure, or gray colored checkmark, etc..

Could it be explained better.. Maybe ;) But there is plenty of info about it - if you look.

Since windows does not really use the read only attrib on folders.. What would you have them display there?? blank -- then people would see that is NOT read only, and how would you toggle the files under to not read only then? Or if they put a check mark.. how would you mark the sub files as read only..

Think of it as a method to allow the user to change the read attrib of files under the folder, etc..

Edited by BudMan, 20 October 2006 - 12:59.


#4 +allan

allan

    Neowinian Senior

  • Joined: 01-February 04
  • Location: New Jersey, USA

Posted 20 October 2006 - 12:32

I'm aware of that article. The blob has no significance nor does it indicate "read only". On the contrary, XP uses a "check mark" to indicate when an attribute box has been selected. To the best of my knowledge that blob is an anomaly that MS has never explained.

#5 ozgeek

ozgeek

    Neowinian Senior

  • Tech Issues Solved: 1
  • Joined: 08-June 03
  • Location: Queensland, Australia

Posted 20 October 2006 - 12:59

I believe the blob means some files in a specific folder has read-only applied where as others in the same file do not have read-only applied. There are some files that you cannot remove read-only from. That's why when you uncheck the read-only box and apply it, when you come back, it is ticked. Same goes for hidden.

#6 +allan

allan

    Neowinian Senior

  • Joined: 01-February 04
  • Location: New Jersey, USA

Posted 20 October 2006 - 13:07

I believe the blob means some files in a specific folder has read-only applied where as others in the same file do not have read-only applied. There are some files that you cannot remove read-only from. That's why when you uncheck the read-only box and apply it, when you come back, it is ticked. Same goes for hidden.

Nope. All folders have that blob. Try it yourself - create a folder and put one file in it with standard attributes.

#7 +BudMan

BudMan

    Neowinian Senior

  • Tech Issues Solved: 92
  • Joined: 04-July 02
  • Location: Schaumburg, IL
  • OS: Win7, Vista, 2k3, 2k8, XP, Linux, FreeBSD, OSX, etc. etc.

Posted 20 October 2006 - 13:08

And I have told you why this is.. How else would you toggle the attrib of the files underneath the folder?? They have to put something there, and the green blob is less confusing that the the grey checkmark ;)