Jump to content



Photo

XP reserves 20% of your Bandwidth


  • Please log in to reply
2 replies to this topic

#1 Binary

Binary

    Proud to be Canadian

  • 2,427 posts
  • Joined: 19-October 01
  • Location: Canada
  • OS: OS X 10.9 & Windows 8 (iMac 2012). Mobile: iOS7 (iPhone 5S & iPad Mini Retina), Android 4.2 & WebOS (TouchPad).

Posted 30 November 2001 - 05:13

Hi dont know if this has been mentiond before or not but it's good to know anyhow.



Apparently the QoS service reserves 20% of your bandwidth for other applications, so no one app is able to be used to its full ability.



Read Here:

http://www.theregist...nt/4/23090.html



Here's the tweak to change it to whatever level you want:



http://www.tweakxp.c...play.asp?id=282



And for those who dont want to be sidetracked here's the tweak:









Increase available bandwidth for network connections



Written By: BigBrother 11/20/2001





This will help increase your bandwidth for any network connection.



1. Make sure your logged on as actually "Administrator". do not log on with any account that just has administrator privileges. To log in as an administrator:

-click on start->logoff->logoff

-in the logon screen hold Ctrl+Alt+Del.

-in the user field type 'Administrator' <-case sensitive.

-in the password field type the password for the administrator (if you don't have one leave blank)

-press ok



2. Start - run - type gpedit.msc

3. Expand the "local computer policy" branch

4. Expand the "administrative templates" branch

5. Expand the "network branch"

6. Highlight the "QoS Packet Scheduler" in left window

7. In right window double click the "limit reservable bandwidth" setting

8. On setting tab check the "enabled" item

9. Where it says "Bandwidth limit %" change it to read 0-- Click apply, OK, exit gpedit.msc

10. Go to your Network connections (start->my computer->my network connection-> view network connections). Right click on your connection, choose properties then under the General or the Networking tab (where it lists your protocols) make sure QoS packet scheduler is enabled.

11. Reboot , now you are all done.



This is more of a "counter what XP does" thing. In other words, XP seems to want to reserve 20% of the bandwidth for itself even with QoS disabled. So why not use it to your advantage. To demonstrate the problem, start up a big download from a server with an FTP client. Try to find a server that doesn't max out your bandwidth. In this case you want a slow to medium speed server to demonstrate this. Let it run for a couple of minutes to get stable. The start up another download from the same server with another instance of your FTP client. You will notice that the available bandwidth is now being fought over and one of the clients download will be very slow or both will slow down when they should both be using the available bandwidth. Using this "tweak" both clients will have a fair share of the bandwidth and will not fight over the bandwidth.



:D



Chris


#2 Daniel F.

Daniel F.

    Deputy Head

  • 9,793 posts
  • Joined: 10-July 01
  • Location: UK
  • OS: Windows 8
  • Phone: Android 4.2.2

Posted 30 November 2001 - 10:38

thanks for the info, but its already in tweak section

#3 Z3r0

Z3r0

    Neowinian

  • 966 posts
  • Joined: 27-November 01

Posted 30 November 2001 - 10:40

oh, that's why I got 61.6kilobytes/s of 64kilobytes/s today.... :)