Jump to content



Photo

Force the deletion of a "file in use"


  • This topic is locked This topic is locked
35 replies to this topic

#1 Elliot B.

Elliot B.

    Over 13 years on Neowin

  • Tech Issues Solved: 4
  • Joined: 16-August 01
  • Location: West Midlands, UK
  • OS: Windows 8.1
  • Phone: Samsung Galaxy S5

Posted 24 January 2009 - 02:58

When trying to delete a file on my computer, I get an error message stating, "The action can't be completed because the file is open in System".

I've tried deleting it in Safe Mode, deleting whilst the explorer.exe process was ended and tried using Unlocker, all fail.

Any ideas?

eb_openinsystem.jpg


#2 seta-san

seta-san

    Neowinian Senior

  • Joined: 17-February 05

Posted 24 January 2009 - 03:05

why don't you try to unmounting it out of magiciso.... it's an icon in bottom left hand corner next to the time.

#3 agreenbhm

agreenbhm

    Technofiend

  • Joined: 13-December 06
  • Location: Raleigh, NC

Posted 24 January 2009 - 03:09

why don't you try to unmounting it out of magiciso.... it's an icon in bottom left hand corner next to the time.



lol

#4 OP Elliot B.

Elliot B.

    Over 13 years on Neowin

  • Tech Issues Solved: 4
  • Joined: 16-August 01
  • Location: West Midlands, UK
  • OS: Windows 8.1
  • Phone: Samsung Galaxy S5

Posted 24 January 2009 - 03:12

why don't you try to unmounting it out of magiciso.... it's an icon in bottom left hand corner next to the time.

I do not have MagicISO installed. Mate, I have 14,520 posts, don't treat me like an idiot.

#5 agreenbhm

agreenbhm

    Technofiend

  • Joined: 13-December 06
  • Location: Raleigh, NC

Posted 24 January 2009 - 03:16

I do not have MagicISO installed. Mate, I have 14,520 posts, don't treat me like an idiot.


rofl. You don't have MagicISO? Then why does it say "MagicISO document"? If you had uninstalled the program, it would show it as an unknown file type, or it would be listed as another document type (if you had another ISO capable reading utility installed).

And just for the record, number of posts does not equal intelligence.

#6 OP Elliot B.

Elliot B.

    Over 13 years on Neowin

  • Tech Issues Solved: 4
  • Joined: 16-August 01
  • Location: West Midlands, UK
  • OS: Windows 8.1
  • Phone: Samsung Galaxy S5

Posted 24 January 2009 - 03:17

rofl. You don't have MagicISO? Then why does it say "MagicISO document"? If you had uninstalled the program, it would show it as an unknown file type, or it would be listed as another document type (if you had another ISO capable reading utility installed).

And just for the record, number of posts does not equal intelligence.

This is Windows. We all know file extensions don't always correct themselves after a program un-installation. Believe me when I say MagicISO is not installed.

And to add to that record, you're correct. However, it does suggest I have a basic lack of Windows-based intelligence at the minimum!

#7 sundayx

sundayx

  • Joined: 27-October 04
  • Location: Hong Kong

Posted 24 January 2009 - 03:20

The 'System' is accessing the file, not MagicISO.

#8 agreenbhm

agreenbhm

    Technofiend

  • Joined: 13-December 06
  • Location: Raleigh, NC

Posted 24 January 2009 - 03:21

a basic lack of Windows-based intelligence


?

But for the topic at hand, idk. Usually rebooting solves that, so you're SOL. Maybe boot up with BartPE and delete it?

#9 MR_Candyman

MR_Candyman

    Neowinian Senior

  • Joined: 16-April 03

Posted 24 January 2009 - 03:21

hmm...I do a lot of windows bashing, but even I have to say I've never seen an instance of file extension associations not clearing properly.

Even so, you sure it's not mounted?

#10 OP Elliot B.

Elliot B.

    Over 13 years on Neowin

  • Tech Issues Solved: 4
  • Joined: 16-August 01
  • Location: West Midlands, UK
  • OS: Windows 8.1
  • Phone: Samsung Galaxy S5

Posted 24 January 2009 - 03:23

?

But for the topic at hand, idk. Usually rebooting solves that, so you're SOL. Maybe boot up with BartPE and delete it?

You forgot 'at the minimum' in your quote, don't make me sound foolish.

I'll give BartPE a try (Y)

hmm...I do a lot of windows bashing, but even I have to say I've never seen an instance of file extension associations not clearing properly.

Even so, you sure it's not mounted?

Positive.

In this instance, the mounting portion of MagicISO didn't fare too well in this build of Windows 7, so that would explain the ext. association problem this time round.

#11 redvamp128

redvamp128

    Neowinian Senior

  • Joined: 06-October 01

Posted 24 January 2009 - 03:27

I am not running Win7 or Vista but I have ran into that issue before on XP-- check to see if for example it has it loaded up in the cache for the Cd burning. This is not meant to give an insult- It should be in the My computer on a Cd and or DVD burner-- a right click on it should tell you if files there are awaiting burning.

You could maybe get more info about what is holding the file up by using this program. (Haven't tested it or known a test on Win7) though worth a shot.

http://technet.micro...s/bb896653.aspx

#12 Snowl

Snowl

    ‮i wasted 10 seconds of your time

  • Joined: 01-December 08
  • Location: Australia.

Posted 24 January 2009 - 03:27

EDIT my bad :|

#13 OP Elliot B.

Elliot B.

    Over 13 years on Neowin

  • Tech Issues Solved: 4
  • Joined: 16-August 01
  • Location: West Midlands, UK
  • OS: Windows 8.1
  • Phone: Samsung Galaxy S5

Posted 24 January 2009 - 03:28

Unlocker. search for it.

You clearly didn't read my short post, did you? :|

#14 seta-san

seta-san

    Neowinian Senior

  • Joined: 17-February 05

Posted 24 January 2009 - 03:29

take out everything in the startup folder in the start menu and do "msconfig" and disable everything in the startup list then reboot and try to remove the iso.

#15 Cavalyr

Cavalyr

    Neowinian

  • Joined: 06-September 04
  • Location: Killeen, TX

Posted 24 January 2009 - 03:29

Unlocker. was just gonna say that one as well. best little tool i use.