Neowin Forums currently being upgraded

Neowin is currently upgrading its forums to Invision Power Board 3. During this time, the forums will be inaccessible. This upgrade started at 8:30 GMT, and we expect it to continue well into tonight. By tomorrow morning, we expect that our upgrade will be complete, and service returned to normal.

Here’s just a few things you can expect to see once we come back:

  • Karma: If you find a post helpful, you can "like" it in the same way you can like a news post on the front page.
  • Favourite Forums: Click the heart icon next to a forum to set that forum as a favourite. Any forum you mark as a favourite will appear at the top of the board index.
  • Full page spy: This page allows you to watch everything that happens on Neowin. It offers a full page view of the "Latest Forum Activity" feature our users have enjoyed for years, with the addition of new front page comments into the mix.
  • Conversations: Private messages are now formatted so you can easily look back on an exchange of messages between you and another user. It's similar to how Gmail handles email conversations.

During this upgrade, you will be able to join our Neowin IRC network - for more details, please see this page.

Thank you all for your patience on this matter - this upgrade has been a long one, and we really hope that the fixes we made will keep the forums up permanently this time.

Update (10:30pm GMT): After a few issues with getting the database backed up (It was causing load on the MySQL server used for the News, hence the issues you may have seen with the front page) we have now begun the running of the upgrade script. Estimated time remaining, around 5 hours (roughly, it may be more, we need to check that we really have fixed the previous load issues). Thanks for your patience everyone! - Dave

Update 2 (3:50am GMT): The forum upgrade script is now complete. We just need to install the skins, and edit a few settings, make sure everything's working, and then we're good to go. Shouldn't be more than an hour longer, all being well. - Dave

Update 3 (10:00am GMT): There's a few bugs with the skins that we are working on. The server load is fine but we want to work out all the bugs before we put the forums online again.

Report a problem with article
Previous Story

Google Wave gets permissions, and more

Next Story

Adobe Flash 10.1 allows private browsing

368 Comments

Commenting is disabled on this article.

Decaytion said,
That video is... WIN.

Yeah, its very cool with one-take planned videos like that.

But isn't this the original video?
http://www.youtube.com/watch?v=-zcOFN_VBVo

Yes! Yes! Yes! Awesome news! Great work devs and all staff at Neowin. Can't wait for it to finally to come online and for us to be able to use all the new features of the beast that Neowin is!

Cannot get 'spy' to work.

[#1076] Sorry, but you do not have permission to use this feature. If you are not logged in, you may do so using the form below if available.

To me the frontpage keeps on changing width every 30/60 seconds. Pretty dizzying most so when you try to type a comment and the page is suddenly half the the size and your comment box disappeared

Now the forums are completely inaccessible. Baffling since the forums performed just fine during the test.

robertwnielsen said,
Well, it WAS online for me, for about a half-hour. Now, I try to log into the forums, and I get a "Neowin Driver Error" page come up.

same. as well as too busy error.

Edited by linsook, Jan 22 2010, 5:49pm :

Spotted the "We're back online (again)" topic and figured we had lift off, but apparently "We're back offline again".

20 hours-ish since it started, man that's blown the original ETA out of the window.

Oh well, some of us do have a life and a living to earn rather than waiting around for most of the day.

Hope the bugs get sorted sooner rather than later.

Another update would be nice though.

Its starting to head towards 24 hours, and I imagine ad revenue will start to become an issue again..

Cyteen said,
Why do I need to allow googleapis.com in noscript to let the menu's work properly?

They are probably linking to Googles copy of Jquery (more likely to be cached, I use their hosted version on my own sites). In theory it makes the page load quicker.

I'm not going to request the forums back, but at least give us a fourth update in this piece of news :p

With Regard to that video..... Some people have way too much time on their hands.....

On a more related note, AWESOME! Glad the forums are still being upgraded! I figured it was a total no-go after the first run melted everything. Nice job Neowin! Seriously, u guys don't get paid enough for this kind of hassle! :-p But you handled it all with honor. Nice job.

Keep up the good work and "May the Force Be With You All" Que the imperial march song... lol

Cool Blackeye Pea Remix video posted in article!!! :)

So glad that the server load looks good currently. I know the front page has an issue, where when I set my color and banner, and leave the page and return it goes back to default, I assume you guys are aware of that and its one of your "bugs with skins" being worked on.

SMELTN said,
So glad that the server load looks good currently. I know the front page has an issue, where when I set my color and banner, and leave the page and return it goes back to default, I assume you guys are aware of that and its one of your "bugs with skins" being worked on.

I thought that was a problem at my work, didn't know others were having the same problem! Exactly the same happening to me.

SMELTN said,
So glad that the server load looks good currently. I know the front page has an issue, where when I set my color and banner, and leave the page and return it goes back to default, I assume you guys are aware of that and its one of your "bugs with skins" being worked on.

I suspect the skin bug with the post edit box being completely screwed up is a bit more important than a bit of bling. ;)

SMELTN said,
So glad that the server load looks good currently. I know the front page has an issue, where when I set my color and banner, and leave the page and return it goes back to default, I assume you guys are aware of that and its one of your "bugs with skins" being worked on.

Are you blocking cookies?

I have a similar problem, Ive set my banner but now carnt change itl. The changes appear to have been made however when i visit Neowin again its stuck on my previous banner.

Wannes said,
How is this update evolving?

Congratulations! Your Finity evolved into Ignition!

Ignition is trying to learn AtlasIPB3, but it already knows 4 moves. Delete a move to learn AtlasIPB3?

- Yes
- No

Chasethebase said,

Congratulations! Your Finity evolved into Ignition!

Ignition is trying to learn AtlasIPB3, but it already knows 4 moves. Delete a move to learn AtlasIPB3?

- Yes
- No

Ahaha, nice. The memories!

Chasethebase said,

Congratulations! Your Finity evolved into Ignition!

Ignition is trying to learn AtlasIPB3, but it already knows 4 moves. Delete a move to learn AtlasIPB3?

- Yes
- No

Rofl, nice one :p

Chasethebase said,

Congratulations! Your Finity evolved into Ignition!

Ignition is trying to learn AtlasIPB3, but it already knows 4 moves. Delete a move to learn AtlasIPB3?

- Yes
- No


LOL. Comment of the year.

Chasethebase said,

Congratulations! Your Finity evolved into Ignition!

Ignition is trying to learn AtlasIPB3, but it already knows 4 moves. Delete a move to learn AtlasIPB3?

- Yes
- No


Hahahaha... :D

I'm glad to hear that the team persevered after the load problems from last time. You guys are bringing the coding skills for sure :). And 12+ hours of work = hardcore.

-Himanshu- said,
Any ETA? It's been down for nearly 4 hours. :(
For those who sleep at night in the GMT zone it has bee longer than 4 hours, more like ~14

vanx said,
For those who sleep at night in the GMT zone it has bee longer than 4 hours, more like ~14

No, it was online for something like 3 hours but was taken offline again.

-Himanshu- said,

No, it was online for something like 3 hours but was taken offline again.

At the time of this post, it's been offline for 7 hours. BUT, the devs are working like crazy to fix most, if not all the bugs in the forum to make it nothing short of perfect. Give the guys space to work their magic, im sure we will be pleasantly surprised when they come back up :)

-Himanshu- said,

No, it was online for something like 3 hours but was taken offline again.
vanx knows that. He's just saying that for those of us who slept last night in the GMT zone (and similar time zones) were asleep when the forum was up for 3 hours, so to us, it seems like the forum has been down for ~14 hours (actually, it's roughly 16 hours).

Edited by Lee G., Jan 22 2010, 1:46pm :

As much as I like things to be working right and not having bugs, I am also fond of an idea of high availability. Were concepts of clustering and replication ever up for consideration to be implemented?

All you guys have to do now is fix IE bugs.
Scrolling with IE while having the pointer over the comments area will lag the eff outta it... try it out for yourself.

EddiePwnsYou said,
All you guys have to do now is fix IE bugs.
Scrolling with IE while having the pointer over the comments area will lag the eff outta it... try it out for yourself.
oh that's why it was lagging. LOL ))) Yep, major headache with scrolling while having mouse over comments.

EddiePwnsYou said,
All you guys have to do now is fix IE bugs.
Scrolling with IE while having the pointer over the comments area will lag the eff outta it... try it out for yourself.

same on firefox :)

EddiePwnsYou said,
All you guys have to do now is fix IE bugs.
Scrolling with IE while having the pointer over the comments area will lag the eff outta it... try it out for yourself.

No lag for me. Scrolling works perfect and smooth.

-Himanshu- said,

No lag for me. Scrolling works perfect and smooth.

But, yes it lags in IE. But doesn't lag for me in FF.
Using IE 8 and FF 3.6.

-Himanshu- said,

But, yes it lags in IE. But doesn't lag for me in FF.
Using IE 8 and FF 3.6.

It does lagg a bit on FireFox. You just need an Atom to experience it.

good luck, i had a brief look at the new forum on the first attempt and i was very impressed.

Thanks for the effort being put into the project.

Deacon Brown said,
As I can't get IRC at work is there one for the iphone I could use?

Just so i can get my daily dose of topics from you guys lol?


Colloquy is the best one :)

Well, I wish Neowin could be wealthy enough to have redundant test servers. This upgrade could have been done on test servers, check out the load and correct bugs before putting everything into production.

Oh well, I hope everything goes smoothly and that the forum will work soon!! Keep up the good work! Sleep well! :)

TruckWEB said,
Well, I wish Neowin could be wealthy enough to have redundant test servers. This upgrade could have been done on test servers, check out the load and correct bugs before putting everything into production.

Oh well, I hope everything goes smoothly and that the forum will work soon!! Keep up the good work! Sleep well! :)

They would be if people would subscribe!

TruckWEB said,
Well, I wish Neowin could be wealthy enough to have redundant test servers. This upgrade could have been done on test servers, check out the load and correct bugs before putting everything into production.
They have test servers, Subs tested Atlas two weeks before the release. But load can't be tested correctly with no traffic...

NienorGT said,
They have test servers, Subs tested Atlas two weeks before the release. But load can't be tested correctly with no traffic...

oh yes it can, there's something called load testing ;)

XerXis said,

oh yes it can, there's something called load testing ;)

They actually did load tests, although I'm not partial to the exact details it didn't flag up any problems.

DomZ said,

They actually did load tests, although I'm not partial to the exact details it didn't flag up any problems.

I'm sure they did the best they could, they are volunteers and neowin doesn't have a limitless budget to test things :)

LacusMD said,
I think he's dead since the last upgrade :)

There was an 'accident' which reset his post count... effectively killing Rappy..... ;)

R.I.P.

hardgiant said,
still offline hours later....so much for a 6 hour upgrade. I love it when a plan comes together.

It was up for a hour or two

After all the chaos is over it'd be nice to re-implement the toggle for collapsing the board stats box at the bottom.

FloatingFatMan said,
Am I the only one who prefers the old skin? No offence, but the new on is kinda ugly....

I still ike the older one, but the newer one is nicer.
Everyone has their own opinions. Lets just hope they port the Finity theme back to the forums which I doubt will every happen.

FloatingFatMan said,
Am I the only one who prefers the old skin? No offence, but the new on is kinda ugly....

I much prefer the new one I find it also looks more professional.

Calum said,

I much prefer the new one I find it also looks more professional.

Perhaps, but the old one was kinder on my eyes with font sizes etc, and when the forum was up for a bit earlier, i was getting some messed up layouts with the reply boxes (I made a thread on it under Site Issues).. If that's something that continues once the upgrade is properly done, it's going to make using the forums very problematic for me... :(

FloatingFatMan said,

Perhaps, but the old one was kinder on my eyes with font sizes etc, and when the forum was up for a bit earlier, i was getting some messed up layouts with the reply boxes (I made a thread on it under Site Issues).. If that's something that continues once the upgrade is properly done, it's going to make using the forums very problematic for me... :(


That won't continue, it's a bug. We fix bugs.

Tom W said,

That won't continue, it's a bug. We fix bugs.

Oh I know that! But not having seen anyone else report it, I presume the problem is only affecting me until more people report it. ;)

I know other than in the comments there is no official announcement of the forums being live, but old quotes need some fixing (quotes from pre-update show in a post message like normal text a person typed out) and they need to port Darkside to the forums.

Seriously, Darkside -> Forums, GoGoGo!

Annoying having two completely different themes between the forums and the main page.

Nagisan said,
I know other than in the comments there is no official announcement of the forums being live, but old quotes need some fixing (quotes from pre-update show in a post message like normal text a person typed out) and they need to port Darkside to the forums.

Seriously, Darkside -> Forums, GoGoGo!

Annoying having two completely different themes between the forums and the main page.

Darkside (and all the color options) will be available once the forums are set up. And I believe quotes/bbcode might be broke for a few days, they have to run an update script in the background to trundle through and convert them all

omganinja said,
forum skins dont match news skins :(

Default is IPB skin which is what you're seeing. I was able to switch to Atlas a little bit ago. :P

Edited by Xilo, Jan 22 2010, 5:50am :

omganinja said,
forum skins dont match news skins :(

Once the site is back up, you'll be able to choose the skin from the drop down menu. It will match the front page web site :)

Xilo said,

Default is IPB skin which is what you're seeing. I was able to switch to Atlas a little bit ago. :P

Yeah i know... forum atlas doesn't match the news atlas....

Edited by omganinja, Jan 22 2010, 6:49am :

omganinja said,

Where's darkside?

What's also kind of strange is that they went with a fixed with front page and a fluid width forum page, meaning that the 'scenes' won't work on the forum.

Stetson said,

What's also kind of strange is that they went with a fixed with front page and a fluid width forum page, meaning that the 'scenes' won't work on the forum.


Most people seem to prefer the fluid layout, so because it's easy to implement on IPB 3, the developers chose to do so. It would not have worked on the main page because of how the contend is laid out.

It's always best to go for what the majority want, if it's possible.

I personally would prefer a fixed width layout on the forums as well, but it isn't what the majority want, so I accept that and will think about creating a Stylish script to display what I would like to see.

trek said,
Back to IPB skin?

wait, you'll see IP.Boards, click on the drop down. You'll see the rest. I guess they are fixing user permissions.

Manmohanjit Singh said,

wait, you'll see IP.Boards, click on the drop down. You'll see the rest. I guess they are fixing user permissions.

yeah, thanks. saw that chooser thinngy after the post. They gotta set the default one i guess.

I was wondering myself how much it hurts them to keep doing this. However I think we all know going forward it's for the best!!!

Tarrant64 said,
I was wondering myself how much it hurts them to keep doing this. However I think we all know going forward it's for the best!!!
Probably not that bad. A majority of forum-goers are going to understand what is going on. They are able to keep the news page up and running which is where a majority of there less-experienced readers hang around (not saying news-readers are less-experienced in general, but anyone coming here from other sites to read the news posts are less likely to visit the forums and be affected by their downtime).

Edited by Nagisan, Jan 22 2010, 5:31am :

I bet we're having the same effect as a DDoS - all of us refreshing the forums page to see if it's ready must be hell for the servers :P

Glad to see things are working out. I've been a reader of Neowin for a pretty long time. Although I just registered a few days ago (seeing the site update motivated me to join). Kudos to the whole team for working on the project so hard.

omganinja said,
Link to wallpaper in VM please? (sans label)

I posted it in the forum a while a go, so it should be in the wallpaper section.

warwagon said,

I posted it in the forum a while a go, so it should be in the wallpaper section.

I'll just go check the forums, OH WAIT

Markus-J said,

...and I just can't hide it..


I'm about to lose control
And I think I like it.

http://www.youtube.com/watch?v=h-LbvFckptY

Edited by crispkreme, Jan 22 2010, 2:45am :

crispkreme said,

I'm about to lose control
And I think I like it.

http://www.youtube.com/watch?v=h-LbvFckptY

haha, good song is good

soniqstylz said,
I bet if you just deleted all of rappy and audioboxer's posts, it'd only take about an hour and a half.

+1
lol

soniqstylz said,
I bet if you just deleted all of rappy and audioboxer's posts, it'd only take about an hour and a half.

LOL +1

I've got a feeling that tonight's gonna be a good night :P
Good luck, hope it all turns out well - I need my forums fix! >:)

Great job team! Can't wait to see full product.
Neowin.net is now working properly on my machine so I'm writing this from my blackbery! See you tomorrow with. Good night (2:40AM)

Video added: when I get excited, I always turn to bad music. Hope it gets you guys pumped like it does for me. If it doesn't, don't hate on me! :P

virtorio said,
Any reason why the text doesn't zoom (yet the layout does) in Safari any more?

If you're using OS X Snow Leopard, remember you get full screen zoom. If you're on Windows though.. No clue.

jamesyfx said,

If you're using OS X Snow Leopard, remember you get full screen zoom. If you're on Windows though.. No clue.


I know. Just annoying, as it was working before and it works in other browsers.

thefonz said,
This makes me happy. But why does my profile picture not appear? <<

Because the avatars are loaded from the forums, which are now being upgraded and therefore temporarily unavailable.

Edited by Steven P., Jan 21 2010, 10:58pm :

SHoTTa35 said,
Good luck! Can't wait for Atlas! "Atlas-ish" filled the void but only for so long. :)
Atlas-ish is a joke compared to the real thing. I used it once, and quickly switched back to Finity.

Strike X said,
How did you managed to sort it out?
It is server upgrade ??
It was a misconfiguration in Apache that was causing the IP.B cache to not build.

Someone in the last neowin news post mentioned that if the cache isn't building completley/not at all, it will cause the high load. Seems they get the cookie, even if it was a lucky guess.

cybertimber2008 said,
It was a misconfiguration in Apache that was causing the IP.B cache to not build.

Someone in the last neowin news post mentioned that if the cache isn't building completley/not at all, it will cause the high load. Seems they get the cookie, even if it was a lucky guess.

It wasn't that ;)

DaveLegg said,

It wasn't that ;)

Apologies, I stand corrected. Well, it was noted you would post about the fix after the upgrade no?

/me wonders why my post disappeared this is a repost.

cybertimber2008 said,

Ok well I stand corrected You guys did at least say "we'll post about it after the upgrade" right?

They will be doing that :)

DaveLegg said,

It wasn't that ;)

Dave nice to see you and the team resolved the problem, nice to see the forum back. IPB 3 is probably one of the best IPS have created since the dawn of IPB what... 8 or 9 years ago. awesome job with the forum design and style.

10/10 for effort and finding the fault. great job.

rm20010 said,
Oi, most of our avatars are missing. :P

Shame the annoying staff members aren't...

Edited by DaveLegg, Jan 21 2010, 9:08pm :

Neobond said,
Damn just heard the babes thread has been lost :(
What babes thread? Don't think we allow babes threads on Neowin.

Neobond said,
Damn just heard the babes thread has been lost :(
I guess there's no more reason to subscribe ;)

Neobond said,
Damn just heard the babes thread has been lost :(

Haha you funny :P. But seriously, when is the forum going to be back up so I can check the babe thread?

Neobond said,
Damn just heard the babes thread has been lost :(

Are you saying this is the price we have to pay?

WTF!!! Bring back IPB 2 again! ;)

neufuse said,
what exactly does Spy do again?

Shows (in realtime I believe) the latest forum posts and news comments

I miss having the Spy thing at the top of the page. I don't want to have to click to a separate page for it. Can we have both...?

crazzy88ss said,
I miss having the Spy thing at the top of the page. I don't want to have to click to a separate page for it. Can we have both...?
You will have both. The full spy is supplementary.

MR_Candyman said,
I, personally, prefer the mini feed of latest forum activity. I doubt I would go to the spy page to see the latest...

The mini feed is still available at the top :)

Capric0rn said,

The mini feed is still available at the top :)

Even when you're browsing a forum? When the forum was up previously with IPB3, I noticed the mini spy only showed up when on the forum index.

Edited by Xilo, Jan 21 2010, 9:53pm :

Xilo said,
Even when you're browsing a forum? When the forum was up previously with IPB3, I noticed the mini spy only showed up when on the forum index.

They turned off features to try and keep the load down - I believe it will be there now it's fixed.

Yea it was already stated that the ipb3 we saw wasnt complete. They have a hacked up version of it ready to go with the spy sitting back on top where we all like it. Among others things we never got to see.

Xilo said,
Never noticed there was a like button on front page articles... lol
Yeah, it's new. Is starting to catch on though.

Yes! The favorite forum thing is a great idea! I was going to suggest something similar which involved custom re-arranging, but I thought it was impossible. So cool.

Good luck, guys! I'm sure we'll find out more details about the previous issues once the upgrade has completed this time :)

Kirkburn said,
Good luck, guys! I'm sure we'll find out more details about the previous issues once the upgrade has completed this time :)

:)

I think one of the issues on the last update was that I received an email every time someone posted in a subbed thread/topic rather than my default of only once per visit. This meant that (with regard mainly to the old update thread) I was getting 60 or 70 new post notifications. This is bad for server loads I would assume and not good for my inbox, which was inundated with thread update messages :(

That said I hope all goes well this time (y)

BeLGaRaTh said,
I think one of the issues on the last update was that I received an email every time someone posted in a subbed thread/topic rather than my default of only once per visit. This meant that (with regard mainly to the old update thread) I was getting 60 or 70 new post notifications. This is bad for server loads I would assume and not good for my inbox, which was inundated with thread update messages :(

That said I hope all goes well this time (y)


You never know, that might have been one of the things fixed. *fingers crossed*