Jump to content



Photo

Apostrophes destroy my words


  • Please log in to reply
7 replies to this topic

#1 PyX

PyX

    Neowinian Senior

  • Joined: 20-December 03

Posted 22 September 2012 - 02:25

Hey guys,

Since Mac OS X 10.8.2, I have a huge problem with my apostrophes. Not the apostrophe that stays as is, but the type that gets transformed automatically by OS X into another apostrophe character.

Say I’m chatting into Facebook for example, and I’m writing "j’ai" (I have in French) followed by a spacebar, my text cursor suddenly JUMPS to the letter after the apostrophe and I’ll continue to type like this : "j’afaimi" (should be "j’ai faim" / I’m hungry)

It’s always happening, it gets on my NERVES !

I have :
- Installed the combo updater
- Reset my PRAM
- Fixed my permissions
- Ran the daily/monthly/yearly OS X maintenance scripts

I’m out of ideas. Anyone ? :(


#2 PsyOpWarlord

PsyOpWarlord

    Geek with Guns

  • Joined: 16-December 01
  • Location: Colorado Springs, CO
  • OS: OS X Mavericks 10.9.3
  • Phone: iPhone 5 - iOS 7.1.1

Posted 22 September 2012 - 03:40

I've tried and I can't create the issue when typing. I even turned off all my extensions in safari but it never jumps back like your experiencing. I've also never seen a setting that would account for this.

Sorry.

#3 Farstrider

Farstrider

    The Clash

  • Joined: 16-March 03
  • Location: Somerset West, Cape Town, SA
  • OS: Arch Linux

Posted 22 September 2012 - 03:51

I've tried and I can't create the issue when typing. I even turned off all my extensions in safari but it never jumps back like your experiencing. I've also never seen a setting that would account for this.

Sorry.


There appears to be a different issue that you are having, the words "you are" and "you're" seems to change to "your"! :rolleyes:

#4 what

what

    Neowinian Senior

  • Joined: 04-December 06
  • Location: Kent, England

Posted 22 September 2012 - 11:17

There appears to be a different issue that you are having, the words "you are" and "you're" seems to change to "your"! :rolleyes:

Wow, good spot sir!

#5 OP PyX

PyX

    Neowinian Senior

  • Joined: 20-December 03

Posted 22 September 2012 - 13:22

I think it has to do with character substitutions in System Preferences. I haven't changed anything though since 10.8.2, and I have no extensions in Safari... Now that I have it turned off, it seems to work.

Thing is, when I type an apostrophe in the address bar for example, it leaves the character alone and everything's right. On the Facebook chat, it changes my apostrophe into another one and then my cursor jumps.

#6 OP PyX

PyX

    Neowinian Senior

  • Joined: 20-December 03

Posted 24 September 2012 - 12:02

Eur..
I don't know what to say
But thanks


Well thanks for the input, it's highly appreciated.

#7 shall_i_cut

shall_i_cut

    Touch me if you dare

  • Joined: 27-August 12
  • Location: Philippines
  • OS: Windows 8.1, Windows 7, Android 4.2.1
  • Phone: O+ 8.91

Posted 24 September 2012 - 12:05

I think its a Facebook thing

#8 .Neo

.Neo

    Generic User

  • Joined: 14-September 05
  • Location: Amsterdam, NL
  • OS: OS X Mavericks
  • Phone: iPhone 5s

Posted 24 September 2012 - 12:58

Can't replicate your issue. Not even on Facebook. :/