Sign in to follow this  
Followers 0
Krome

login problem Guild Wars 2 Help

2 posts in this topic

Hi guy.

I am shocked and desperate for answer. I need someone to tell me what is going on to my Guild Wars 2 account.

Today, when I started the client, I play the game normally and then there was an update. After the game client finish update, I logged in, and the game client ask me that it is "Important" to change my password. So I change my password. Then I logged in and play. Went to eat so I went afk a tiny bit and perhaps logged out. Then later on I log in and play again. Do a few events here and there. Then I went on to World versus World. Too busy trying to help out so I don't chat much. After a while, game kicked me out. I end up at a random location in Cursed Shore. I log back in. Game seems lagging somewhat. Everyone is not lagging. I can move around and everyone moves around. But the skill itself, when I activate, it just stalls. It would not work. That is the kind-of-lag-that-isn't-a-lag experience I got. I log out and log back in to hopefully fix the problem. This time it works fine. So I que myself back into WvW. Again, I got kicked out. I log back in and then que myself back in WvW. Again, I got kicked out. I log back in for the third time, I got kicked out of WvW for the third time. The fourth time I try to log in, I get this:

post-956-0-21265000-1350140348_thumb.png

Can someone tell me what is wrong with that. I try to log back in my master account, it says wrong password or account has been locked out.

My computer is very secure. I do not have any third-party that hook itself to Guild Wars 2. I log in my Guild Wars account, it worked fine but not Guild Wars 2.

I beg if anyone know something, or give me a hint on what to do to fix this problem, I owe you big time. Thank you guys. I really needed your help on this.

Share this post


Link to post
Share on other sites

ok sorry guys... it seems weird but after a few minutes, I try to log in again, this time I can log in... I didn't see any of my gold missing... so I think it is ok...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.