Sign in to follow this  
Followers 0

win7 Please help - Externel Drive acting weird

1 post in this topic


Hey Neowin,

My home server died after a power outage. I had 3 drives die on me. My Windows drive, Family drive and my pagefile drive (not too worried about this one). I had made back-ups...locally and well after the OS drive died so did my RAID so all my drives now show up as offline and with a red X in drive management. I had made a backup on October 29th, 2012 onto an external drive. When I tried to restore using the recovery console Windows would see the image on the drive but all attempts to actually copy date to my drives failed so I was forced to buy 3 new drives and reinstall windows. As it stands I've lost all my family photos and I urgently want to get them back from the stupid external drive. This drive is about 3 years old. I see it has 3 .vhd images one is 365 GB which is the one that has all my family photos on and I desperatly want to get it off that drive but copying it fails. Using drive management to attach the VHD fails as well. I can open the drive on my computer and see the contents but when I try copying anything off the drive just spins and stops, the little red activity light flashes blue and red then stops at red and I have to turn the external off and back on. I have tried putting the external drive into my other computer that has a hot swap bay and my computer sees the drive in Drive managment but its got no drive letter and shows up as 456 GB free. I dont know what to do I'm just so worried. Any help would be great. I have also tried doing a check disk and it just stops, no activity on the hard drive. I can feel it vibrate though so it's not dead. Any suggestions?

Thank you!

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.