Sign in to follow this  
Followers 0

Samsung Galaxy S3 MMS over Wi-fi Question

12 posts in this topic

Posted

Ok, so I am able to get the text that says I have an MMS message when I am on wifi, however, i cannot download it, which is fine. BUT why does my phone not give me a notification and vibrate like other text messages? It is annoying to not know I have a new message even though after someone else sends me an SMS I can see that in my text message folder it shows that there are 2 unread messages and the other message is always a MMS from someone else. So, if the phone can process that i got a new message why wont it vibrate so I can then turn on my 4G and download the message?

So, my question is, how do I get a text notification for MMS when I am on wifi and not on 4G?

Share this post


Link to post
Share on other sites

Posted

It took me a while to find a second device to try this with, but I contacted someone and asked them to send me an MMS, making sure that I was only connected to my Wifi in the house. I received a sound, a vibration and a notification, and was also able to view the message without disconnecting from my Wifi.

So for the moment I would say that there is a setting that you haven't selected under your options, but I need to look in to that a bit more first. (Y)

EDIT: Having done a quick search, check the settings under your messaging app. Have you got your MMS messages set to auto-retrieve? If not, try turning it on and doing a test.

Share this post


Link to post
Share on other sites

Posted

Ok, so I am able to get the text that says I have an MMS message when I am on wifi, however, i cannot download it, which is fine. BUT why does my phone not give me a notification and vibrate like other text messages? It is annoying to not know I have a new message even though after someone else sends me an SMS I can see that in my text message folder it shows that there are 2 unread messages and the other message is always a MMS from someone else. So, if the phone can process that i got a new message why wont it vibrate so I can then turn on my 4G and download the message?

So, my question is, how do I get a text notification for MMS when I am on wifi and not on 4G?

Use Whatapp: http://www.whatsapp.com

Share this post


Link to post
Share on other sites

Posted

It took me a while to find a second device to try this with, but I contacted someone and asked them to send me an MMS, making sure that I was only connected to my Wifi in the house. I received a sound, a vibration and a notification, and was also able to view the message without disconnecting from my Wifi.

So for the moment I would say that there is a setting that you haven't selected under your options, but I need to look in to that a bit more first. (Y)

EDIT: Having done a quick search, check the settings under your messaging app. Have you got your MMS messages set to auto-retrieve? If not, try turning it on and doing a test.

yes, i have always had it on auto retrieve and it doesnt work :( i did just check turn on MMS Alert which alerts when mode changes to MMS. I dont know if that will work but i am going to do a test now.

Share this post


Link to post
Share on other sites

Posted

i dont want to use that, i just want my phone to be able to notify me when I have a new MMS message and need to turn on mobile data to download it.

Share this post


Link to post
Share on other sites

Posted

MMS' works in the way that the phone gets an SMS notifying it you have an MMS. depending on the phone/software, when data is off it will either notify you you have an MMS to download and say you can't download it, or give you one of those web links to download the MMS in a browser.

So as long as your notifications are correctly set up, you should get a notification of having an MMS waiting for you. being on WiFI or not won't affect the MMS at all since it doesn't use WiFi at all for MMS'. they are only downloaded through data.

Share this post


Link to post
Share on other sites

Posted

Are you disabling mobile data? As long as your 3G is on (you can disable 4G/LTE) it should download a MMS.

SMS will work as long as your cellular connection is on (so it will work on roaming or with data disabled), but MMS needs a cellular data connection. MMS doesn't work on wifi-only (without other apps).

When you have both wifi and mobile data on, it should switch on mobile long enough to get the MMS. I do remember the HTC Hero had a bug where it didn't, and it was later fixed in a OTA. Haven't heard of that on a GS3 though...

Share this post


Link to post
Share on other sites

Posted

MMS' works in the way that the phone gets an SMS notifying it you have an MMS. depending on the phone/software, when data is off it will either notify you you have an MMS to download and say you can't download it, or give you one of those web links to download the MMS in a browser.

So as long as your notifications are correctly set up, you should get a notification of having an MMS waiting for you. being on WiFI or not won't affect the MMS at all since it doesn't use WiFi at all for MMS'. they are only downloaded through data.

Are you disabling mobile data? As long as your 3G is on (you can disable 4G/LTE) it should download a MMS.

SMS will work as long as your cellular connection is on (so it will work on roaming or with data disabled), but MMS needs a cellular data connection. MMS doesn't work on wifi-only (without other apps).

When you have both wifi and mobile data on, it should switch on mobile long enough to get the MMS. I do remember the HTC Hero had a bug where it didn't, and it was later fixed in a OTA. Haven't heard of that on a GS3 though...

Ok, so when I have mobile data AND wifi on, everything works fine and it switches to mobile data to download the message and i get a notification and its like a normal text, i do not need to go to the message and hit download because it automatically downloads it. BUT If i have mobile data off and ONLY wifi it does not give me a notification that I have a MMS message waiting for me that i need to download, so i do NOT know that I need to turn on mobile data, go to the message app, click the thread with a new message, and hit download so I can see the message.

Share this post


Link to post
Share on other sites

Posted

Try turning off automatic download of MMS.

Share this post


Link to post
Share on other sites

Posted

Try turning off automatic download of MMS.

is that the same as auto-retrieve? or is there a special one for MMS only?

Share this post


Link to post
Share on other sites

Posted

that should be it, SMS' will always auto retrieve I believe.

Share this post


Link to post
Share on other sites

Posted

that should be it, SMS' will always auto retrieve I believe.

IT WORKS NOW! YAY! YOURE A GENIUS I LOVE YOU!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.