Jump to content



Photo

BSOD on wake from sleep

win7

  • Please log in to reply
7 replies to this topic

#1 Lord Method Man

Lord Method Man

    Neowinian Senior

  • Tech Issues Solved: 1
  • Joined: 18-September 12
  • OS: Windows 8.1 Pro
  • Phone: Nokia Lumia 1520

Posted 30 December 2012 - 02:06

Hey, I have a three year old secondary PC that I just recently started using again after about a year in storage. I did a clean reinstall of Windows 7 x64 a few days ago. Now that I have everything set up for use I'm getting BSODs every time I wake the PC from sleep. I need some help tracking down the culprit.

Here are some details:

Problem signature:
Problem Event Name: BlueScreen
OS Version: 6.1.7601.2.1.0.256.1
Locale ID: 1033
Additional information about the problem:
BCCode: f4
BCP1: 0000000000000003
BCP2: FFFFFA8007E73B30
BCP3: FFFFFA8007E73E10
BCP4: FFFFF80002D84460
OS Version: 6_1_7601
Service Pack: 1_0
Product:

I'm also attaching the minidump file to this post as I don't have the software necessary to decode them. I'm hoping someone here can help with it.

[attachment=323906:122912-61308-01.zip]


#2 Hum

Hum

    totally wAcKed

  • Tech Issues Solved: 5
  • Joined: 05-October 03
  • Location: Odder Space
  • OS: Windows XP, 7

Posted 30 December 2012 - 02:11

Check and reseat your RAM and video card.

Reseat hard drive cables, or replace them.

Update the chip set drivers, and video driver.

Do you have a sound card ? Reseat, update.

Do you have a wifi card inside the case ? Reseat, update.

#3 OP Lord Method Man

Lord Method Man

    Neowinian Senior

  • Tech Issues Solved: 1
  • Joined: 18-September 12
  • OS: Windows 8.1 Pro
  • Phone: Nokia Lumia 1520

Posted 31 December 2012 - 18:28

Checked all my connections and drivers. I have a feeling that it's my Logitech Gaming Software that's doing it. Their 8.xx drivers have always been glitch as hell when it comes to waking from sleep. The minidump file says it could be caused by wininit.exe which probably leads to LCore.exe

#4 Detection

Detection

    Detecting stuff...

  • Joined: 30-October 10
  • Location: UK
  • OS: 7 SP1 x64

Posted 31 December 2012 - 18:38

Are the relevant power saving features enabled in the BIOS too ?

S1 & S3 are ones I remember, I believe there are more too, I have a vague memory of a similar problem with one of my old machines and that was the cause

#5 yowanvista

yowanvista

    Neowinian Senior

  • Tech Issues Solved: 3
  • Joined: 19-February 10
  • Location: Mauritius
  • OS: Windows 8.1 Pro 64-Bit
  • Phone: i9001-CM11-KitKat 4.4.4 - Kernel 3.4.96

Posted 31 December 2012 - 18:59

I'm seeing I/O errors in the dump file, it's a common issue with some SSDs, especially OCZ drives with problematic controllers. You might want to upgrade the firmware/AHCI driver if you have an SSD. Disable any power saving utilities and set your power option to "High Performance'. Install Windows on a regular HDD to see if that also causes BSODs. Test your SSD/HDD with any utilities such as SeaTools

Update your Realtek RTL8168D/8111D Family PCI-E Gigabit Ethernet NIC driver (Rt64win7.sys):
http://www.realtek.c...3&GetDown=false

CRITICAL_OBJECT_TERMINATION (f4)
A process or thread crucial to system operation has unexpectedly exited or been
terminated.
Several processes and threads are necessary for the operation of the
system; when they are terminated (for any reason), the system can no
longer function.
Arguments:
Arg1: 0000000000000003, Process
Arg2: fffffa80072a0b30, Terminating object
Arg3: fffffa80072a0e10, Process image file name
Arg4: fffff80002d85460, Explanatory message (ascii)

Debugging Details:
------------------


PROCESS_OBJECT: fffffa80072a0b30

IMAGE_NAME:  csrss.exe

DEBUG_FLR_IMAGE_TIMESTAMP:  0

MODULE_NAME: csrss

FAULTING_MODULE: 0000000000000000

PROCESS_NAME:  csrss.exe

EXCEPTION_CODE: (NTSTATUS) 0xc0000006 - The instruction at 0x%p referenced memory at 0x%p. The required data was not placed into memory because of an I/O error status of 0x%x.

BUGCHECK_STR:  0xF4_IOERR



#6 PrEzi

PrEzi

    Neowinian

  • Joined: 26-June 07

Posted 31 December 2012 - 19:09

Update your drivers, and I mean :
-chipset
-ethernet/networking
-gpu
-audio

If it doesn't help - BIOS and firmware (if any e.g. SSD) too.

#7 OP Lord Method Man

Lord Method Man

    Neowinian Senior

  • Tech Issues Solved: 1
  • Joined: 18-September 12
  • OS: Windows 8.1 Pro
  • Phone: Nokia Lumia 1520

Posted 31 December 2012 - 19:12

I'll try the Ethernet driver next. I just updated my BIOS which I was unaware would default back to IDE mode; I switched it back to AHCI but now my SATA drives are not appearing as removable drives anymore. I'm currently doing a full format on a 1 TB external drive that hasn't been working so once that's finished I'll get back to troubleshooting.

#8 OP Lord Method Man

Lord Method Man

    Neowinian Senior

  • Tech Issues Solved: 1
  • Joined: 18-September 12
  • OS: Windows 8.1 Pro
  • Phone: Nokia Lumia 1520

Posted 01 January 2013 - 22:18

Updated drivers, still does it.

I went ahead and did a reformat + fresh install of Win 7 and incrementally tested it after installing each device. It seemed to work up until I installed the latest NVidia video card drivers, after that I got a BSOD on wake again.

It could be a coincidence and that I was just lucky with my previous tests even though I sleep/woke it at least twice for each test as it doesn't do it every time, but close (~75%).

My next step is going to be installing old NVidia drivers and see how that works.