Jump to content
Sign in to follow this  
Followers 0

IP Board 3.4


23 posts in this topic

Posted

Request: I think it would be nice if you guys (Neowin) upgraded to IP. Board 3.4. It has a lot of new features and functionality. I tried it and it is not buggy.
1 person likes this

Share this post


Link to post
Share on other sites

Posted

Neowin doesn't wanna upgrade becuase of the mods they have for 3.2 :(

I do agree though. It's gotten much better. Also adds mobile mod controls and it's much faster as well.
1 person likes this

Share this post


Link to post
Share on other sites

Posted

[quote name='remixedcat' timestamp='1357811869' post='595444438']
Neowin doesn't wanna upgrade becuase of the mods they have for 3.2 :(

I do agree though. It's gotten much better. Also adds mobile mod controls and it's much faster as well.
[/quote]

They will probably upgrade sometime this year. But wait, there mods would stay where they are. IP. Board keeps everything the way it is when you upgrade to a new version. I've owned multiple forums and they were all running IP. Board and when I upgraded to the latest version, all my mods were still there.

Share this post


Link to post
Share on other sites

Posted

[quote name='Kamran Mackey' timestamp='1357812114' post='595444444']
They will probably upgrade sometime this year. But wait, there mods would stay where they are. IP. Board keeps everything the way it is when you upgrade to a new version. I've owned multiple forums and they were all running IP. Board and when I upgraded to the latest version, all my mods were still there.
[/quote]

Some hooks have issues, however my upgrades all have ran smoothly though.

Share this post


Link to post
Share on other sites

Posted

We are going to upgrade but we're waiting for a few bug fix releases first

Share this post


Link to post
Share on other sites

Posted

[quote name='Redmak' timestamp='1357812257' post='595444448']
We are going to upgrade but we're waiting for a few bug fix releases first
[/quote]

Which ones?

Share this post


Link to post
Share on other sites

Posted

Well, the latest IP. Board is 3.4.1. And I believe they released a security update not too long ago to fix a security issue. What's the latest version you guys are using now anyway?

Share this post


Link to post
Share on other sites

Posted

Until this list is a bit shorter http://community.invisionpower.com/resources/bugs.html/_/ip-board/

We may upgrade when 3.4.2 is released

Share this post


Link to post
Share on other sites

Posted

[quote name='Kamran Mackey' timestamp='1357812437' post='595444458']
Well, the latest IP. Board is 3.4.1. And I believe they released a security update not too long ago to fix a security issue. What's the latest version you guys are using now anyway?
[/quote]

Mine's been done patched for a while now and I also applied the editor patch as well.....

Share this post


Link to post
Share on other sites

Posted

[quote name='remixedcat' timestamp='1357812495' post='595444462']
Mine's been done patched for a while now and I also applied the editor patch as well.....

[/quote]
[quote name='Redmak' timestamp='1357812487' post='595444460']
Until this list is a bit shorter [url="http://community.invisionpower.com/resources/bugs.html/_/ip-board/"]http://community.inv...tml/_/ip-board/[/url]

We may upgrade when 3.4.2 is released
[/quote]

Well, 3.4.2 should be released very soon. And thats great to hear remixedcat.
1 person likes this

Share this post


Link to post
Share on other sites

Posted

[quote name='Kamran Mackey' timestamp='1357812114' post='595444444']
They will probably upgrade sometime this year. But wait, there mods would stay where they are. IP. Board keeps everything the way it is when you upgrade to a new version. I've owned multiple forums and they were all running IP. Board and when I upgraded to the latest version, all my mods were still there.
[/quote]

Most of our mods aren't (and can't be) done through hooks, we have to edit a lot of the source files for IP.Board itself (there's over 200 modifications we have to make) to provide the functionality we use here.

Share this post


Link to post
Share on other sites

Posted

Why can't you do it with hooks??

Share this post


Link to post
Share on other sites

Posted

wow, that's a lot of modifications

Share this post


Link to post
Share on other sites

Posted

[quote name='remixedcat' timestamp='1358017929' post='595449978']
Why can't you do it with hooks??
[/quote]
A lot of what we do changes existing functionality, rather than extending it. Also, there aren't hook points at every location in the code where we need to do things. On top of that, hooks themselves are problematic on a multi-server setup without modifications to make them work.

Share this post


Link to post
Share on other sites

Posted

How would hooks have trouble with multiserver setups??

Share this post


Link to post
Share on other sites

Posted

if i remember correctly they had already talked about when they were going to upgrade and what functionality they were not planning on using.

Share this post


Link to post
Share on other sites

Posted

[quote name='remixedcat' timestamp='1358019295' post='595450010']
How would hooks have trouble with multiserver setups??
[/quote]
Hooks themselves don't, but the process that enables and disables them causes issues if we don't have one of our mods in place

Share this post


Link to post
Share on other sites

Posted

Have you tested these on a test board and how have your results been?

Share this post


Link to post
Share on other sites

Posted

In case anyone hasn't noticed, 3.4.2 is out now.

Share this post


Link to post
Share on other sites

Posted

[quote name='Lirodon' timestamp='1359067777' post='595477264']
In case anyone hasn't noticed, 3.4.2 is out now.
[/quote]
We've noticed. :)
1 person likes this

Share this post


Link to post
Share on other sites

Posted

We (~5m post since 2007) upgraded from 3.2.3 to 3.4.1 about a month ago and ever since then I get daily complaints about the rich text editor slicing link URLs, not encoding unicode characters properly, quote and code blocks not working properly, lack of button-based BBcode editor, etc etc

They've backported the 3.4.2 RTE fixes back to 3.4.1 but it's still not quite there. In hindsight, we probably should've waited too.

Share this post


Link to post
Share on other sites

Posted

[quote name='muggerfugger' timestamp='1359068667' post='595477290']
What ever happen to neowin creating its own forum script? i read you guys were going to do this a year or so ago?

Might be alot easier than redoing lines and pages of edits each time IPB is updated.
But then again it'd be hard to come up with something as nice as ipb.
[/quote]

Was codenamed IF, so IF was a big IF

Anyway 3.4 update along with [i]more[/i] is coming soon. We're working on it.
1 person likes this

Share this post


Link to post
Share on other sites

Posted

Do you got a working install of your custom script? I'd love to see it!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.