Jump to content



Photo

Kim Dotcom's new Mega storage service is live


  • Please log in to reply
99 replies to this topic

#16 George P

George P

    Neowinian Senior

  • 18,736 posts
  • Joined: 04-February 07
  • Location: Greece
  • OS: Windows 8.1 Pro 64bit
  • Phone: HTC Windows Phone 8X

Posted 19 January 2013 - 19:28

Well I can't even go to the main site it seems unless this thing has some ****ty requirement to use chrome or something.


#17 Lee G.

Lee G.

    Neowinian Senior

  • 10,393 posts
  • Joined: 28-October 04
  • Location: London, UK
  • OS: Windows 8.1

Posted 19 January 2013 - 19:30

Well I can't even go to the main site it seems unless this thing has some ****ty requirement to use chrome or something.


If you're not using Chrome it gives you a warning saying that you that you are using an 'outdated browser'. You can tell it not to show the warning again though, and as far as I can see the site functions fine using Firefox.

#18 +Xinok

Xinok

    Resident Reresident

  • 3,494 posts
  • Joined: 28-May 04
  • Location: Shikaka
  • OS: Windows 7 x64
  • Phone: Galaxy S3 (Wicked)

Posted 19 January 2013 - 19:45

According to the service, files are encrypted locally before being uploaded to the server and they never know the encryption keys. A few cloud backup services, including SpiderOak, BackBlaze, and CrashPlan have similar security, except that you must provide them with your password in order to download files from the web client. Wuala is an exception, but it runs as a Java applet in your browser which is how it handles the local decryption of files.

So a simple question: How does Mega handle the local encryption and decryption of files when uploading and downloading?

#19 xendrome

xendrome

    In God We Trust; All Others We Monitor

  • 7,311 posts
  • Joined: 05-December 01
  • OS: Windows 8.1 Pro x64

Posted 19 January 2013 - 19:51

URL is timing out. How is Kimble going to start his "Get out of Jail" fed-honeypot if you guys can't sign up and put your IP in his logs and illegal warez in his datatubes?

#20 ady199

ady199

    Neowinian

  • 447 posts
  • Joined: 25-October 01

Posted 19 January 2013 - 19:53

It must be getting hammered at the moment - I managed to register in seconds and activated my account without any issues but I've now tried to upload some PDFs (5 in total, sizes ranging from 495kb to 45mb) but its just sitting there and just says pending - its been like that now for 5 minutes

#21 +OOOOOOOO

OOOOOOOO

    Neowinian Senior

  • 2,348 posts
  • Joined: 21-September 04

Posted 19 January 2013 - 19:57

Brilliant ... except all effing day it's been down. Pretty bad advertisement for a cloud hosting company :D

#22 Guth

Guth

    Alba Gu Bráth

  • 803 posts
  • Joined: 30-December 05
  • Location: Scotland
  • OS: Windows 8 Pro
  • Phone: iPhone 5

Posted 19 January 2013 - 20:00

http://thenextweb.co...fe/?fromcat=all

Look at the image he posted, MegaMovie with the caption "MPAA lets talk" hahaha this guy is nuts.
Looks like they are going to start movie streaming (legit i guess. probably. maybe.) :laugh:
Posted Image

#23 Deleted Bye

Deleted Bye

    Neowinian Senior

  • 3,781 posts
  • Joined: 17-June 09

Posted 19 January 2013 - 20:02

Brilliant ... except all effing day it's been down. Pretty bad advertisement for a cloud hosting company :D

For a free service that will get hammered by millions of people in the first day, this has been 100% expected by most.

#24 Timan

Timan

    Fade Away...

  • 9,860 posts
  • Joined: 21-October 01
  • Location: Virginia, USA

Posted 19 January 2013 - 20:02

Posted Image

This is what I find funny, no servers in usa lol

#25 Nothing Here

Nothing Here

    Neowinian Senior

  • 2,164 posts
  • Joined: 23-February 08
  • Location: California, U.S.A.
  • OS: Windows 8 Pro / Kororaa 17

Posted 19 January 2013 - 20:04

Very slow to reg right now.

#26 2xSilverKnight

2xSilverKnight

    Neowinian Master

  • 2,087 posts
  • Joined: 07-August 01

Posted 19 January 2013 - 20:09

Looks like there are servers in Canada

#27 ady199

ady199

    Neowinian

  • 447 posts
  • Joined: 25-October 01

Posted 19 January 2013 - 20:10

Well I cancelled the 5 file upload and tried just to upload 1 489kb pdf file - Its just been sitting there for the last 15 minutes with a status of 'pending'

#28 Nothing Here

Nothing Here

    Neowinian Senior

  • 2,164 posts
  • Joined: 23-February 08
  • Location: California, U.S.A.
  • OS: Windows 8 Pro / Kororaa 17

Posted 19 January 2013 - 20:12

After 15 mins my reg still hasn't gone through............ Just went through. :p

Edit:
Now it tells me that my pass is wrong. Then I get Oops! Something went wrong!

Edit2:

No issues now. But I'm confused about this:

To strengthen the key, we have collected entropy from your mouse movements and keystroke timings.

Can someone explain what this means please? Thanx.

#29 ady199

ady199

    Neowinian

  • 447 posts
  • Joined: 25-October 01

Posted 19 January 2013 - 20:21

Well I cancelled the 5 file upload and tried just to upload 1 489kb pdf file - Its just been sitting there for the last 15 minutes with a status of 'pending'


Well if this is a sign of things to come, I'm not impressed - I've been trying to upload a 489kb pdf file as a test for the last 25 minutes and its still showing the upload status as pending :crazy:

#30 Deleted Bye

Deleted Bye

    Neowinian Senior

  • 3,781 posts
  • Joined: 17-June 09

Posted 19 January 2013 - 20:21

Well I can't even go to the main site it seems unless this thing has some ****ty requirement to use chrome or something.

or it could be this:

Posted Image[color=#000000 !important]Kim Dotcom[/color][color=#999999 !important]@KimDotcom[/color]

[font=Georgia, Palatino, serif !important]
Wow. I have never seen anything like this. From 0 to 10 Gigabit bandwidth utilization within 10 minutes.
[/font]


Well if this is a sign of things to come, I'm not impressed - I've been trying to upload a 489kb pdf file as a test for the last 25 minutes and its still showing the upload status as pending :crazy:


Posted Image[color=#000000 !important]Kim Dotcom[/color][color=#999999 !important]@KimDotcom[/color]

[font=Georgia, Palatino, serif !important]
Wow. I have never seen anything like this. From 0 to 10 Gigabit bandwidth utilization within 10 minutes.
[/font]