Jump to content



Photo

NVIDIA GeForce 314.22 WHQL Drivers

nvidia gpu drivers geforce notebook desktop whql

  • Please log in to reply
3 replies to this topic

#1 Avi

Avi

    Neowinian

  • 1,143 posts
  • Joined: 01-September 03
  • Location: Tel-Aviv, Israel

Posted 26 March 2013 - 13:05

http://www.geforce.com
http://www.geforce.c...rivers-released

Lots of speed gains in games.
I could quote it all, or you could just enter the link... :p


#2 spikey_richie

spikey_richie

    There's no place like 127.0.0.1

  • 2,342 posts
  • Joined: 02-February 05
  • Location: Nuneaton, UK
  • OS: Windows 8.1 Pro 64-bit
  • Phone: Sony Xperia Z1

Posted 26 March 2013 - 13:07

Nice.

Be sure to set your PhysX processor back to your primary GPU rather than 'Auto-select' to prevent the annoying driver hanging issue.

#3 +LogicalApex

LogicalApex

    Software Engineer

  • 5,863 posts
  • Joined: 14-August 02
  • Location: Philadelphia, PA
  • OS: Windows 7 Ultimate x64
  • Phone: Nexus 5

Posted 26 March 2013 - 13:45

Nice.

Be sure to set your PhysX processor back to your primary GPU rather than 'Auto-select' to prevent the annoying driver hanging issue.


Is this issue specific to this driver version? As I use it on Auto-Detect so Physx uses my GTX 260 secondary leaving breathing room on my GTX 580 primary.

#4 spikey_richie

spikey_richie

    There's no place like 127.0.0.1

  • 2,342 posts
  • Joined: 02-February 05
  • Location: Nuneaton, UK
  • OS: Windows 8.1 Pro 64-bit
  • Phone: Sony Xperia Z1

Posted 26 March 2013 - 13:47

I only have 1x GTS 450 and then a 2700k which has a GPU. I found if I left the drivers as auto, I'd get unresponsive notifications and lock-ups. Setting it to the GTS 450 prevents it. Have a few friends with single cards who have had the same issue, and the fix has worked for them too.



Click here to login or here to register to remove this ad, it's free!