Sign in to follow this  
Followers 0
wiggly1uk2000

Windows 7 (build 7000) making my router go nuts!

59 posts in this topic

Oops, forgot to answer the question! Yes, I'm in the UK - picking up from the Tacolneston trasmitter. What about the rest of you guys?

Hi :)

I pick up the Winter Hill transmitter here (North West UK) and my Freeview TV card is the Hauppauge Nova-T PCI (had it a couple of years now and has worked well in Media Centre in Vista).

I've checked my listings and am getting the Freeview Channel "Dave" and it's assigned channel number 19 in Media Centre. I've had a quick scan through the listings and as far as I can tell, all the usual channels I get around here are in the Media Centre line up.

As I type this message in at the forum I've been watching the LED on my Netgear Internet connection going crazy and all I'm doing is watching the BBC News 24 channel via Media Centre! : (

Share this post


Link to post
Share on other sites

Beta testing - it's a tough job but somebody's gotta do it! :D

Seriously though, we know MS are aware of this problem now. It's great to see them posting on this forum. Hopefully a fix will be available soon.

Share this post


Link to post
Share on other sites

Thanks guys, I'll get in touch with the media centre product group and make sure they are aware of this issue affecting UK users.

Please bear in mind that given this is a beta they may not be able to produce an "out-of-band" fix for this issue and it may have to wait until the next public Windows 7 release. It'll be up to the product group to make that decision.

I'll post any updates around this issue here if appropriate.

Share this post


Link to post
Share on other sites

Thanks willg... hopefully MS will release a fix as we may well end up with a whole lot of unhappy ISPs on our backs for breaching fair usage policy!

Like everyone else on this forum, my router is permanently maxed out, with no more than a 1 second pause before it fires back up again, which can sometimes make surfing pretty impossible.

Hopefully Microsoft will realise that whilst we're happy to have a new OS to 'play' with, we're also helping them develop the product, so fingers crossed they'll see fit to eventually release a patch.

In case it helps, yep, I'm in the UK too, on the Bluebell Hill (Kent) transmitter, running 1x Hauppauge Win-TV Diversity USB stick (set on dual tuner mode) and 2x Hauppauge Win-TV PCI cards (chipset 90xxx). The only guide data I'm missing is for the "Dave" channel (you could re-patch this easily from within XP, Vista and Vista+TV Pack MCEs, but not in Win7).

Share this post


Link to post
Share on other sites

Same problem here, huge router traffic once MCE starts.

Tuner BlackGold BG 3540 DVB-T and DVB-S

Router Netgear DG834G

Mobo Intel DG45FC

Tx Crystal Palace

The problem is that till this is solved I have to take the machine off the network which rather limits futher testing.

Any MS UK folk listening and can give an update?

D

Share this post


Link to post
Share on other sites

atleast your connection is slow. on mine it keeps disconnecting the router every 20 mins. then have to go downstairs and turn off the modem and out it on again. Since this i went back to vista now.

Share this post


Link to post
Share on other sites

When I say my connection is slow, it too is so slow I have to either turn the router off and do without the internet, or re-boot into Vista instead. Again, hardly conducive to a decent testing environment!

So, I've turned off WER, disabled guide updates and still the internet connection is too slow to use. It appears turning off these functions doesn't make a blind bit of difference.

Fingers crossed MS will sort this out for us so we can do what they want us to do, and test their otherwise nice new OS!

Share this post


Link to post
Share on other sites
When I say my connection is slow, it too is so slow I have to either turn the router off and do without the internet, or re-boot into Vista instead. Again, hardly conducive to a decent testing environment!

So, I've turned off WER, disabled guide updates and still the internet connection is too slow to use. It appears turning off these functions doesn't make a blind bit of difference.

Fingers crossed MS will sort this out for us so we can do what they want us to do, and test their otherwise nice new OS!

My internet is really slow too and also drops out little now and then. So damn annoying. It has nothing to do with my ISP cause my other computers internet works fine. Tried to disable firewall, no change . Tried all different drivers i found to my Realtek ethernet card, no succes. Tried my d-link wireless adapter, no succes. This is drivig me nuts also, since everything else with windows 7 is so nice. But have a working internet connection is kinda the most important thing ^^ Cant really play online games properly cause my latency goes from 20 ms to 3000 ms and also drops you out of game when internet drops.

:( :(

Share this post


Link to post
Share on other sites
We haven't given MS employees special tags before (Spartan_X and Brandon Live come to mind (Brandon Live has an MVC tag for his site contributions, NOT because he works for MS)) but you can try if you want.

hmmm... "willg" :shiftyninja: I wonder if that stands for William Gates III. Neowin might want to consider MVC in that case. :p

Share this post


Link to post
Share on other sites

Strange I have that same router and it connects fine. Just simply load the ethernet drivers and bam the router's found and I'm on the net in no time.

Share this post


Link to post
Share on other sites

The thing to remember guys is that to the best of my knowledge even if you disable WER any reports that have already been generated may still be uploading. Disabling WER just stops new ones being created.

Check your task manager and if you see multiple instances of wermgr.exe then that's what's happening for sure. Once these reports have all been uploaded you should see your internet speeds return to normal, assuming there's nothing else slowing you down.

If you really can't live with the wait then you can always delete your WER problem history and then you should see an instant improvement. Just bear in mind that the more error reports MS get for this bug the easier it will be for them to fix it so choose this option as a last resort.

Share this post


Link to post
Share on other sites

Just a quick update,

I've talked with the Media Centre product group, they are aware, and working on the issue and are investigating a solution for the Windows 7 beta.

So bear with us on this, we appreciate your support of the Windows 7 beta and your patience.

-Will

Share this post


Link to post
Share on other sites
Just a quick update,

I've talked with the Media Centre product group, they are aware, and working on the issue and are investigating a solution for the Windows 7 beta.

So bear with us on this, we appreciate your support of the Windows 7 beta and your patience.

-Will

It's a pleasure helping, and thank-you for giving a real person to Windows 7 development and giving us feedback (Not forgetting Brandon).

I loved Vista well all from 3.11 onwards with excepting of ME, but I think Windows 7 is going to be best yet by far.

Any news dual tuner problems? ie only 1 working?

Edited by stevember

Share this post


Link to post
Share on other sites

More info on this issue...

TEST 1

1. Disabled WER service.

2. Disabled automatic guide download.

3. Cleared out WER logs.

4. Error logs continued to be dumped into the ReportQueue dir.

5. Terminated ehshell.exe

6. No more error logs and a fast internet connection.

7. 4 hours later, still no error logs and still a fast connection.

8. Opened Media Center, no error logs.

9. Updated guide listings manually, no error logs.

10. Points 8 & 9, above: not watching live TV at all.

11. Updated favourites line-up, adding CNN to the list.

12. Switched to live TV, error logs started appearing: about 10, 4 second gap between each.

12. No more logs for a while, then switched to another channel.

13. Another 7 or so logs generated, 4 second gap between each.

14. Waited again, no more logs, then changed channel again.

15. Another 7 or so logs generated, 4 second gap between each.

16. Waited again, no more logs, then changed channel again.

17. This time, around 10 logs appeared, 4 second gap between each, then 2 mins without.

18. Without doing anything else, another 4 or 5 logs appeared, longer gaps between each.

19. Quit Media Center, no more logs appeared.

TEST 2

1. WER service still disabled.

2. Cleared out WER logs.

3. Opened Media Center.

4. Automatic guide download enabled.

5. Manually requested guide update.

6. Played an old dvr-ms file recorded in Vista Media Center (pre-TV Pack).

7. Played two wtv files recorded last night.

8. Checked guide had updated successfully.

9. All the above without any logs generated.

10. Switched to live TV (BBC One), 8 errors generated, 4 second gaps between.

11. Two minutes without further errors, then 2 more appeared. Another minute, then another 1.

12. Observation: in both tests, viewing with sound off and MHEG subtitles on generates the same number of errors as viewing with sound on and MHEG subtitles off.

13. Changed channel to BBC Two - oddly, only one error generated.

14. Switched to ITV1 and 28 errors appeared before settling back down again for a minute, when a 29th appeared.

15. Changed to Channel 4: no picture or sound, no error logs, but MHEG 'red button' (interactive) message in corner.

16. Changed to Five: picture and sound back, as are the errors.

17. Quit Media Center, no more errors.

18. Went back in, straight to Channel 4. Again, no sound or vision, but this time 11 errors before a "Service is unavailable" message appeared for about 5 seconds. No previous tuning/reception issues.

19. 20 error logs generated before changing to CNN (during its off-air period when all you see is an MHEG5-generated "holding" screen).

20. Errors continue to appear.

21. Quit Media Center, no further errors.

22. Went back in, to CNN (incidentally, no guide data available for this new additional Freeview channel yet). Errors again start to appear.

23. Quit Media Center, no further errors.

24. Back into Media Center, this time to a radio service: BBC Radio 4. Again, errors start to appear.

Additional info:

Terminating ehexthost.exe (runs whilst Media Center is open) makes no difference.

Terminating ehtray.exe likewise makes no difference, other than losing sound and picture! Errors still appear.

From this, we can see that the Guide update may NOT be the cause of the issue here, but something to do with changing channels (and perhaps how live TV interacts with the Guide?). In addition, MHEG5 functionality might not be the cause (as errors appear regardless of whether or not an MHEG5 function is running). Terminating ehshell.exe (used for monitoring guide-scheduled recordings even whilst Media Center is closed down) stops the errors. Of course, I'm not an IT pro so am probably clutching at straws!

Hopefully this is helpful to someone over at Microsoft, if any MS guys here would like to pass it on!

Dan

Share this post


Link to post
Share on other sites

Any news Will?

Share this post


Link to post
Share on other sites
atleast your connection is slow. on mine it keeps disconnecting the router every 20 mins. then have to go downstairs and turn off the modem and out it on again. Since this i went back to vista now.

Try the steps located Here from the Valhalla forums (a South Australian LAN) to fix your problem. It was primarily a fix for Vista, but it works just as well for Windows 7. There's a link to the reg file if you don't want to do all the steps manually - but doing it stopped my router getting nuked like that too.

Share this post


Link to post
Share on other sites
Try the steps located Here from the Valhalla forums (a South Australian LAN) to fix your problem. It was primarily a fix for Vista, but it works just as well for Windows 7. There's a link to the reg file if you don't want to do all the steps manually - but doing it stopped my router getting nuked like that too.

I've just tried the suggestions from this posting and although I'm not saying the tweaks wont make the LAN/Networking more efficient, it has not cured the problem we have been reporting with Windows 7 Media Centre and the Guide (EPG) making internet use unusable by almost completely gobbiling up all available bandwidth trying to send error reports.

I've personally found this problem so bad in Windows 7 Beta that I have, for the moment at least, given up on using the beta... thats a shame really because the rest of the OS seems quite stable and very usuable.

Guess we are going to have to wait for Microsoft to come out with a fix for this before those of us in the UK who use Medica Centre can carry on evaluating this beta release : (

Thanks to the poster for the tips/tweaks (I've just applied them to my Vista install : ) )

Share this post


Link to post
Share on other sites

installing dd-wrt firmware on my linksys was the best thing i have ever done for a router

Share this post


Link to post
Share on other sites

UK and New Zealand Windows 7 Beta users -

The Windows Media Center team has identified an issue with the Windows 7 Beta on systems running in locales that use in-band scheduling ?DVB-T in the United Kingdom and New Zealand are specifically impacted by this issue.

The scenario is that after starting Media Center, there are multiple crashes in mcGlidHost resulting in Windows Error Reporting (WER) attempting to upload the crash information. Depending on the in-band scheduling data, there can be enough crash data generated to notice the upload activity on your network routers.

We have identified the root cause of this issue and are working on releasing a fix as quickly as possible. We will post additional information as it becomes available.

In the meantime, we recommend affected users follow the steps below as a temporary solution. Taking these steps will turn off in-band schedule loading which in turn will avoid the crash. This workaround will affect the in-band schedule supplementing guide data.

Once the fix is available, we recommend reverting this change and we will post that information when the fix is available.

To work around this problem, configure Windows 7 Beta to disable in-band schedule loading using the following steps:

1. Click Start, type regedit in the Start Search box and then click regedit in the Programs list

a. If you are prompted for an administrator password or confirmation, type your password or click Continue

2. Locate and then click the following registry subkey:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Media Center\Service

3. If a key named GLID is not present, right click, select New -> Key and name it GLID

4. Right click and select New -> DWORD (32 bit) Value

5. Name it DisableInbandScheduleLoading and hit Enter

6. Double click on DisableInbandScheduleLoading and set the Value Data to 1, then click on OK

7. Exit the Registry Editor

8. Restart your system

--------------------------------------------------------------------------

Tim Schreck

Media Center SE

This posting is provided "AS IS" with no warranties, and confers no rights.

Share this post


Link to post
Share on other sites

Thanks for that - will give it a go :)

Share this post


Link to post
Share on other sites
UK and New Zealand Windows 7 Beta users -

The Windows Media Center team has identified an issue with the Windows 7 Beta on systems running in locales that use in-band scheduling ?DVB-T in the United Kingdom and New Zealand are specifically impacted by this issue.

The scenario is that after starting Media Center, there are multiple crashes in mcGlidHost resulting in Windows Error Reporting (WER) attempting to upload the crash information. Depending on the in-band scheduling data, there can be enough crash data generated to notice the upload activity on your network routers.

We have identified the root cause of this issue and are working on releasing a fix as quickly as possible. We will post additional information as it becomes available.

In the meantime, we recommend affected users follow the steps below as a temporary solution. Taking these steps will turn off in-band schedule loading which in turn will avoid the crash. This workaround will affect the in-band schedule supplementing guide data.

Once the fix is available, we recommend reverting this change and we will post that information when the fix is available.

To work around this problem, configure Windows 7 Beta to disable in-band schedule loading using the following steps:

1. Click Start, type regedit in the Start Search box and then click regedit in the Programs list

a. If you are prompted for an administrator password or confirmation, type your password or click Continue

2. Locate and then click the following registry subkey:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Media Center\Service

3. If a key named GLID is not present, right click, select New -> Key and name it GLID

4. Right click and select New -> DWORD (32 bit) Value

5. Name it DisableInbandScheduleLoading and hit Enter

6. Double click on DisableInbandScheduleLoading and set the Value Data to 1, then click on OK

7. Exit the Registry Editor

8. Restart your system

--------------------------------------------------------------------------

Tim Schreck

Media Center SE

This posting is provided "AS IS" with no warranties, and confers no rights.

Many thanks for that.

I've just applied the registery alterations and so far, things are looking goo:):) .... last time I tried to access this board and to post a message, with Windows 7 Media Centre running, it was almost impossible because of this problem.

Thanks again :D:D

Share this post


Link to post
Share on other sites

Ant chance you could check with them to see if they are going to sort out the lack of 50hz for the xbox360 extender in pal regions. This was fixed in vista by an update but it's broken again in window 7

Thanks.

Just a quick update,

I've talked with the Media Centre product group, they are aware, and working on the issue and are investigating a solution for the Windows 7 beta.

So bear with us on this, we appreciate your support of the Windows 7 beta and your patience.

-Will

Share this post


Link to post
Share on other sites
Ant chance you could check with them to see if they are going to sort out the lack of 50hz for the xbox360 extender in pal regions. This was fixed in vista by an update but it's broken again in window 7

Thanks.

I'm looking into this - nice catch.

--------------------------------------------------------------------------------

Tim Schreck

Microsoft Windows Media Center SE

This posting is provided "AS IS" with no warranties, and confers no rights.

Share this post


Link to post
Share on other sites

If you want anymore info about this problem let me know.

Thanks for looking into it. This is the only thing stopping me testing win7 with my extenders day to day.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.