Jump to content

12 posts in this topic

Posted

I have a friend's Samsung laptop with SecureBoot enabled. I need to boot from a CD to perform some backups and partition resizing, but I can't do that because SecureBoot is enabled. If I disable it, will it break the current Windows 8 installation from booting, or will it not change a thing?

Share this post


Link to post
Share on other sites

Posted

Okay, so I disabled SecureBoot.
Windows 8 boots normally.
[b]USB sticks and CD/DVD disks still don't boot. [/b]What the...?

edit - sorry for replying to myself like that, maybe a moderator could merge it with the original post?

Share this post


Link to post
Share on other sites

Posted

Are you getting error message, or is the system just continuing on and booting Windows?
Are you trying to boot from the the USB stick/DVD drive using the systems boot menu, or by setting the other devices higher up in the boot order?

Share this post


Link to post
Share on other sites

Posted

I tried moving the the devices boot priority in the BIOS settings screen.
I tried using the boot menu shown after holding F10 when booting up.

When the computer tries to boot from the DVD, for example, the LED flashes on the drive for a few seconds before Windows 8 starts to boot. So it seems the computer is trying to boot from the optical disk... but doesn't.

I'm kind of disoriented right now :D

Share this post


Link to post
Share on other sites

Posted

Perhaps the system is trying to boot the media in EFI mode, and the media doesn't have an EFI bootloader? Sometimes the boot menu you can invoke will give you two options for each device (e.g. Boot to CD, as well as Boot to CD EFI).

Hopefully systems aren't being made that will ONLY boot EFI configured media.
1 person likes this

Share this post


Link to post
Share on other sites

Posted

Are you sure your boot disks are "bootable" for real? Did you miss some BIOS/UEFI setting that should be enabled to let the computer boot from secondary devices like USB sticks and optical disks?

Share this post


Link to post
Share on other sites

Posted

My disks are bootable on other devices. I just noticed that another computer with UEFI gives me the option to boot from "legacy" devices. This laptop (Samsung NP300) does not - it only lists bootable devices. So it seems it's trying to boot in EFI mode and EFI mode only. Is there a way to boot, for example, Hirens Boot CD on this computer or am I stuck with being able to boot nothing? :D

edit - I searched all over the EFI settings screen and found no further boot options. Only boot priority, SecureBoot, clock, Hyperthreading, battery charging mode (80% od full), passwords...

Share this post


Link to post
Share on other sites

Posted

Sounds like you're stuck, and I'm very concerned about how this is going to affect me in the future when I have to deal with this issue. I wonder if it might be possible to chain-load non-EFI media from a multi-purpose EFI boot CD or USB flash?

I have to say that your situation truly does suck.

Share this post


Link to post
Share on other sites

Posted

Found it. Appears "SecureBoot" options are scattered around a bit. I thought I disabled it, but... I didn't :D
Everything boots nicely now, but many utilities on Hiren's Boot CD reboot the machine. The bootable CD of Acronis Disk Director works fine, though :)
Thanks for all the help and sorry to bother you, as it all came out to be a non-issue at the end :p

Share this post


Link to post
Share on other sites

Posted

[quote name='soulburner' timestamp='1352116632' post='595297969'] Found it. Appears "SecureBoot" options are scattered around a bit. I thought I disabled it, but... I didn't :D Everything boots nicely now, but many utilities on Hiren's Boot CD reboot the machine. The bootable CD of Acronis Disk Director works fine, though :) Thanks for all the help and sorry to bother you, as it all came out to be a non-issue at the end :p [/quote]

Hello Soulburner, how are you today? I got the NP300 and I've been trying to do what you just did for the last 2 weeks! First of all, well done. How did you get the UEFI media to show up? I appears I disabled the Secure boot and selected CSM OS. I also tried the other secure boot menu but doubt it worked. Please assist (with screen shots if possible).

Thanks.

Share this post


Link to post
Share on other sites

Posted

Good day, sorry to bring this up again but I have tried for two months to sort this out. Does anyone know of any solution? I had to leave the shiny new windows 8 and continue working with my mini that is Windows 7. The boot options do not show "UEFI" beside it when trying to boot Windows 7 from USB.

Help, help, help. These charms are annoying! If I want to play games then it is all fine, but serious business can not take place always running round for basic tasks.

Share this post


Link to post
Share on other sites

Posted

I know that I'm replying to a 6 month old post but I found a solution to this problem that others may

find helpful.

 

I have a Samsung NP355E5C (aka '355E') laptop and could find no way to boot with anything but the

internal hard drive.

 

I was getting rid of Win 8 and installing Win 7 from a DVD, which wasn't happening because you can't

boot from a CD/DVD.

 

Ok here's the steps I took: (a couple may not have anything to do with anything but a couple are very

important because you can boot with USB or CD/DVD afterward)

 

Boot computer (turn it on, for those technologically challenged)  :)

 

Hold or continually tap F2 key to enter BIOS Setup. If you see the Win 7 "Starting Windows" or the Win 8

"spinning circle" you waited too long and will have to try again.

 

Once inside Setup, under the 'Boot' tab, I set 'Secure Boot' to 'Disabled'.

 

This will cause an 'OS Selection Mode' to appear beneath 'Secure Boot' that wasn't previously visible.

 

Change the 'OS Selection Mode' from 'UEFI OS' to 'UEFI and Legacy OS'.

 

Now go back up to the top listing on this page, 'Boot Device Priority' (still under the 'Boot' tab), which

previously only showed that the internal hard drive was the only bootable device.

 

Highlight it and press Enter. Note that it will probably still show only the internal hard drive listed.

Don't worry as this only requires an 'Exit Saving Changes' or use the F10 key shortcut for this same action.

 

Now, during the restart, press F2 again and once again enter the BIOS Setup.

 

If you go to the 'Boot Device Priority' under the 'Boot' tab, you'll now be able move up or down the devices

that you want to boot first.

 

(Despite advising to look in here again, when I simply changed the 'OS Selection Mode' to

'UEFI and Legacy OS', it booted from my DVD on the next restart i.e. I didn't have to go in a second time

and set the boot order up or down as desired. It defaulted to my DVD boot.

 

 

Under the 'Exit' tab, it will say 'Boot Override' along with the name of your internal hard drive.

 

 

So, now it will boot from a USB device or CD/DVD drive.

 

 

.

 

1 person likes this

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.