Sign in to follow this  
Followers 0

win8 AutoPin Controller - do not pin everything to Start Screen

8 posts in this topic

Posted

AutoPin Controller - the child of my sleepless night :cry: .

This application beats the most annoying feature of Windows 8 - auto pinning the installed software to Start Screen. With this little tool you can temporary disable pinning feature, then you can install everything you want and it will not be pinned. After that you can unlock pinning feature again.

lDQ0L.png

Also AutoPin Controller will allow you to reset the Start Screen with one click: it will remove all tiles/shortcuts and set them to first logon state.

A tricky tip: lock the pinning, install software you need, unlock the pinning and pin that YOU NEED, not everything.

Download link

I started to hate Windows 8 for auto pinning after I got VS 2012 installed. I got full Start Screen of crap :angry:

4 people like this

Share this post


Link to post
Share on other sites

Posted

Thanks :)

Share this post


Link to post
Share on other sites

Posted

This will help to not make everything cluttered when you install something and pin only the stuff people want. :punk:

Share this post


Link to post
Share on other sites

Posted

Thanks for you application! I was looking for this functionality.

Unfortunately, it doesn't work for all types of shortcuts, like library shortcuts. I use library shorcuts (shortcut to e.g. the "Documents" library) in the start menu folder to enable keyboard shortcuts. I don't want actually see them (in the desktop, taskbar or start screen). The problem is that Windows handles library shortcuts differently than application shortcuts. With application shortcuts, Windows remembers whether you've pinned or unpinned them. Library shortcuts are always pinned whenever you reboot (or perhaps re-login) you PC.

Note: I say 'library shortcuts' to be precise but it may also apply to other types of shortcuts.

Would it be possible to disable this?

Share this post


Link to post
Share on other sites

Posted

Let me see

Share this post


Link to post
Share on other sites

Posted

KeyMs92,

I can't repeat your issue. I put "C:\Users\Sergey\AppData\Roaming\Microsoft\Windows\Start Menu\Programs\Documents - Shortcut.lnk" which point to Documents library and it does not appear pinned.

But, try to set "hidden" attribute on that shortcut file. Maybe it will help you.

Share this post


Link to post
Share on other sites

Posted

Thanks for your reply! Sorry to say, but seems I can't reproduce the issue either... It's working perfectly now!

It's weird.. it's almost like it didn't initialize properly in the beginning (despite several reboots during that period). It's only now that I see that the 'add to start screen' option in the jumplist is actually gone - before it wasn't. BTW, yes the application was actually on 'locked' during that time. :)

One other thing is that I've had several 'waves' of the same error: 'not authorized to makes this change', or something like that. It happens when opening the application as well as when clicking a button. Maybe these two issues are related, I'm not sure... I'll let you know if I experience problems again.

1 person likes this

Share this post


Link to post
Share on other sites

Posted

Many thanks, I have to install Visual Studio 2012 next after rebuilding earlier.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.