Sign in to follow this  
Followers 0

win8 Weird Windows 8 Power Management Issue

23 posts in this topic

Posted

I am facing a strange a rather annoying problem since the time I installed RTM version of Windows 8 Pro.

I have a habit listening to my favorite music in iTunes on my PC which feeds Audio to Onkyo HT-R380 receiver via HDMI cable and another HDMI cable connects to my Samsung monitor (Samsung monitor is the main display).

The power options are default:

GFraL.jpg

Now the problem: I leave the computer while continue to listen to music. But after 10 min, the Samsung monitor display turns off as per power options. But the music also stops at the same time.

I almost broke my head to solve this but it's been bugging me for last 2 months.

I have Nvidia GeForce GTX 670 and I tried all the Windows 8 X64 drivers released so far by Nvidia. Currently on latest WHQL 306.97.

Any help why music stops when screen goes blank?

PS: This issue never happened in Windows 7

Share this post


Link to post
Share on other sites

Posted (edited)

Under your power options, do you have the balanced, high performance and power saver options like 7 does?

I only ask as it might be worth setting it up to high performance, then trying to change the monitor and sleep options :)

edit

Also are you using desktop speakers?

Some Samsung monitors I think come with built in speakers, like my hp and acer monitors do, and before I bought my desktop speakers, and ran my audio to them. (when my monitor went off due to those settings, the sound went as well)

Edited by Dushmany

Share this post


Link to post
Share on other sites

Posted

^^ Doesn't work under high performance as well :(

No desktop speakers nor does my monitor have internal ones. it's Onkyo 5.1 HT system.

Share this post


Link to post
Share on other sites

Posted

Does it happen if you use something made by Microsoft to play your music?

Share this post


Link to post
Share on other sites

Posted (edited)

^^ Doesn't work under high performance as well :(

Sorry, that was all I had :(

edit.. oops, statement withdrawn as I got confused and replied to ArialBlue by mistake

Edited by Dushmany

Share this post


Link to post
Share on other sites

Posted

Does it happen if you use something made by Microsoft to play your music?

I have removed WMP and Music app as I don't like too many apps doing same thing to clutter. I will try installing WMP. But iTunes does all sync and all with phone so it's the main audio player.

Edit: Same happens in WMP or Music App. :(

Share this post


Link to post
Share on other sites

Posted

No suggestions?

Share this post


Link to post
Share on other sites

Posted

In the Nvidia Control Panel, what options are listed under Display > Set up digital audio?

Share this post


Link to post
Share on other sites

Posted

In Nvidia Control Panel the following options are there:

sGpX3.jpg

In Windows Sound properties:

3SB7i.jpg

Share this post


Link to post
Share on other sites

Posted

I have a habit listening to my favorite music in iTunes on my PC which feeds Audio to Onkyo HT-R380 receiver via HDMI cable and another HDMI cable connects to my Samsung monitor (Samsung monitor is the main display).

Clarify. Is the monitor in question connected via HDMI or DVI?

Share this post


Link to post
Share on other sites

Posted

Clarify. Is the monitor in question connected via HDMI or DVI?

Monitor is connected by DVI and Onkyo & TV is connected by HDMI.

Here is a video of the problem.

http://www.youtube.com/watch?v=vXr8Bk_fSHI

Share this post


Link to post
Share on other sites

Posted

The only thing I can think of is the Nvidia drivers. Do you have NVIDIA HD Audio Driver installed in your Control Panel list?

Share this post


Link to post
Share on other sites

Posted

Yes HD driver is installed

Share this post


Link to post
Share on other sites

Posted

If you haven't already tried, uninstall it, reboot, and see if anything changes. It is automatically installed with any driver package downloaded from Nvidia's site, so it's not like you can't un-do getting rid of it.

Share this post


Link to post
Share on other sites

Posted

I uninstalled it but then i get no audio from HDMI.

Share this post


Link to post
Share on other sites

Posted

I went through your setup and video.

I have few questions as well as suggestion as below:

1. Do you still have Windows 7 ? I would like you to test the same thing as in the video you posted where your samsung monitor, TV and onkyo av receiver are all connected to your pc and turned on. And check if it gives any issue as I think it might be related to Onkyo settings as below.

2. I think your TV is turning off the audio. I noticed that there is a setting in Onkyo which lets TV control the audio output in Onkyo. Can you check what happens while your TV is off and just Samsung monitor and Onkyo is on ? (Check Onkyo Manual Page 34 for settings)

I hope this helps.

Share this post


Link to post
Share on other sites

Posted

When your monitor is turning off it's more than likely killing the HDCP connection and therefore kills the audio. The Dell sound bars will do something similar if enabled, but it's off by default.

1 person likes this

Share this post


Link to post
Share on other sites

Posted

When your monitor is turning off it's more than likely killing the HDCP connection and therefore kills the audio. The Dell sound bars will do something similar if enabled, but it's off by default.

I agree with this. It kills the conncection. So your hdmi cable stops transmitting the audio too.

Share this post


Link to post
Share on other sites

Posted

^^ yes. This issue simply does not exist in Windows 7. Everything works flawlessly. This issue happens even if I keep my TV switched off. As soon as monitor turns off due to power settings, the whole audio stream to Onkyo receiver switches off and back on when mouse is moved.

I dont know if this Windows 8 "by design" feature.

Share this post


Link to post
Share on other sites

Posted

I think Windows 8 considers Onkyo as 2nd display device, even when the TV is off. Try switching to single display mode, using WinKey+P. That might probably disconnect you from Onkyo but not sure.

Also, did you check the HDMI audio settings in Onkyo ? Or look for option by which it would be recognized as HDMI audio only device to your PC.

From the audio options screenshot you posted it appears to be detected as display device for sure and that is correct but its causing issue in Windows 8.

Share this post


Link to post
Share on other sites

Posted

Is there not an option in your menu settings of your monitor to keep audio on during sleep or low power mode?

Share this post


Link to post
Share on other sites

Posted

Is there not an option in your menu settings of your monitor to keep audio on during sleep or low power mode?

No.

I think Windows 8 considers Onkyo as 2nd display device, even when the TV is off. Try switching to single display mode, using WinKey+P. That might probably disconnect you from Onkyo but not sure.

Also, did you check the HDMI audio settings in Onkyo ? Or look for option by which it would be recognized as HDMI audio only device to your PC.

From the audio options screenshot you posted it appears to be detected as display device for sure and that is correct but its causing issue in Windows 8.

I checked HDMI audio settings in Onkyo. But there are no configurable settings there and again, same setup works perfectly in Windows 7.

Share this post


Link to post
Share on other sites

Posted

Hi sanke,

I think the monitor is the wrong way to investige this as the other screen is going off as well. Is the computer going to sleep?

I have a similar issue, Mine seems to go into power save mode after 5 mins regardless of what I set the power options to.

If you leave the PC for a bout 10 seconds after the screen goes off does it still start up instantly? or has it gone into hibernate or sleep mode? I see you have it set to Never sleep, but mine ignores that at the moment! So it sleeps when the monitor goes off.

(I have Windows 8 pro, upgraded from win7. I was wondering if there is another power save menu in win 8 that is overwriting the win 7 options I had set before the upgrade.)

Brin

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.