Jump to content



Photo

Seagate FA GoFlex Pro Wont Mount via USB 2.0

help

  • Please log in to reply
5 replies to this topic

#1 Tokiga

Tokiga

    Neowinian

  • Joined: 29-July 02

Posted 25 November 2012 - 01:34

As the title says I have Seagate FA GoFlex Pro that wont Mount via USB 2.0 (its not a usb 3.0 connector). It does mount via eSata and passes all diagnostics. I've checked all my USB ports with flash drives and they all mount.

I've tried three different USB cords with the GoFlex and it wont mount with any of them.

Any ideas as to what could be preventing it from mounting?

Windows 7


#2 Mindovermaster

Mindovermaster

    Neowinian Senior

  • Tech Issues Solved: 9
  • Joined: 25-January 07
  • Location: /USA/Wisconsin/
  • OS: Mint Debian LMDE
  • Phone: HTC ONE V

Posted 25 November 2012 - 01:39

Could be a letter conflict (if Windows)

#3 +warwagon

warwagon

    Only you can prevent forest fires.

  • Tech Issues Solved: 2
  • Joined: 30-November 01
  • Location: Iowa

Posted 25 November 2012 - 01:47

Does it show up in the device manager? is it USB 3.0?

#4 OP Tokiga

Tokiga

    Neowinian

  • Joined: 29-July 02

Posted 25 November 2012 - 02:01

Scratch that it is NOT showing up in the device manager, and yes its windows 7. its not a usb 3.0 connector

#5 OP Tokiga

Tokiga

    Neowinian

  • Joined: 29-July 02

Posted 25 November 2012 - 03:10

It appears this issue has something to do with the usb 2.0 adapter its not even lighting up anywhere hopefully the warranty covers the adapter and not just the drive (seagate drives have swappable adapters for different connection types usb 2.0, 3.0, esata, thunderbolt etc)

#6 +goretsky

goretsky

    Neowinian Senior

  • Tech Issues Solved: 3
  • Joined: 12-March 04
  • Location: Southern California

Posted 26 November 2012 - 07:33

Hello,

Just to check, were you using a USB 2.0 "Y" cable that plugged into two USB ports on the computer? It is possible that connecting the Seagate FreeAgent GoFlex Pro via one USB 2.0 port does not provide enough power (amperage) to power both the USB to SATA bridgeboard and the hard disk drive. I cannot say that I have had this problem with the 1TB or 1.5TB versions of the drive, but it could be something specific to the USB port(s) on the computer(s) you have used.

Regards,

Aryeh Goretsky