Sign in to follow this  
Followers 0
thatguyandrew1992

win8 Problems with permission on drives

21 posts in this topic

Hey all,

I just installed Windows 8 on my new ssd which is my C drive. My old drive, D Drive, had Win7 on it and all my files, so I moved all my files to the root of the drive and deleted all the Windows and Programs junk from the D drive.

I have issues with permissions now. I download all my exes to the D drive and when I run them, they always popup with permission issues when trying to add something to the start menu loction in Program Data on my C drive. I have to go in and add the folder myself and give all permissions to "Everyone" This seems dangerous and unessacary. What can I do?

Also, I installed File Shredder on my C drive, and I'm trying to shred stuff on my D Drive when right clicking on the file it says "Some files cant be shredded bcause its in use or you dont have the required privileges." And it's not in use.

:(

Please help

Share this post


Link to post
Share on other sites

It cam from a different OS, so the SID for the permissions on that drive are different. Overwrite them from the root of the drive with your new permissions.

Share this post


Link to post
Share on other sites

Try taking ownership of the folder and make sure you populate your changes to all child objects of the folder in question, then set your permissions accordingly.

Share this post


Link to post
Share on other sites

It cam from a different OS, so the SID for the permissions on that drive are different. Overwrite them from the root of the drive with your new permissions.

Which permissions do I need to set? I'm not famililar with them, and I don't want to cause any security issues.

Try taking ownership of the folder and make sure you populate your changes to all child objects of the folder in question, then set your permissions accordingly.

I did. I got that little right click, take ownership thing, but it didnt work :/

Share this post


Link to post
Share on other sites

Right click drive, properties > Security tab > Advanced > Owner > Edit > Tick replace owner on subcontainers and objects > click your username >okay... okay out of them all and hopefully that should sort your problem.

PS thats Windows 7 - I'm guessing Windows 8 is similar

Share this post


Link to post
Share on other sites

Right click drive, properties > Security tab > Advanced > Owner > Edit > Tick replace owner on subcontainers and objects > click your username >okay... okay out of them all and hopefully that should sort your problem.

PS thats Windows 7 - I'm guessing Windows 8 is similar

It didn't work :(

Share this post


Link to post
Share on other sites

At your own risk you can try resetting the permissions for your D: drive:

At an administrator CMD prompt enter the following:


D:
icacls * /T /Q /C /RESET
[/CODE]

Share this post


Link to post
Share on other sites

At your own risk you can try resetting the permissions for your D: drive:

At an administrator CMD prompt enter the following:


D:
icacls * /T /Q /C /RESET
[/CODE]

What is the risk?

Share this post


Link to post
Share on other sites

Okay what about starting at the D drive itself? right click the D drive and then try to take ownership on the entire drive and then set your permissions, also don't forget to replace owner and permissions on all sub containers and objects

Share this post


Link to post
Share on other sites

Right click drive, properties > Security tab > Advanced > Owner > Edit > Tick replace owner on subcontainers and objects > click your username >okay... okay out of them all and hopefully that should sort your problem.

PS thats Windows 7 - I'm guessing Windows 8 is similar

With that option, on mine I can select... Administrators or my own username. Would I have to select my username, or could I select Administrators?

Just cuz personally I notice by default, on anything I check permissions on, it has Administrators, , SYSTEM, and Users. If I don't have to have my username in there, Id prefer not to. I am the administrator.

Share this post


Link to post
Share on other sites

Administrators should work too, if you are one.

Share this post


Link to post
Share on other sites

What is the risk?

Just does a permissions reset but should not be applied to the main OS drive. As long as you switch to D: first, it should be fine to use.

E.g.


C:\> D:
D:\> icacls * /T /Q /C /RESET
[/CODE]

Share this post


Link to post
Share on other sites

Just does a permissions reset but should not be applied to the main OS drive. As long as you switch to D: first, it should be fine to use.

E.g.


C:\> D:
D:\> icacls * /T /Q /C /RESET
[/CODE]

I tried, but the first file on the drive appears with the message access denied. Then more files follow, saying access denied. :(

Share this post


Link to post
Share on other sites

I tried, but the first file on the drive appears with the message access denied. Then more files follow, saying access denied. :(

Use this to replace the "Take Ownership" right click menu

http://localhostr.co...FullControl.reg

Use it on the entire drives root of folders, once its finished, goto the drives/folders properties > security tab > add "Everyone" to the "Group or usernames" entry box and hit apply

Now goto the permissions box underneath and hit "Advanced" > Owner tab > Edit > make sure to check the "Replace owner on subcontainers and objects" checkbox > "Other Users or Groups" button and enter "Everyone" into that

Wait for it to do its ownership/permissions things,

Ok out of all the windows and see how you get on there

You might find you need to repeat the above on more than just the drives root, sub-folder etc, takes a while to gain ownership back from a previous OS but its possible

Share this post


Link to post
Share on other sites

Did you run it in an administrative command prompt?

Share this post


Link to post
Share on other sites

Okay, so it turns out there are some specific files that I'm trying to shred that are giving this privilege problem. Other files aren't. When I do these permission things a little warning box appears for several files (including the ones I want to shred). Other files can be shredded just fine.

@Detection - Thanks for posting a reply but that didn't solve the issue.

To be clear - the issue is now, there are ~10 files with permission issues it seems

And it turns out when just adding the files in through the program it self (not the right click menu) it shreds. Jeez....

Share this post


Link to post
Share on other sites

We can go back and forth for days here, even when you spell out the exact commands!

Its easier for someone to just teamviewer in and fix it for you in like 10 seconds.

As already stated YOU NEED to be an OWNER to set permissions.. Then set them as you need - yes by default admin and system should have full control.

What you do after that on a non system drive is up to you. I root of my D set like this

post-14624-0-86351200-1356800218.png

Keep in mind when your in explorer your not normally elevated - so your not ADMIN, does not matter if your in the admin group or not.. This is for example you get a prompt to write a file to root of C

post-14624-0-06215100-1356800377.png

Notice the permissions on your C drive -- users and authenticated users have what?

post-14624-0-98437600-1356800671.png

If you don't want that to happen then you need to set the permissions how you want them, to set permissions you have to have full control already or be an owner, or be able to elevate to admin that had permissions, etc. etc..

Now if you want we can have yet another discussion on the basics of NTFS permissions.. But the information to fix your issue has already been given.

As stated take OWNER of your D from the root, write this ownership down the tree. Then set the permissions how you want.. Since the disk came from other OS, then sure its a good idea to reset them! Its not going to hurt anything if its just a data drive. You could set everyone to full control as the only permission if you wanted.. Its your DISK, set the permissions how you want!

Or just PM details so I can TeamViewer in and we can straighten all out in like 10 seconds.

Share this post


Link to post
Share on other sites

Thanks for your help BudMan but I have all of that set already.

EDIT: I think I got it all fixed...

Share this post


Link to post
Share on other sites

And it only took three days ;) And you "think" its fixed... sweet!

Share this post


Link to post
Share on other sites

And it only took three days ;) And you "think" its fixed... sweet!

:/

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.