Jump to content



Photo

Registry - Can not create new DWORD or change key permissions

win8

  • Please log in to reply
4 replies to this topic

#1 Elliot B.

Elliot B.

    Over 12 years on Neowin

  • Tech Issues Solved: 4
  • Joined: 16-August 01
  • Location: West Midlands, UK
  • OS: Windows 8.1
  • Phone: Samsung Galaxy S5

Posted 06 January 2013 - 13:38

When I try to create a DWORD, I get:

"Cannot create value: Error writing to the registry."

If I right-click on the key, choose Permissions, click Administrators, click Allow - Full Control, then click "OK", I get:

"Unable to save permission changes on ShellFolder. Access is denied."

There is no "Owner" tab in Advanced Security Settings, only "Permissions", "Auditing" and "Effective Access".

I don't remember it being this difficult in Windows 7, so I guess Microsoft has tightened security further in Windows 8.

Any ideas?


#2 episode

episode

    Neowinian Fanatic

  • Tech Issues Solved: 3
  • Joined: 11-December 01

Posted 06 January 2013 - 13:46

Are you running regedit as an admin when you open it?

#3 OP Elliot B.

Elliot B.

    Over 12 years on Neowin

  • Tech Issues Solved: 4
  • Joined: 16-August 01
  • Location: West Midlands, UK
  • OS: Windows 8.1
  • Phone: Samsung Galaxy S5

Posted 06 January 2013 - 13:47

Are you running regedit as an admin when you open it?


No idea. I have UAC disabled, and I run Regedit via. Run.

EDIT: I've tried going to C:\Windows and right-clicking on regedit.exe and selecting "Run as administrator" - same issues.

#4 DudeBro

DudeBro

    /人◕ ‿‿ ◕人\

  • Joined: 30-July 05
  • Location: California, USA

Posted 06 January 2013 - 14:10

In permissions > advanced settings, above the Permissions, Auditing, and Effective Access tabs is a link to change the owner. Should look like this:

Owner: SYSTEM Change

Click on the blue 'Change' link. Change to admin, user account or whatever. Set permissions to allow Full-Control. This should let you edit protected registry keys. Works for me.

#5 OP Elliot B.

Elliot B.

    Over 12 years on Neowin

  • Tech Issues Solved: 4
  • Joined: 16-August 01
  • Location: West Midlands, UK
  • OS: Windows 8.1
  • Phone: Samsung Galaxy S5

Posted 06 January 2013 - 14:39

In permissions > advanced settings, above the Permissions, Auditing, and Effective Access tabs is a link to change the owner. Should look like this:

Owner: SYSTEM Change

Click on the blue 'Change' link. Change to admin, user account or whatever. Set permissions to allow Full-Control. This should let you edit protected registry keys. Works for me.

Unfortunately, this does not work here.



Click here to login or here to register to remove this ad, it's free!