Jump to content



Photo

Linux and Windows 8 Fast Startup

windows 8 fast startup ntfs

  • Please log in to reply
15 replies to this topic

#1 +Majesticmerc

Majesticmerc

    Resident Idealist

  • Tech Issues Solved: 8
  • Joined: 24-August 05
  • Location: United Kingdom
  • OS: Arch Linux / Win 7
  • Phone: HTC One X

Posted 13 January 2013 - 02:42

I thought this would be worth linking here, since it might be relevant to some Neowinians:

The new Fast Startup feature of Windows 8 puts the filesystem's integrity at risk if other operating systems are used to write to Windows partitions. Data loss is particularly likely with dual-boot configurations that involve Linux and Windows 8.


Full Article.

TL;DR If you're using the Windows 8 Fast Startup option and dual boot with another OS, consider the Windows 8 partition(s) to be read-only and/or disable fast startup. Writing to a Win8 partition from Linux can cause the files to go missing on Win8 and/or be corrupted due to the way that fast startup works. The NTFS-3G driver has not yet been updated to detect fast-boot, so will mount as read/write on many distros (including Debian and Ubuntu). Apparently a fix is in Debian testing, but this means that Stable users won't see it for a while yet.


#2 +Karl L.

Karl L.

    xorangekiller

  • Tech Issues Solved: 15
  • Joined: 24-January 09
  • Location: Virginia, USA
  • OS: Debian Testing

Posted 13 January 2013 - 04:11

Thanks! That article has good technical detail and is very informative. Its so much more useful than most of the nonsense that makes it onto the front page.

#3 rkenshin

rkenshin

    Fists of Steel!

  • Joined: 01-October 02
  • Location: Hampshire, IL
  • OS: Windows 8 Pro, Mac OS 10.8, (VM's): Ubuntu 12.10, Fedora 17, Backtrack 5, Linux Mint, OpenSUSE

Posted 13 January 2013 - 14:57

Of course, if you've disabled Hibernation, this need not apply. Still, a good article for the people that use this option.

#4 Detection

Detection

    Detecting stuff...

  • Joined: 30-October 10
  • Location: UK
  • OS: 7 SP1 x64

Posted 13 January 2013 - 15:29

I disabled fast boot when I was running 8 anyway, with an OS as young as 8 there is always going to be bugs that need a reboot to fix, fast boot means you have to reboot on top of normally powering on in the morning, where normally a shutdown and power on would have done the same job without fast boot

#5 OP +Majesticmerc

Majesticmerc

    Resident Idealist

  • Tech Issues Solved: 8
  • Joined: 24-August 05
  • Location: United Kingdom
  • OS: Arch Linux / Win 7
  • Phone: HTC One X

Posted 13 January 2013 - 16:14

Of course, if you've disabled Hibernation, this need not apply. Still, a good article for the people that use this option.


Correct me if I'm wrong, but aren't fast startup and hibernation different things? I mean they accomplish similar goals, but they're not the same thing. Disabling hibernation != disabling fast startup. NTFS-3G already detects hibernation and only mounts an NTFS partition as read-only if Windows is hibernating, but the issue is that it doesn't do the same thing for fast startup (yet), which means that there's a risk.

#6 Aergan

Aergan

    Neowinian Senior

  • Tech Issues Solved: 6
  • Joined: 24-September 05
  • Location: Staffordshire, UK
  • OS: Xubuntu 14.04.1 / Server 2012 R2 / Ubuntu Server 14.04.1
  • Phone: Sony Xperia Z1

Posted 13 January 2013 - 18:40

Thanks for the heads up, I just added Ubuntu to my laptop yesterday.

#7 rkenshin

rkenshin

    Fists of Steel!

  • Joined: 01-October 02
  • Location: Hampshire, IL
  • OS: Windows 8 Pro, Mac OS 10.8, (VM's): Ubuntu 12.10, Fedora 17, Backtrack 5, Linux Mint, OpenSUSE

Posted 13 January 2013 - 19:41

Correct me if I'm wrong, but aren't fast startup and hibernation different things? I mean they accomplish similar goals, but they're not the same thing. Disabling hibernation != disabling fast startup. NTFS-3G already detects hibernation and only mounts an NTFS partition as read-only if Windows is hibernating, but the issue is that it doesn't do the same thing for fast startup (yet), which means that there's a risk.


The Fast Startup option uses Hibernation, or its own form of it. Disabling hibernation completely disables the fast startup option in Windows 8. I think the Fast Startup option is using the same hiberfile.sys that hibernation is using. Running the command "powercfg -h off" in the command prompt removes this option and deletes the hiberfile.sys. Fast Startup no longer becomes an option. You can achieve the same results this way of disabling Fast Startup (and saving space now that you no longer have a hiberfile.sys).

"The Fast Startup feature creates an issue because it doesn't shut Windows 8 down completely but switches it to a special hibernation state instead – although it looks like it has been freshly booted when switched back on because all applications have been closed."

Also, found on Eightforums.com "Because if you disable Hibernate, Fast Startup also disabling automatically" http://www.eightforums.com/tutorials/6320-fast-startup-turn-off-windows-8-a.html (Option 3)

#8 Farchord

Farchord

    Life is but a sum of your achievements

  • Joined: 06-November 01
  • Location: Shawinigan, Quebec, Canada
  • Phone: iPhone 5

Posted 13 January 2013 - 19:49

I have an SSD, I disabled hibernation anyway.

#9 OP +Majesticmerc

Majesticmerc

    Resident Idealist

  • Tech Issues Solved: 8
  • Joined: 24-August 05
  • Location: United Kingdom
  • OS: Arch Linux / Win 7
  • Phone: HTC One X

Posted 13 January 2013 - 19:57

The Fast Startup option uses Hibernation, or its own form of it. Disabling hibernation completely disables the fast startup option in Windows 8. I think the Fast Startup option is using the same hiberfile.sys that hibernation is using. Running the command "powercfg -h off" in the command prompt removes this option and deletes the hiberfile.sys. Fast Startup no longer becomes an option. You can achieve the same results this way of disabling Fast Startup (and saving space now that you no longer have a hiberfile.sys).

"The Fast Startup feature creates an issue because it doesn't shut Windows 8 down completely but switches it to a special hibernation state instead – although it looks like it has been freshly booted when switched back on because all applications have been closed."

Also, found on Eightforums.com "Because if you disable Hibernate, Fast Startup also disabling automatically" http://www.eightforu...indows-8-a.html (Option 3)


Ah okay, interesting. Thanks for the info :)

#10 rkenshin

rkenshin

    Fists of Steel!

  • Joined: 01-October 02
  • Location: Hampshire, IL
  • OS: Windows 8 Pro, Mac OS 10.8, (VM's): Ubuntu 12.10, Fedora 17, Backtrack 5, Linux Mint, OpenSUSE

Posted 14 January 2013 - 00:58

Ah okay, interesting. Thanks for the info :)


You're welcome. Still, a great find! :D

#11 bdsams

bdsams

    Neowinian Senior

  • Joined: 28-April 03
  • Location: Cincinnati, Ohio

Posted 14 January 2013 - 14:12

Is anyone able to verify this? If so, will pass the word along on the front page.

#12 +Frank B.

Frank B.

    Member N° 1,302

  • Tech Issues Solved: 11
  • Joined: 18-September 01
  • Location: Frankfurt, DE
  • OS: OS X 10.10
  • Phone: iPhone 6

Posted 14 January 2013 - 14:17

Is anyone able to verify this? If so, will pass the word along on the front page.

h-online.com is the English site of heise.de. Their magazines have a good reputation for actually researching what they're writing about.

That said independent confirmation could be good. Surely someone here has a Windows 8/Linux dual-boot config.

#13 +Karl L.

Karl L.

    xorangekiller

  • Tech Issues Solved: 15
  • Joined: 24-January 09
  • Location: Virginia, USA
  • OS: Debian Testing

Posted 14 January 2013 - 20:16

Is anyone able to verify this? If so, will pass the word along on the front page.


I'm not sure if files don't get lost or corrupted reliably, but I was not able to reproduce this with Windows 8 and Debian 7 dual-booting in VirtualBox. (I don't run Windows natively, but I don't see how a native installation would make any difference.) My log of commands I ran in Windows and Debian to try to reproduce this problem, as well as their output, is below.

PS C:\Users\xorangekiller> mkdir Desktop\rar


	Directory: C:\Users\xorangekiller\Desktop


Mode				LastWriteTime	 Length Name
----				-------------	 ------ ----
d----		 1/14/2013   2:51 PM			rar


PS C:\Users\xorangekiller> echo rar > Desktop\rar.txt
xorangekiller@pigeonhole:~$ sudo mkdir /mnt/rar
xorangekiller@pigeonhole:~$ sudo parted -l
Model: ATA VBOX HARDDISK (scsi)
Disk /dev/sda: 8590MB
Sector size (logical/physical): 512B/512B
Partition Table: msdos

Number  Start   End	 Size	Type	  File system	 Flags
1	  1049kB  8186MB  8185MB  primary   ext4			boot
2	  8187MB  8589MB  402MB   extended
5	  8187MB  8589MB  402MB   logical   linux-swap(v1)


Model: ATA VBOX HARDDISK (scsi)
Disk /dev/sdb: 32.2GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos

Number  Start   End	 Size	Type	 File system  Flags
1	  1049kB  368MB   367MB   primary  ntfs		 boot
2	  368MB   32.2GB  31.8GB  primary  ntfs


xorangekiller@pigeonhole:~$ sudo mount -t ntfs /dev/sdb2 /mnt/rar
xorangekiller@pigeonhole:~$ mkdir /mnt/rar/rar
xorangekiller@pigeonhole:~$ echo rar > /mnt/rar/rar.txt
xorangekiller@pigeonhole:~$ ls -l /mnt/rar/ /mnt/rar/Users/xorangekiller/Desktop/
/mnt/rar/:
total 2359737
-rwxrwxrwx 1 root root	 398156 Jul 25 23:44 bootmgr
-rwxrwxrwx 1 root root		  1 Jun  2  2012 BOOTNXT
drwxrwxrwx 1 root root	   4096 Jan  4 00:53 Config.Msi
lrwxrwxrwx 2 root root		 60 Jul 26 03:22 Documents and Settings -> /mnt/rar/Users
-rwxrwxrwx 1 root root 2147483648 Jan 14 14:30 pagefile.sys
drwxrwxrwx 1 root root		  0 Jul 26 03:33 PerfLogs
drwxrwxrwx 1 root root	   4096 Oct 27 11:45 ProgramData
drwxrwxrwx 1 root root	   4096 Nov  2 17:46 Program Files
drwxrwxrwx 1 root root	   4096 Dec 12 21:11 Program Files (x86)
drwxrwxrwx 1 root root		  0 Jan 14 14:38 rar
-rwxrwxrwx 1 root root		  0 Jan 14 14:38 rar.txt
drwxrwxrwx 1 root root		  0 Sep  6 21:44 $Recycle.Bin
-rwxrwxrwx 1 root root  268435456 Jan 14 14:30 swapfile.sys
drwxrwxrwx 1 root root	   4096 Oct 27 11:38 System Volume Information
drwxrwxrwx 1 root root	   4096 Oct 15 00:37 Users
drwxrwxrwx 1 root root	  24576 Jan  4 00:52 Windows

/mnt/rar/Users/xorangekiller/Desktop/:
total 1
-rwxrwxrwx 1 root root 282 Dec 12 21:55 desktop.ini
drwxrwxrwx 1 root root   0 Jan 14 14:39 rar
-rwxrwxrwx 1 root root   0 Jan 14 14:39 rar.txt

xorangekiller@pigeonhole:~$ sudo umount /mnt/rar
PS C:\Users\xorangekiller> ls Desktop


	Directory: C:\Users\xorangekiller\Desktop


Mode				LastWriteTime	 Length Name
----				-------------	 ------ ----
d----		 1/14/2013   2:51 PM			rar
-a---		 1/14/2013   2:56 PM		 12 rar.txt


PS C:\Users\xorangekiller> ls C:\


	Directory: C:\


Mode				LastWriteTime	 Length Name
----				-------------	 ------ ----
d----		 7/26/2012   3:33 AM			PerfLogs
d-r--		 11/2/2012   5:46 PM			Program Files
d-r--		12/12/2012   9:11 PM			Program Files (x86)
da---		 1/14/2013   3:01 PM			rar
d-r--		10/15/2012  12:37 AM			Users
d----		  1/4/2013  12:52 AM			Windows
-a---		 1/14/2013   3:01 PM		  4 rar.txt




#14 medhunter

medhunter

    Muslim Emergency physician

  • Joined: 19-June 11
  • Location: Egypt
  • OS: Win 7 SP1 Home Premium , Ubuntu 12.04 LTS, Xubuntu 13.04
  • Phone: Sony Sola

Posted 15 January 2013 - 04:19

Pretty useful. Thanks

#15 ArialBlue

ArialBlue

    var lulz;

  • Joined: 24-June 10
  • Location: Democratic People's Republic of Korea
  • OS: Windows Master Race

Posted 15 January 2013 - 04:43

Run Linux in a VM.
Oracle Virtual Box is decent.

No need to dual boot.