Jump to content



Photo

Nokia Lumia 800 + Windows Phone 7.8

nokia lumia 800

  • Please log in to reply
15 replies to this topic

#1 wrack

wrack

    Wireless Robotic Android Calibrated for Killing

  • Joined: 09-December 06
  • Location: Melbourne, Australia

Posted 23 January 2013 - 23:25

Hi,

I have got a Nokia Lumia 800 from VodaFone Australia. I have debranded it by installing Country Variant of Windows Phone 7.5 (yes). All is working great.

Yesterday I tried to get 7.8 but Australian Country Variant has not been released so I used Asia Pacific version (059L975: RM-801 VAR APAC1 IN CV MBLACK) and all is well but the incoming and outgoing calls will not recognise the contacts stored in international format. All my 400 contacts are stored this way for a reason as to when I am travelling overseas, I don't have to change the number.

I turn on the "International Assist" settings in the phone settings. Is there any other special setting anywhere that I need to turn on?

Can anyone who has done the same confirm that this issue is not happening on their phone and if so which version did you download?

I do not use the bluetooth share or ringtone maker so I don't care if any other version may not have them.

TA :)


#2 thechronic

thechronic

    Neowinian Senior

  • Joined: 21-July 05
  • Location: UK

Posted 23 January 2013 - 23:28

I updated mine in the UK using the correct update for my location and i've no issues at all

#3 OP wrack

wrack

    Wireless Robotic Android Calibrated for Killing

  • Joined: 09-December 06
  • Location: Melbourne, Australia

Posted 23 January 2013 - 23:33

I updated mine in the UK using the correct update for my location and i've no issues at all


Thanks. I assume you are in UK. I can't find AU version on NaviFirm just yet and the UK one I found is not a country variant. Below are the versions I see for UK and they all seem to be carrier specific.

059N205: Nokia 800 RM-801 O2 UK GB V5 Black (7.8)
059R263: RM-801 VAR254537 Vodafone UK PAYG SL Black v2
059L704: RM-801 Vodafone UK GB VAR254524 Contract Black V7
059M503: RM-801 Vodafone UK GB VAR254530 Contract Cyan V7

#4 thechronic

thechronic

    Neowinian Senior

  • Joined: 21-July 05
  • Location: UK

Posted 23 January 2013 - 23:34

i am in the UK yes :)

I updated using the nokia care suite, my provider is EE (Orange, UK)

#5 OP wrack

wrack

    Wireless Robotic Android Calibrated for Killing

  • Joined: 09-December 06
  • Location: Melbourne, Australia

Posted 23 January 2013 - 23:37

i am in the UK yes :)

I updated using the nokia care suite, my provider is EE (Orange, UK)


Oh ok so I assume the device is still branded as in when you restart the phone you can see the carrier logo/branding? For Australia none of the country variant or carrier specific ones are released!

#6 ingramator

ingramator

    Hacker

  • Joined: 04-July 12
  • OS: Windows 7/8, OSX 10.8, Linux/UNIX/BSD
  • Phone: Lumia 920, iPhone 5, GS3

Posted 24 January 2013 - 08:08

Oh ok so I assume the device is still branded as in when you restart the phone you can see the carrier logo/branding? For Australia none of the country variant or carrier specific ones are released!


I actually am not really sure why it's doing that with your contacts! What do you mean by not recognise though? So it just comes up with the number without the contact associated is what I'm presuming? I don't think that's a country problem but you could try flashing the stock RM801 image without any region specifics. It will still work exactly the same but you wont have ringtone maker or Bluetooth share in it!

#7 tenpoundmouse

tenpoundmouse

    Winner of the 100 metre egg & spoon race (1985-1987).

  • Joined: 11-October 02
  • Location: London UK
  • OS: OS X
  • Phone: Nexus 5 : Lumia 920

Posted 24 January 2013 - 08:40

I updated mine in the UK (I'm on the 3 network) with a unbranded version and haven't had any issues but I do have Bluetooth share and ringtone maker, they were in the Nokia collection but have since disappeared. I used 059N205: Nokia 800 RM-801 O2 UK GB V5 Black (7.8).

#8 Riva

Riva

    Neowinian

  • Tech Issues Solved: 1
  • Joined: 11-February 07

Posted 24 January 2013 - 08:48

I would say you should roll up and wait for the official one. It isn't far off. I updated two Lumia 800s in the UK as well with no issues at all.

#9 thechronic

thechronic

    Neowinian Senior

  • Joined: 21-July 05
  • Location: UK

Posted 24 January 2013 - 11:14

Oh ok so I assume the device is still branded as in when you restart the phone you can see the carrier logo/branding?


No branding on my device - works with any network :)

#10 OP wrack

wrack

    Wireless Robotic Android Calibrated for Killing

  • Joined: 09-December 06
  • Location: Melbourne, Australia

Posted 24 January 2013 - 12:07

I actually am not really sure why it's doing that with your contacts! What do you mean by not recognise though? So it just comes up with the number without the contact associated is what I'm presuming? I don't think that's a country problem but you could try flashing the stock RM801 image without any region specifics. It will still work exactly the same but you wont have ringtone maker or Bluetooth share in it!


Hey thanks mate. My contacts are stored in lets say, +61 4xx xxx xxx format. When I call someone directly using the number 04xx xxx xxx the OS does not recognise the contact name. Similarly, when I get a call from that number I can see the number in 04xx xxx xxx format but the name says UNKNOWN CONTACT.

Do you happen to know the product code of the stock RM801? How do I identify it in NaviFirm?

Don't really care about the Bluetooth Share or the Ringtone Maker. Utter useless to me.

I updated mine in the UK (I'm on the 3 network) with a unbranded version and haven't had any issues but I do have Bluetooth share and ringtone maker, they were in the Nokia collection but have since disappeared. I used 059N205: Nokia 800 RM-801 O2 UK GB V5 Black (7.8).


Thanks. I will wait for the AU version.

I would say you should roll up and wait for the official one. It isn't far off. I updated two Lumia 800s in the UK as well with no issues at all.


Yeah. I have rolled back to 7.5 for the time being as I can't live without knowing the contact names.

No branding on my device - works with any network :)


Oh ok. What I meant was that when you restart the phone, you no longer see the carrier logo. It just shows the Nokia and Windows Phone and that is it. With branded devices it shows carrier logo upon startup.

#11 ingramator

ingramator

    Hacker

  • Joined: 04-July 12
  • OS: Windows 7/8, OSX 10.8, Linux/UNIX/BSD
  • Phone: Lumia 920, iPhone 5, GS3

Posted 25 January 2013 - 03:47

Hey thanks mate. My contacts are stored in lets say, +61 4xx xxx xxx format. When I call someone directly using the number 04xx xxx xxx the OS does not recognise the contact name. Similarly, when I get a call from that number I can see the number in 04xx xxx xxx format but the name says UNKNOWN CONTACT.

Do you happen to know the product code of the stock RM801? How do I identify it in NaviFirm?

Don't really care about the Bluetooth Share or the Ringtone Maker. Utter useless to me.


Ahh Ok, that's kind of strange! I don't store my numbers with the country extension so I'm taking your word for it :p Are your contacts strictly local or cloud synced? The stock image is just the first one in the list on NaviFirm you'll see it there!

#12 OP wrack

wrack

    Wireless Robotic Android Calibrated for Killing

  • Joined: 09-December 06
  • Location: Melbourne, Australia

Posted 25 January 2013 - 07:03

Ahh Ok, that's kind of strange! I don't store my numbers with the country extension so I'm taking your word for it :p Are your contacts strictly local or cloud synced? The stock image is just the first one in the list on NaviFirm you'll see it there!

All my contacts are cloud synced to LIVE.com account. They all are stored in international format with the exception of few that I haven't bothered about. I will try to find the stock rom and see how that goes. Thanks for the help.

#13 thechronic

thechronic

    Neowinian Senior

  • Joined: 21-July 05
  • Location: UK

Posted 26 January 2013 - 16:15

Oh ok. What I meant was that when you restart the phone, you no longer see the carrier logo. It just shows the Nokia and Windows Phone and that is it. With branded devices it shows carrier logo upon startup.


no Carrier logo but i dont think it did to start with to be honest.

#14 Detection

Detection

    Detecting stuff...

  • Joined: 30-October 10
  • Location: UK
  • OS: 7 SP1 x64

Posted 30 January 2013 - 21:16

Seems people are already managing the update their Lumia 800s to the official 7.8 via Zune using the disconnect trick and going about it the normal way by the sounds of it

http://forum.xda-dev...d.php?t=2125565

#15 iwan87

iwan87

    Neowinian

  • Joined: 25-February 13

Posted 25 February 2013 - 08:27

All my contacts are cloud synced to LIVE.com account. They all are stored in international format with the exception of few that I haven't bothered about. I will try to find the stock rom and see how that goes. Thanks for the help.


Did you have any luck here? Telstra are killing me with the wait but still no Australian variant on navifirm!



Click here to login or here to register to remove this ad, it's free!