Jump to content



Photo

Changing the IRC protocol association on Windows 8

win8

  • Please log in to reply
8 replies to this topic

#1 Lee G.

Lee G.

    Neowinian Senior

  • Joined: 28-October 04
  • Location: London, UK
  • OS: Windows 8.1

Posted 25 January 2013 - 23:08

Hello,

I would like to remove Google Chrome's association with the IRC protocol. If I open an IRC link from Run, such as irc://irc.neowin.net/neowin, Google Chrome opens. I would like mIRC to be associated with this protocol.

I've tried removing the association using Set Default Programs, but have had no success. It will only allow me to change it to a Windows 8 app.

Posted Image

The checkbox cannot be unchecked.

Posted Image

I checked the association using a program called FileTypesMan, and it shows that the IRC protocol is associated with mIRC. It's being overridden by Chrome in some way. I've searched through Chrome's settings, but have found no way to remove the association.

Posted Image

Any help to fix this is appreciated.


#2 syobon999

syobon999

    Neowinian

  • Joined: 22-December 09

Posted 26 January 2013 - 03:12

Thats the same with Comodo Dragon here

#3 prz

prz

    minimalism

  • Joined: 13-September 03
  • Location: White Salmon, Washington
  • OS: Windows 8, Mountain Lion, iOS 6, Android Jellybean
  • Phone: Motorola Droid Razr

Posted 25 February 2013 - 02:20

This is a deal breaker for me.

#4 Torolol

Torolol

  • Joined: 24-November 12

Posted 25 February 2013 - 02:34

yep, association problem still happens even with the new windows 8's association scheme.
better complain to Chrome devs to ask how to un-associate the "irc://", then re-install the mIRC.

#5 syrist

syrist

    Resident One Post Wonder

  • Joined: 09-March 13

Posted 09 March 2013 - 20:31

I was able to remove the IRC association from Google Chrome by making this simple registry change:
  • Go to HKEY_LOCAL_MACHINE\SOFTWARE\Clients\StartMenuInternet\Google Chrome\Capabilities\URLAssociations\
  • Then delete the IRC line
That's it. I tested it on my Windows 8 machine and clicking on an IRC link in Chrome launches mIRC and prompts me to connect to the server. This is assuming you have the IRC links assosicated with mIRC.

Here... I made a simple registry file that will make the Chrome changes as well as associate IRC and XDCC links to mIRC:

Windows Registry Editor Version 5.00
[HKEY_CLASSES_ROOT\irc]
@="URL: IRC Protocol"
"URL Protocol"=""
[HKEY_CLASSES_ROOT\irc\shell\open\command]
@="C:\\Program Files (x86)\\mIRC\\mirc.exe %1"
[HKEY_CLASSES_ROOT\xdcc]
@="URL: XDCC Protocol"
"URL Protocol"=""
[HKEY_CLASSES_ROOT\xdcc\shell\open\command]
@="C:\\Program Files (x86)\\mIRC\\mirc.exe %1"
[HKEY_LOCAL_MACHINE\SOFTWARE\Clients\StartMenuInternet\Google Chrome\Capabilities\URLAssociations]
"irc"=-

Hope this helps...

-Pete

#6 prz

prz

    minimalism

  • Joined: 13-September 03
  • Location: White Salmon, Washington
  • OS: Windows 8, Mountain Lion, iOS 6, Android Jellybean
  • Phone: Motorola Droid Razr

Posted 11 March 2013 - 08:42

I was able to remove the IRC association from Google Chrome by making this simple registry change:

  • Go to HKEY_LOCAL_MACHINE\SOFTWARE\Clients\StartMenuInternet\Google Chrome\Capabilities\URLAssociations\
  • Then delete the IRC line
That's it. I tested it on my Windows 8 machine and clicking on an IRC link in Chrome launches mIRC and prompts me to connect to the server. This is assuming you have the IRC links assosicated with mIRC.

Here... I made a simple registry file that will make the Chrome changes as well as associate IRC and XDCC links to mIRC:

Windows Registry Editor Version 5.00
[HKEY_CLASSES_ROOT\irc]
@="URL: IRC Protocol"
"URL Protocol"=""
[HKEY_CLASSES_ROOT\irc\shell\open\command]
@="C:\\Program Files (x86)\\mIRC\\mirc.exe %1"
[HKEY_CLASSES_ROOT\xdcc]
@="URL: XDCC Protocol"
"URL Protocol"=""
[HKEY_CLASSES_ROOT\xdcc\shell\open\command]
@="C:\\Program Files (x86)\\mIRC\\mirc.exe %1"
[HKEY_LOCAL_MACHINE\SOFTWARE\Clients\StartMenuInternet\Google Chrome\Capabilities\URLAssociations]
"irc"=-

Hope this helps...

-Pete



Hey thanks a million, literally saved me from reverting to 7 for now!

#7 savantique

savantique

    Neowinian

  • Joined: 07-April 12

Posted 08 December 2013 - 20:01

I just encountered the same issue and the registry entry, while conveniently adding XDCC protocol functionality, did not alter the IRC protocol from being handled by Chrome. I really don't understand why this could be and would really appreciate it if someone could take another look at this and offer a solution.



#8 crislee

crislee

    Resident One Post Wonder

  • Joined: 13-January 14

Posted 13 January 2014 - 08:00

I registered just because of this issue.  I use the following method as quoted, as soon as it is removed, it works, but only a bandaid (temporary) fix.  As soon as you restart your Win 8, the IRC association in the regedit in the location as quoted below will come back haunting again.

 

Any other options?

Thanks.

 

I was able to remove the IRC association from Google Chrome by making this simple registry change:

  • Go to HKEY_LOCAL_MACHINE\SOFTWARE\Clients\StartMenuInternet\Google Chrome\Capabilities\URLAssociations\
  • Then delete the IRC line
That's it. I tested it on my Windows 8 machine and clicking on an IRC link in Chrome launches mIRC and prompts me to connect to the server. This is assuming you have the IRC links assosicated with mIRC.

Here... I made a simple registry file that will make the Chrome changes as well as associate IRC and XDCC links to mIRC:


Windows Registry Editor Version 5.00
[HKEY_CLASSES_ROOT\irc]
@="URL: IRC Protocol"
"URL Protocol"=""
[HKEY_CLASSES_ROOT\irc\shell\open\command]
@="C:\\Program Files (x86)\\mIRC\\mirc.exe %1"
[HKEY_CLASSES_ROOT\xdcc]
@="URL: XDCC Protocol"
"URL Protocol"=""
[HKEY_CLASSES_ROOT\xdcc\shell\open\command]
@="C:\\Program Files (x86)\\mIRC\\mirc.exe %1"
[HKEY_LOCAL_MACHINE\SOFTWARE\Clients\StartMenuInternet\Google Chrome\Capabilities\URLAssociations]
"irc"=-
Hope this helps...

-Pete

 



#9 hasamalaha

hasamalaha

    Resident One Post Wonder

  • Joined: 19-July 14

Posted 19 July 2014 - 17:42

I registered just because of this issue.  I use the following method as quoted, as soon as it is removed, it works, but only a bandaid (temporary) fix.  As soon as you restart your Win 8, the IRC association in the regedit in the location as quoted below will come back haunting again.

 

Any other options?

Thanks.

I'm having this same issue.  Registry works until I restart my computer.  Did you ever find a fix?  





Click here to login or here to register to remove this ad, it's free!