Sign in to follow this  
Followers 0

Windows 8.1 Won't Sleep When Idle


19 posts in this topic

Posted

Ever since I upgraded to the Windows 8.1 beta (and even now with the Windows 8.1 RTM), my computer will not idle to sleep. This wouldn't be that much of a problem since I almost always remember to put it to sleep before walking away. But sometimes the computer will wake on its own through a scheduled task, and then the computer will stay on until I return to it. (By the way, I'd rather not disable scheduled tasks from being able to wake the machine.)
The computer is set to sleep after 30 minutes of inactivity. I have set the Power Option "When sharing media" to "Allow the computer to sleep." I have deactivated all "wake_armed" devices so that

powercfg /devicequery wake_armed

returns

NONE

I have installed all the drivers Windows couldn't automatically detect (of which there was only my "Creative Game Port"). Finally, I have generated a report from

powercfg /energy duration 3600

Originally, it informed me of a few problems, such as the "When sharing media..." setting. As I said earlier, I have now set the "When sharing media" setting to "Allow the computer to sleep." Here is the report, which seems to suggest that I have no further serious problems:
https://skydrive.live.com/redir?resid=3D3292D8A7DEC2F4!17449&authkey=!AIllZ4c3A8_-XHU
SkyDrive will probably show the HTML upon clicking above. Try clicking Download and then opening the file. Thank you for your help.
I originally posted this on Super User, but I haven't received any respones.

Share this post


Link to post
Share on other sites

Posted

check all of your devices in device manager and disable "Allow this device to wake..."?

Share this post


Link to post
Share on other sites

Posted

i have this same issue since i upgraded to 8.1 this week

 

i check "powercfg /requests" and they all say none yet my computer won't go to sleep on its own

 

in my instance i upgraded from 8 using the keep all option

Share this post


Link to post
Share on other sites

Posted

xendrome, I think

powercfg /devicequery wake_armed
should reveal all devices which have that setting enabled. Either way, I've checked the usual suspects, and none of them are allowed to wake the computer.

Brando212, I upgraded from Windows 8 to 8.1 beta, which is when I first noticed this problem. But with the final version, I performed a clean install, and the problem remains. But maybe you could discover the source of your problem with

powercfg /energy duration 3600
The result of that operation is pretty insightful, although it still didn't help me.

Share this post


Link to post
Share on other sites

Posted

For me the fix was to leave the Homegroup. Not sure why this is broken but that fixed the sleep issue across two machines.

3 people like this

Share this post


Link to post
Share on other sites

Posted

Kool Box, nice going!  That was the trick.  Thank you very much.

Share this post


Link to post
Share on other sites

Posted

hmm, i'll have to check this when i get home. i don't think my effected computer is part of a home group though

Share this post


Link to post
Share on other sites

Posted

Brando212, Windows 8.1 automatically started a Homegroup for me.  Windows 8 did not do this, so I'm guessing that's why Windows 8.1 has this problem.

Share this post


Link to post
Share on other sites

Posted

I had this same problem. It ended up being my Logitech USB wireless receiver that came with my keboard/mouse combo causing it.

Share this post


Link to post
Share on other sites

Posted

interesting, did it show under "powercfg /requests" for you?

 

i have logitech wireless mouse/keyboard on mine but it doesn't show up on that command

 

edit: also yeah I checked and my computer definitely isn't part of a homegroup. when i click on homegroup it asks if i want to join one. so that's not the problem for me

Share this post


Link to post
Share on other sites

Posted

gonna set

powercfg /energy duration 3600

before i go to bed tonight to see if it shows any results. so far i haven't been able to find any reason why my computer won't go to sleep.

 

though GreyWolf's post makes me wonder if my problem is the same as his

Share this post


Link to post
Share on other sites

Posted

I had the same problem with 8.1 (RTM) fresh install.

Its joined up to a Server 2012 Essentials server, and not part of a homegroup. However, removing the PC from the non existent home group solved the issue for me!

Thanks!

Share this post


Link to post
Share on other sites

Posted

Disabling Home Group worked for me. -Windows 8/1 Pro Preview Build 9431

Share this post


Link to post
Share on other sites

Posted

Well, the problem is back :(

 

powercfg /requests shows nothing...

Share this post


Link to post
Share on other sites

Posted

All computers that are using HOMEGROUP have to all be on the same HOMEGROUP and have to be properly configured to share something before any of the computers will auto sleep properly.

Example, I had two computers on Win 8.1 Pro (which automatically starts a HOMEGROUP when installed) that would NOT connect using my old HOMEGROUP password. I created a new HOMEGROUP password and managed to get these two computers to share files. However, there was a THIRD computer on the network (with Win 8) who had the old HOMEGROUP password. I successfully changed it to the new HOMEGROUP by leaving and rejoining using the new password. Yet I could not see any files on this last computer. I had to UNSHARE with the HOMEGROUP all of the files and folders under users. Then I shared the one folder that I wanted to share. That worked and that also FINALLY let my computer sleep!

 

Two other things. The computers do NOT have to be booted up to cause this issue. You can easily tell if this is your problem by disabling your network adapter, setting sleep for one minute and waiting 5 minutes to see what happens.

Share this post


Link to post
Share on other sites

Posted

For me the fix was to leave the Homegroup. Not sure why this is broken but that fixed the sleep issue across two machines.

It doesn't work for me. :|

Share this post


Link to post
Share on other sites

Posted

You might have same problem as I had with Windows 8.1. It was network settings related. My PC did not sleep because of LanmanServer service and one sharing setting that I had enabled. To disable LanmanServer service, you need to go to services. Just type services to RUN row and press enter. All services are opened before you. Find LanmanServer service and press right button of your mouse. Stop it and disable its automatic start and it won't start with Windows anymore. Next you need to disable that one jamming network sharing setting. Open network and sharing center by right clicking your WLAN bars. Then press "change advanced settings for sharing". Press All networks and click Disable sharing of public folders. That did it for me, the computer sleeps!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.