Broken spring tab thingy on the back of my subwoofer


Recommended Posts

quadz0

The little spring tab on the back of my sub (Klipsch Promedia 2.1) went missing so I can't hold any wires in there now. I've attached a picture if you don't know what I'm talking about

What options do I have to remedy the situation? I was considering stuffing a piece of styrofoam or something in there to keep the wire in place, but I don't know how safe that would be...

Thanks

post-154782-0-25727600-1314828165.jpg

Link to post
Share on other sites
uniacidz

Is fine.

The plastic just holds it in place against the metal terminal, just use something to do the same. Doesnt have to look good, just needs to be secure

Link to post
Share on other sites
shakey

The plastic is just extra hold... which if you aren't moving it around much, you shouldn't really need. If you are unable to find something that you can use as another holder, just strip the wire down enough, ball up the exposed wire, and sort of jam it in, so that it will hold in there... My receiver has one of this almost broken off... I was able to get the plastic piece back on and used a spring from some other old thing to make it work properly, but in the long run, not really needed.

Link to post
Share on other sites
quadz0

Awesome, I figured it wasn't a big deal. Just wanted to be sure.

Thanks!!

Link to post
Share on other sites
jerzdawg

I think electrical tape could have worked as well... make sure the exposed part of the wire is fully inserted and then just put the tape across the back, should have 0 negative effects

Link to post
Share on other sites
This topic is now closed to further replies.
  • Recently Browsing   0 members

    No registered users viewing this page.