Z-5500 control pod wire damaged


 Share

Recommended Posts

Hello Neowin!

My sisters Hamster got away a few days ago and chewed through a hard to replace cable... :(

I was wondering if anyone could assist me in which direction to go in terms of replacing this cable?

post-254276-0-25548000-1315157550.jpg

Cheers,

Phil.

Link to comment
Share on other sites

They don't do spare control pods..

I'd recommend sourcing a replacement or splicing the cable and attaching new wire then heat shrink it

yes they do. the analog cables on my set went and they said all they could do is send me a spare control pod... call them.

Link to comment
Share on other sites

I have 3 times and they said they don't supply them...

Yep, they said they don't repair them... told me to get in contact with a local audio shop for repairs :\

The first response i get charges $45 for an estimate :no:

Link to comment
Share on other sites

  • 3 weeks later...
  • 7 years later...

Similar problem here...  Trusty faithful Z500 unit playing up and isolated to control cable.  It's like $500 or so to upgrade to a unit that is as good or better.  What a waste of money.

 

So I am wondering if I can just repair this control cable.

 

Any ideas please.  The images above don't work (cannot be found).  So I am hoping I can just splice the cable on to a new connector.

Link to comment
Share on other sites

Please don't resurrect old threads from the grave.

 

Feel free to start a new topic with respect to your question.

 

//locked

Link to comment
Share on other sites

  • Jim K locked this topic
This topic is now closed to further replies.
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.