• Sign in to Neowin Faster!

    Create an account on Neowin to contribute and support the site.

Sign in to follow this  

Nvidia Drivers

Recommended Posts

DjmUK    0

This guide will give you step-by-step instructions on installing Linux Nvidia Display Drivers.

Just like with the ATi guide, you should make sure that your kernel-source is installed, and correctly symlinked to /usr/src/linux (most rpms should do this for you).

* Remember to kill the X server before installing the drivers. This can be done with ctrl-alt-backspace. If you use a graphical logon manager such as gdm, hit ctrl-alt-backspace, then hit ctrl-alt-f1, then, as root, do a killall gdm.

Nvidia Download Page - Version (1.0-4496)

Supported Nvidia Graphics Cards, under (app-a) APPENDIX A

Download The Drivers - Size (7.81 MB)

Make sure you have XFree86 4.0.1 or higher installed before starting (latest version to this date is 4.3.1):

XFree86 --version

- I am going to assume that you placed the downloaded drivers into your /tmp directory for this guide.

- You want to be outside of the 'X' server to install these drivers (as noted above).

- From here, you should be at the command line prompt and you've logged in as root.

Change directory (to where the drivers are located):

cd /tmp

Installation:

sh NVIDIA-Linux-x86-1.0-4496-pkg2.run

- Follow the onscreen instructions (mainly pressing Yes/OK to all the prompts).

- You will be asked a question regarding compiling the Kernel, so let it do that for you. With me, a little error message appeared saying that my kernel isn't compiled for this (or something to that affect)...but the good news is that it will download an update from their FTP server and automatically configure it for you.

- That's it, all done. When the installation has completed, I would recommend rebooting your PC - just to make sure that all went well.

Now you will need to edit a single line from a file named XF86Config before the new drivers will work (/etc/X11/XF86Config):

If you already have an XF86Config file working with a different driver (such as the 'nv' or 'vesa' driver), then all you need to do is find the relevant Device section and replace the line:

Driver "nv" (or Driver "vesa")

with 

Driver "nvidia"

In the Module section, make sure you have:

Load "glx"

You should also remove the following lines:
    
Load "dri"
Load "GLcore"

Useful Driver Update Commands

Log in as root (or "su" from a terminal point) and run one of the commands below in any directory you're in:

nvidia-installer --latest
nvidia-installer --update
nvidia-installer --uninstall

What do they do?

--latest (Displays a record of the latest drivers available)
--update (Same as "--latest", but auto-installs the latest ones for you)
--uninstall (I think you can figure this one out)

Common Problem (Kernel Upgrade)

Q: I just upgraded my kernel, and now the NVIDIA kernel module won't load. What's wrong?

A:The kernel interface layer of the NVIDIA kernel module must be compiled specifically for the configuration and version of your kernel. If you upgrade your kernel, then the simplest solution is to reinstall the driver.

ADVANCED:

You can install the NVIDIA kernel module for a non running kernel (for example: in the situation where you just built and installed a new kernel, but haven't rebooted yet) with a command line such as this:

sh NVIDIA-Linux-x86-1.0-4496-pkg1.run --kernel-name='KERNEL_NAME'

Where 'KERNEL_NAME' is what `uname -r` would report if the target kernel were running.

* This guide worked for me with no problems on (Red Hat 9 / Kernel 2.4.20-20.9 / XFree86 4.3.0 / GeForce 2 Pro / TFT & CRT Monitors).

* Some of the quotes/notes were taken from Nvidia's README file & from the ATi Guide.

Share this post


Link to post
Share on other sites
Li_Lee    0

Wow, thanks DjmUK

A great guide, I'll try this sometime seens as I havn't tried installing the drivers before :)

Share this post


Link to post
Share on other sites
MR_Candyman    114

I'd try this if I still had my old nvidia card...maybe when I "accidentally" install linux on my GF's comp (which has my od card) then I'll try it....

but thanks for the tip man, a lot of people will benefit from it

Share this post


Link to post
Share on other sites
Scoody    0

Instead of killing the X server "that" way, you can use "init 3" as root, do your stuff and then "init 5"

Share this post


Link to post
Share on other sites
DjmUK    0

init 3 sometimes works with me, although it doesn't always work in "su" for some reason. Oh well, now there's 2 ways of getting there :)

Share this post


Link to post
Share on other sites
rezza    0

"init 3" doesn't work for some people, me included, because I'm always in runlevel 3 when i'm not shutting down/booting/rebooting... I don't have X starting up automatically when i boot...

Share this post


Link to post
Share on other sites
Daem0hn    0

for those gentoo users to get the latest versions

emerge nvidia-kernel && emerge nvidia-glx && modprobe nvidia

then update your /etc/X11/XF86Config file

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.