• Sign in to Neowin Faster!

    Create an account on Neowin to contribute and support the site.

  • 0
Sign in to follow this  

All USB Ports have suddenly stopped working

Question

Zimmyantz    9

Hi Neowinians,

Hopefully your pearls of wisdom can help me out once again.

On Friday night, I left my computer running while i slept, for updates to complete etc...(Done this many times).

On Saturday I went to use the PC and noticed my G5 and G15 Mouse/Keyboard were not lit up in the normal way, as if they were not plugged in. I decided to reboot, to see if that would fix the problem, unfortunately not, everything usb, including external hard drive and wireless adapter are not being picked up.

Decided that their may have been a power surge on the USB, so unplugged everything, left it for a few hours and retried, same result, nothing. Luckily I have a PS2 keyboard in reserve for just this occasion.

I then decided to see if a Windows 7 reinstall would cure the problem as I only really have that on my Primary. This also had no effect and the USB's are still not working.

OK I said, lets dismantle the PC and re-build, maybe something has some out, completely dis-assembled it, re-assembled it, tried boot up and again the USB's are not working.

This time, google searched the issue, on advise, tried to see if he registry key was set to 3 for the USBSTOR, as it was.

Also checked BIOS to ensure that USB was enabled, it is.

There was talks to a virus possibly doing this, but would the OS Reinstall not have hit that?

Next step is an RMA, so if anyone thinks they might know the issue, here are the PC Specs:

Windows 7 64bit

i5 3570K running at 4.2 (but have tried clear CMOS thinking it might cure my problem), so now at stock.

Noctua Heatsink

2gb Radeon 7950HD

8gb Corsair Vengeance Ram

MSI Z77A G45 Motherboard

OCZ Agility 3 SSD

Any help is appreciated

To Add, this includes the front USB Ports on the case.

Share this post


Link to post
Share on other sites

Recommended Posts

  • 0
Crisp    3,271

Did you try resetting the CMOS by pulling the battery and waiting 5 minutes?

Share this post


Link to post
Share on other sites
This topic is now closed to further replies.
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.