• Sign in to Neowin Faster!

    Create an account on Neowin to contribute and support the site.

  • 0
Sign in to follow this  

[Q] Problem with configration modem and router

Question

MaPa    7
Hi all.

 

 

I have a little hardware issue. 

My ISP delivers modem. Before I bought additional router all my devices connects to this modem. But this modem have poor wifi signal, so I bought D-link dir-300. 

 

Now, the best part. Modem deliver following ip configuration: 192.168.0.100 to 192.168.0.139 and subnet mask 255.255.255.0. Working configuration d-link: router ip: 192.168.0.140, ip range 192.168.0.141 to 192.168.0.170. 

 

Where is the problem? If I connect smartphone or laptop to d-link I can not browse shared folders on laptop which is connected to modem. 

 

How can I resolve that problem?

Share this post


Link to post
Share on other sites

10 answers to this question

Recommended Posts

  • 0
sc302    1,792

Let me know if this makes any more sense to you.  the dlink is on the left and this is what we are concentrating on.  the modem on the right is just a random modem, substitue that with your modem.  Disable dhcp on the dlink, set the lan to 192.168.0.2, make sure the wireless ssid and passkey is the same (upper/lower count, spaces and punctuation count as well...Home is not the same as home).  DHCP will pass to the clients connected to the dlink up to the modem for all ip requests.  The dlink is no longer a router, all it does is pass traffic up to the modem.

post-118098-0-60227700-1371499818.jpg

Share this post


Link to post
Share on other sites
  • 0
sc302    1,792

If you connected the modem to the dlink internet port, the modem (untrusted network) and the dlink lan (trusted network) are in the same ip subnet. 

 

Change the dlink internal network or lan to 192.168.1.x vs 192.168.0.x and your stuff will magically start working again.

Share this post


Link to post
Share on other sites
  • 0
Brandon C.    116

If you connected the modem to the dlink internet port, the modem (untrusted network) and the dlink lan (trusted network) are in the same ip subnet. 

 

Change the dlink internal network or lan to 192.168.1.x vs 192.168.0.x and your stuff will magically start working again.

^This

And I would connect the laptop to the DLINK lan instead of the modem.

Share this post


Link to post
Share on other sites
  • 0
MaPa    7

ok, I set exactly what you say sc302 but now I can not manage trought laptop connected to modem not d-link.

Share this post


Link to post
Share on other sites
  • 0
sc302    1,792

you need to not connect to the modem, you need to connect to the dlink. 

 

The only way for you to manage when connected to the modem is to not use the physical internet/wan connection on the dlink and to use one of the LAN ports on the dlink (removing the cable from the internet port and putting that cable in one of the LAN ports), disable the dhcp on the dlink, and give the dlink internal ip or lan ip of something in the 192.168.0.x range preferably outside of the dhcp scope that the modem is handing out.  If what you are trying to do is to simply have another access point for more coverage this is the preferred method. 

Share this post


Link to post
Share on other sites
  • 0
MaPa    7

hm.... so there is no way ? I have to connect my TV to d-link because it stands in differernt room. I know that I can connect media server to d-link too but I prefer quiet :) 

Share this post


Link to post
Share on other sites
  • 0
sc302    1,792

I am not understanding the issue.  I gave two scenerios that work, one using the internet port and the other not using the internet port of the dlink.  If you dont use the internet port on the dlink, you can manage the dlink from your modem, if you use the internet port on the dlink you cannot.

 

You being able to use the internet port has nothing to do with access, it is just a port label to make life easy for people who don't have multiple routers that simply want to expand their wireless coverage or put one of these devices in another room.

Share this post


Link to post
Share on other sites
  • 0
MaPa    7

so I should insert cable not to ethernet port in d-link ?

Share this post


Link to post
Share on other sites
  • 0
MaPa    7

ok, let me try :) 

Share this post


Link to post
Share on other sites
  • 0
MaPa    7

12565210363CWV3S.jpg

thank you so much :) no works perfect !!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.