• 0

How to use dual networks on Windows XP?


Go to solution Solved by Roger H.,

Question

Ice_Blue

Dell Optiplex Windows XP system with on-board ethernet and add-on PCI wireless card.

The PCI wireless is connected to the Internet via ISP provided wireless router.

The on-board ethernet is connected to the LAN.

Only one connection works at a time, i.e. when I plug in the ethernet cable, the wi-fi stops working, and vice versa.

How can I get both to work simultaneously?

Wi-fi Adapter:
IP: 192.168.1.10
Default Gateway: 192.168.1.1
Subnet Mask: 255.255.255.0

Ethernet Adapter:
IP: 192.168.0.2
Default Gateway: 192.168.0.1
Subnet Mask: 255.255.255.0

 

Googling this turns up a plethora of conflicting advice.

Hopefully, someone here can straighten this out.

 

Link to post
Share on other sites

11 answers to this question

Recommended Posts

  • 0
Roger H.

Not my forte but do you want the LAN to only work for local file transfers or is it another ISP connection?

 

You could proably remove the default gateway from the LAN (i think) or set some priorities in the properties of the WLAN connection?

Link to post
Share on other sites
  • 0
Ice_Blue

Not my forte but do you want the LAN to only work for local file transfers or is it another ISP connection?

 

Yes. The LAN is only used to share files locally.

Link to post
Share on other sites
  • 0
+BudMan

Then as Roger correctly stated already just remove the gateway from that network interface, since it has no "gateway" off the 192.168.0.0/24 network.

  • Like 1
Link to post
Share on other sites
  • 0
1ON

When you say stop working - What exactly do you mean?

 

NIC / WLAN adapter show as disconnected? or pings drop to devices on each subnet?

Link to post
Share on other sites
  • 0
Ice_Blue

When you say stop working - What exactly do you mean?

 

NIC / WLAN adapter show as disconnected? or pings drop to devices on each subnet?

 

It doesn't disconnect. There is simply no response when trying to access shared folders on the LAN, and Firefox says "Page cannot be found"

Then as Roger correctly stated already just remove the gateway from that network interface, since it has no "gateway" off the 192.168.0.0/24 network.

 

OK, will try this a.s.a.p.

Bah had to login on firefox to be able to paste links in this WYSIWYG editor >.>

 

http://superuser.com/questions/67408/use-wireless-and-wired-connections-at-the-same-time

 

Seems to be what Budman and Roger says. Will try and report.

It's at one of my client's office.

Link to post
Share on other sites
  • 0
Top Qat

Are the computers on the LAN side connected to the internet?

 

If not, use could use Internet Connection Sharing (ICS) on the Win XP machine.

That way your internet access will work and the LAN side will have access to your PC and the internet.

Link to post
Share on other sites
  • 0
+theblazingangel

Then as Roger correctly stated already just remove the gateway from that network interface, since it has no "gateway" off the 192.168.0.0/24 network.

 

Precisely (Y)

Link to post
Share on other sites
  • 0
froggyliver

The faster connection should be the connection Windows uses. This is usually the Ethernet connection. I "think" you need a server OS to use both.

Link to post
Share on other sites
  • 0
Ice_Blue

Are the computers on the LAN side connected to the internet?

 

No. It's purely for file sharing.

Link to post
Share on other sites
  • 0
The_Observer

Remove the Gateway and DNS on your LAN. I have this setup for one of my servers at home (two internet connections)

 

Wireless - DHCP

LAN - Static IP address and Subnetmask (No Gateway and DNS)

 

While im not using Windows XP. I think you should be fine with this setting.

  • Like 1
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.