• Sign in to Neowin Faster!

    Create an account on Neowin to contribute and support the site.

  • 0
Sign in to follow this  

Google thinks I'm in a different country

Question

bomba6    5

I'm from Israel.

My IP starts with 46.x.x.x.

whatismyipaddress shows me correctly on the map.

 

BUT,

since today Google thinks I'm in Germany:

* Youtube shows suggestions from Germany

* Play Store is fully open (include buying devices like Nexus 5). Devices, magazines, music etc. are NOT available in Israel.

* Pretty much every google service thinks I'm from Germany.

 

I haven't installed any proxies, any software...

 

Are there any other people with the same problem as mine right now?

 

Is there a way I could "debug" this?

 

Thanks!

Share this post


Link to post
Share on other sites

25 answers to this question

Recommended Posts

  • 0
bomba6    5

Thanks paul0544, but it is something more fundamental than this.

I'm not just being redirected to another Google domain, I'm actually getting content that is blocked in my country.

On the other hand, I'm not getting content which is NOT blocked in my country.

  • Like 1

Share this post


Link to post
Share on other sites
  • 0
DConnell    6,580

You'd better move before Google realizes you're not where you're supposed to be! :woot:

  • Like 3

Share this post


Link to post
Share on other sites
  • 0
Jason S.    1,495

i had this problem once too - my acct was showing up in Mexico. Suspecting my acct was hacked i quickly changed my pw and enabled 2-factor auth. Problem hasnt happened since.

Share this post


Link to post
Share on other sites
  • 0
Trap    3

I've had this before also.

Share this post


Link to post
Share on other sites
  • 0
link6155    791

Google worked fine for me, but YouTube always thinks I'm in the UK when I'm really in the US. Not a big issue since there's only a few word changes, but it's a bit annoying that it displays a banner at the top saying that the language has been set to UK.

Share this post


Link to post
Share on other sites
  • 0
bomba6    5

@ChuckFinley Thanks, I filled the form.

I doubt they will look at it.

 

I'm trying to connect my ISP to change my IP.

Share this post


Link to post
Share on other sites
  • 0
+John Teacake    454

Most likely rebooting your modem or router would do that. They would distribute another from their pool. Other than that you wouldn't get another ip.

Share this post


Link to post
Share on other sites
  • 0
bomba6    5

Tried that. Rebooted both my router and modem. Disconnected both of them from power supply. Disconnected any cable that was connected to the modem.

I forgot to mention that I am connected over MPLS.

My ISP says my IP will be changed in about 3 months, and they can do nothing about that.

 

(Actually things in here are complicated because we have one company that provides the "infrastructure" and another company which is the ISP. They refuse to speak with each other, no matter what is the problem. It is easier this way to tell the user "its the other company's problem".)

Share this post


Link to post
Share on other sites
  • 0
Nashy    1,661

They try that here sometimes too, in Australia.  Ombudsman fixed this.

Last time I had this issue, it was due to a DNS addon I had in Chrome.

Share this post


Link to post
Share on other sites
  • 0
+John Teacake    454

Ahhhh OK I see. Well you could find the fastest DNS server in your country by using namebench or DNSBench. Set your system DNS then try again.

Share this post


Link to post
Share on other sites
  • 0
bomba6    5

I ran namebench, ALL my results appear like this:

  • www.google.com is hijacked: 173.194.112.52, 173.194.112.50, 173.194.112.49, 173.194.112.51, 173.194.112.48
  • google.com appears incorrect: 212.199.219.247, 212.199.219.221, 212.199.219.227, 212.199.219.237, 212.199.219.226, 212.199.219.217, 212.199.219.216, 212.199.219.222, 212.199.219.251, 212.199.219.236, 212.199.219.232, 212.199.219.246, 212.199.219.241, 212.199.219.231, 212.199.219.242, 212.199.219.212
  • twitter.com appears incorrect: 199.16.156.38, 199.16.156.6, 199.16.156.198

Anyway, I changed the DNS in my router, but it didn't solve the problem.

212.199.219.* is my ISP BTW.

Share this post


Link to post
Share on other sites
  • 0
+John Teacake    454

You would definately need to reboot or at least flush your caches before checking this. Rebooting is the easiest way. Also check that your clients are all signing from the same hymn sheet with regards to DNS servers. Try setting them on Windows clients and see if that helps.

Share this post


Link to post
Share on other sites
  • 0
bomba6    5

I'm behind a router (TP-LINK 741 with dd-wrt).

This just started 2 days ago, without me installing anything on any machine nor changing any configuration in the router.

I've done factory reset to the router as well and the problem remains.

 

All the clients show DNS entries of 192.168.1.101 which is my router.

 

I have now surfed to another site which is not Google and found that it has redirected me to the Dutch version. So I'm beginning to think the problem is deeper than I thought...

Share this post


Link to post
Share on other sites
  • 0
+John Teacake    454

Your not going through some kind of corporate proxy are you?

Share this post


Link to post
Share on other sites
  • 0
bomba6    5

No. At home. Private user. No proxies are defined or have ever been.

I factory reseted the router just to be sure. It gets the DNS of my ISP. As I mentioned, changing the DNS didn't help.

 

Edit:

this is tracert to google.com:

C:\Users\x>tracert -d google.com

Tracing route to google.com [212.199.219.212]
over a maximum of 30 hops:

  1     1 ms     2 ms    <1 ms  192.168.1.101
  2     9 ms     9 ms    29 ms  10.159.160.1
  3     *       11 ms     *     212.199.24.218
  4    12 ms    10 ms     9 ms  212.199.24.217
  5    14 ms     9 ms    27 ms  212.199.219.212

Trace complete.

212.199.* are all of my ISP.

Share this post


Link to post
Share on other sites
  • 0
Torolol    926

how about logout, then login via country specific google like

google.co.il ?

Share this post


Link to post
Share on other sites
  • 0
bomba6    5

@Torolol I tried that. Didn't work.

I tried opening private browsing so no cookies and stuff. Didn't work.

 

Again- I'm getting content that is only available in Germany in my case- like the Google play store with the ability to buy music, books, devices- which are not available in Israel.

So even if YOU (or anyone else) will change its location settings on Google, you will NOT gain access to content which is normally not available in your country. This could be achieved by using proxies, which spoofs your IP so Google thinks you are from a different country. This is NOT the case here as I'm not using proxy.

Share this post


Link to post
Share on other sites
  • 0
riahc3    440

Hello,

When you disconnected your modem and router, did you wait 5 minutes? ISP's hand out IPs but there is a short lease to them (very short, since there are few IPv4 left) so you have to disconnect them for a while (I usually do 5 minutes and it works). It doesnt seem you have a static IP so it should give you a new one. Then you can hope that new one is from your country.

Also of course I imagine you did your standard flushing of cache, DNS, etc...

Share this post


Link to post
Share on other sites
  • 0
bomba6    5

riahc3- things goes differently with my ISP. They lease the IPs for 3 months. So disconnecting will not work here.

They give each modem 3 IP addresses, so you can plug in 3 different sources to the modem (each source has it's own MAC address of course), and the modem has a "table" of MAC address and its corresponding IP.

They can send a "clear" command to the modem to clear it's MAC-IP binding (the MAC comes from the router) but they won't do that.

 

This was finally "solved" by "spoofing" the MAC address to the one from my PC (instead of the one of the router. This can be done in my DD-WRT firmware using "mac clone"). So now the modem "sees" my PC and assigns another IP address as this is a different MAC.

 

I can quickly reproduce this by setting back the MAC to my router's.

Share this post


Link to post
Share on other sites
  • 0
riahc3    440

Hello,

riahc3- things goes differently with my ISP. They lease the IPs for 3 months. So disconnecting will not work here.

They give each modem 3 IP addresses, so you can plug in 3 different sources to the modem (each source has it's own MAC address of course), and the modem has a "table" of MAC address and its corresponding IP.

They can send a "clear" command to the modem to clear it's MAC-IP binding (the MAC comes from the router) but they won't do that.

 

This was finally "solved" by "spoofing" the MAC address to the one from my PC (instead of the one of the router. This can be done in my DD-WRT firmware using "mac clone"). So now the modem "sees" my PC and assigns another IP address as this is a different MAC.

 

I can quickly reproduce this by setting back the MAC to my router's.

So you have 3 IPs without NAT enabled on your router?

Share this post


Link to post
Share on other sites
  • 0
bomba6    5

It has nothing to do with NAT on the router. The modem can give up to 3 IPs to the devices connected directly to it (i.e. a router, an IP phone, etc).

 

I might be wrong tho, I don't exactly know all the technical details, but I only know it helped solving my problem.

Share this post


Link to post
Share on other sites
  • 0
vcfan    2,338

sometimes if I unluckily end up on a google site, it sometimes gives me the Spanish version.

Share this post


Link to post
Share on other sites
  • 0
riahc3    440

Hello,

It has nothing to do with NAT on the router.

NAT allows multiple devices to use one public IP address. If you have 3 devices that need a IP and you have 3 IPs, you dont need NAT.

 

The modem can give up to 3 IPs to the devices connected directly to it (i.e. a router, an IP phone, etc).

You recieve 3 IPs I suppose because you have this agreement with your ISP right?

 

I might be wrong tho, I don't exactly know all the technical details, but I only know it helped solving my problem.

If you changed your MAC address and it works, that means that somewhere over the internet someone's MAC address is registered to recieve that IP.

You mentioned your ISP told you that your IP changes every 3 months: Do you have a static IP or a dynamic IP?

Share this post


Link to post
Share on other sites
This topic is now closed to further replies.
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.