• Sign in to Neowin Faster!

    Create an account on Neowin to contribute and support the site.

  • 0
Sign in to follow this  

Wireless N devices only connecting at 72 Mbps

Question

Lord Method Man    1,612

I have a Linksys EA6400 router and I run the 2.4 GHz radio in Mixed G and N mode and the 5 GHz radio in AC only mode. Last night I noticed that my 2.4 Ghz N devices were only connected at 72 Mbps, when they had previously been connecting at 144 Mbps, they have a full signal. One of my PCs is actually connecting at 6.5 Mbps which is how I noticed the problem to begin with.

 

I've tried resetting the router, Ive tried changing the channel on the 2.4 Ghz radio from Auto to 11, 6, and 1 and each time I connects at 72 Mbps. Channel width is also set to auto. What is causing this? I had no problem with N devices connecting at 144 before, now suddenly in the past couple days they are down to 72. Something is wrong.

 

Share this post


Link to post
Share on other sites

13 answers to this question

Recommended Posts

  • 0
+BudMan    3,720

I mention this only because I have seen it more times that you would think. 

 

Have you verified your actually connecting to your wireless, and not some wireless across the street ;)

 

Curious - why are you running Mixed G/N mode - do you also have G devices connecting or any G devices at all?  I am not a fan of mixed mode, if you have need for G devices I would run them on their own AP with a different ssid and channel.

 

Also are you using different SSIDs for your 2.4 and 5ghz - for example I normally add -5ghz or -ac or _5 or _ac to the to that ssid, especially if the ssid is the same. So forexample

 

2.4 yourssid

5 yourssid_5ghz

 

This way your very clear on which one your connecting to if using a client that can see both.  What encryption are you using - many N cards will only connect to N speeds if OPEN or WPA2, if your using mixed mode wpa/wpa2 tkip+aes this could cause issues.  But normally if that were the case you would see of 54mbit connection speed.

Share this post


Link to post
Share on other sites
  • 0
daorbed9    85

Set channel width to 40Mhz, it seems you are in 20Mhz.  Auto doesn't always work.

Share this post


Link to post
Share on other sites
  • 0
Lord Method Man    1,612

There is no 40 MHz option, only Auto and 20 MHz.

 

I thought it should connect at 144 Mbps with 20 MHz anyway, and 300 with 40 MHz.

Share this post


Link to post
Share on other sites
  • 0
daorbed9    85

Hmm its an AC router and it supports 300 at 2.4.  I dunno maybe reset the router and or try a firmware flash.  I doubt you see 144 at 20MHz much.

Share this post


Link to post
Share on other sites
  • 0
Lord Method Man    1,612

Just checked the AC network, its set to 80 MHz and I'm still able to connect to it at 867 Mbps just fine.

Share this post


Link to post
Share on other sites
  • 0
riahc3    440

Hello,

Checked your neighbor's wireless, as in what channel they are using?

Share this post


Link to post
Share on other sites
  • 0
Lord Method Man    1,612

No, haven't looked at any of that.

 

I'm mostly concerned with the PC that is now connecting at 6.5 Mbps, I only suspect its related to other devices also having their speed halved. Its a desktop running Windows 7 with a Linksys PCI 802.11n adapter.

Share this post


Link to post
Share on other sites
  • 0
Lord Method Man    1,612

Off the top of my head I don't know if I have any G devices left, I just ran it in mixed mode to have G available if needed. I know the SSIDs are right though as I name them "<Name> N" and "<Name> AC"

 

Pretty sure encryption on both radios is WPA2.

Share this post


Link to post
Share on other sites
  • 0
Lord Method Man    1,612

Ok so I switched the 2.4 GHz AP from Mixed to N-only and bam my 2 wireless N desktops shot up to 300 Mbps and my Surface 2 is now connecting at 150 Mbps. Seems like having it Mixed was part of the problem.

 

For whatever reason my laptop is still connecting at 72 Mbps. Win, I can not.

Share this post


Link to post
Share on other sites
  • 0
riahc3    440

Hello,

No, haven't looked at any of that.

Well, just in case, I would check on that too. Just to rule out any possibility.

Share this post


Link to post
Share on other sites
  • 0
+BudMan    3,720

"Seems like having it Mixed was part of the problem."

 

Seems like? heheheeh -- you will find some conflicting opinions to be sure around here.  There have been many a discussion about performance hit of mixed mode.  Some people think its not an issue, while the protocol and just common sense tells you differently ;)  There were many changes to the protocol from G to N.. Many of these new features can not be used if you have to allow for clients that do not understand them..  For example guard interval of 400ns vs 800ns, frame aggregation, etc.  Now if no clients actually connected there is mixed or protection mode, etc.  So depending what your router actually goes into could have an effect if no actual G clients connected and using the bandwidth at there slower speed.

 

You are always better to be in native N then Mixed environment, be it you will notice a the performance hit or not.. What does it matter all that much if your internet is only G speeds anyway ;)

 

What I would recommend to anyone that is moving from G to N or even AC -- just keep your older router and use it as AP to provide access to your older clients that do not support the new protocol.  This is been good advice when we went from B to G, G to N and now N to AC..  And will still be good practice when we go to AD.

 

Running mixed mode is not a good solution, unless you have no other choice..  Lets say your old G router died, doesn't make a lot of sense to get G again.. So you go with N or AC.. Which now all your clients that have support N for years can use that.. But if you still have some legacy G, other than spending more money for a G AP -- sure run mixed mode.  But as soon as your legacy G stuff is gone - switch to N only..  If you buddy comes over with his ancient pos laptop and wants to use your wireless and only has G, tell him to update his POS machine ;)

 

The only reason I have G running at all is my son's older laptop, hey I need a few bucks for free shipping anyway!!

http://www.amazon.com/TP-LINK-TL-WN725N-Wireless-Adapter-Miniature/dp/B008IFXQFU/ref=lh_ni_t?ie=UTF8&psc=1&smid=ATVPDKIKX0DER

 

This little mini N looks good, $9 and I can turn off my old G wrt54g router ;)  If not for your thread would of never thought of it and just left my G AP running.. 

 

If anyone interested in reading some of the differences in g vs n protocol that can effect performance - here is a few year old whitepaper from Motorola

Performance_Impact_of_802.11N_Capable_Access_Point.pdf

Share this post


Link to post
Share on other sites
  • 0
Lord Method Man    1,612

Gonna mark this as solved as turning off Mixed Mode seemed to fix just about everything.

Share this post


Link to post
Share on other sites
  • 0
ViperAFK    797

There is no 40 MHz option, only Auto and 20 MHz.

 

I thought it should connect at 144 Mbps with 20 MHz anyway, and 300 with 40 MHz.

Not all routers support 40mhz over 2.4ghz, and they almost always use 20mhz as the default setting. Even when they do its not always ideal, because using 40mhz width on 2.4ghz uses over half of the channels in the band, so its very susceptible to wireless interference (and can cause wireless interference for other people nearby).

 

http://www.smallnetbuilder.com/wireless/wireless-features/31743-bye-bye-40-mhz-mode-in-24-ghz-part-1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.