• 0

DNS help


Go to solution Solved by DaveLegg,

Question

ashpowell

Hi, 

 

Please excuse me as I'm not that good with server side stuff...

 

I'm having trouble with my nameservers/server. I set a small one up to host a few small sites for family & friends.

 

I set up custom nameservers via WHM, registered the nameservers to the IPs at the registrar, and have pointed the nameservers on the domain to the custom ones.

I've done this quite a few times before, all with no problems. But this time It's not going to plan, it doesn't seem to be propagating.

 

the domain is alp[dot]ninja and the nameservers are dns1 and dns2 .alp[dot]ninja

 

I have had a cPanel member of staff look at the config on the server and they say it's set up all correct. The problem is I don't know where the problem lies & what to do about it. I know for some of you it will be a 2 second peace of cake to do a scan or what not and see what the problem is.

 

So any help is appreciated! (the nameservers were changed and registered a good few days ago now)

 

Thanks

Link to post
Share on other sites

5 answers to this question

Recommended Posts

  • 0
DaveLegg

The nameserver IPs are registered as:
dns2.alp.ninja.   95.154.227.88
dns1.alp.ninja.   95.154.227.86

 

Are these correct? Neither of them are responding to DNS requests, so if they are correct, have you checked the DNS software is running, and not blocked by a firewall?

Link to post
Share on other sites
  • 0
+BudMan

yup those are you registered NS

 

Domain Name: alp.ninja
Domain ID: 5f1e8090fc2040cb89c03ccf02602192-D
WHOIS Server: http://whois.enom.com
Updated Date: 2014-09-12T12:00:23Z
Creation Date: 2014-08-02T22:27:55Z
Registry Expiry Date: 2015-08-02T22:27:55Z
Name Server: dns2.alp.ninja
Name Server: dns1.alp.ninja

 

Not sure where dave got those IPs..  the Roots are not handing out any glue, the IP addresses for those NS

 

;; Received 541 bytes from 199.7.83.42#53(l.root-servers.net) in 69 ms

alp.ninja.              86400   IN      NS      dns1.alp.ninja.
alp.ninja.              86400   IN      NS      dns2.alp.ninja.
dig: couldn't get address for 'dns1.alp.ninja': no more

 

Use to be ok, back on 9-4

 

Begin testing delegation for alp.ninja.

Name servers listed at parent: ns1.alp.ninja,ns2.alp.ninja

Name servers listed at child: ns1.alp.ninja,ns2.alp.ninja

 

Parent glue for alp.ninja found: ns1.alp.ninja (107.155.101.61)

Parent glue for alp.ninja found: ns2.alp.ninja (107.155.101.203)

 

But now there is no glue!!

 

 

  • Like 1
Link to post
Share on other sites
  • 0
ashpowell

The IP addresses are correct yes.. BudMan I see yours is bringing back the old nameservers (ns1 and ns2, new ones are dns1 and dns2)

The cPanel guy said he tested everything on the server and all seemed to be correct... could this be wrong then? 

 

Thanks for both your prompt replies btw

Link to post
Share on other sites
  • 0
ashpowell

Hold on not sure if I've fixed it... or it's sorted itself... I've just ran intoDNS again and it seems to be okay now, i think?

I ran /usr/local/cpanel/scripts/configure_rh_firewall_for_cpanel which is default script from cpanel which opens necessary ports, restarted relevent services and seems to have solved it.... So you were right in thinking it was being blocked. 
Thank you so much for your help!

I guess thats what you get when the server people install cPanel for you! Never had a problem before.

 

See! I come to neowin and get it sorted straight away. Thanks again guys

Link to post
Share on other sites
  • 0
+BudMan

Your glue is there now

 

D:\>dig NS ninja

; <<>> DiG 9.10-P2 <<>> NS ninja
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 34812
;; flags: qr rd ra; QUERY: 1, ANSWER: 4, AUTHORITY: 0, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 4096
;; QUESTION SECTION:
;ninja.                         IN      NS

;; ANSWER SECTION:
ninja.                  86400   IN      NS      demand.gamma.aridns.net.au.
ninja.                  86400   IN      NS      demand.alpha.aridns.net.au.
ninja.                  86400   IN      NS      demand.delta.aridns.net.au.
ninja.                  86400   IN      NS      demand.beta.aridns.net.au.

;; Query time: 32 msec
;; SERVER: 192.168.1.253#53(192.168.1.253)
;; WHEN: Mon Sep 15 05:14:10 Central Daylight Time 2014
;; MSG SIZE  rcvd: 154


D:\>dig NS alp.ninja @demand.gamma.aridns.net.au

; <<>> DiG 9.10-P2 <<>> NS alp.ninja @demand.gamma.aridns.net.au
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 31210
;; flags: qr rd; QUERY: 1, ANSWER: 0, AUTHORITY: 2, ADDITIONAL: 3
;; WARNING: recursion requested but not available

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 4096
;; QUESTION SECTION:
;alp.ninja.                     IN      NS

;; AUTHORITY SECTION:
alp.ninja.              86400   IN      NS      dns1.alp.ninja.
alp.ninja.              86400   IN      NS      dns2.alp.ninja.

;; ADDITIONAL SECTION:
dns1.alp.ninja.         86400   IN      A       95.154.227.86
dns2.alp.ninja.         86400   IN      A       95.154.227.88


;; Query time: 39 msec
;; SERVER: 37.209.196.7#53(37.209.196.7)
;; WHEN: Mon Sep 15 05:14:33 Central Daylight Time 2014
;; MSG SIZE  rcvd: 108


D:\>

 

And yes they answer now

 

D:\>dig @95.154.227.86 alp.ninja SOA

; <<>> DiG 9.10-P2 <<>> @95.154.227.86 alp.ninja SOA
; (1 server found)
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 36266
;; flags: qr aa rd; QUERY: 1, ANSWER: 1, AUTHORITY: 2, ADDITIONAL: 3
;; WARNING: recursion requested but not available

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 4096
;; QUESTION SECTION:
;alp.ninja.                     IN      SOA

;; ANSWER SECTION:
alp.ninja.              86400   IN      SOA     dns1.alp.ninja. ashpowell.outlook.com. 2014091214 86400 7200 3600000 86400

;; AUTHORITY SECTION:
alp.ninja.              86400   IN      NS      dns2.alp.ninja.
alp.ninja.              86400   IN      NS      dns1.alp.ninja.

;; ADDITIONAL SECTION:
dns1.alp.ninja.         14400   IN      A       95.154.227.86
dns2.alp.ninja.         14400   IN      A       95.154.227.88

;; Query time: 107 msec
;; SERVER: 95.154.227.86#53(95.154.227.86)
;; WHEN: Mon Sep 15 05:15:59 Central Daylight Time 2014
;; MSG SIZE  rcvd: 165

 

Before there was NO glue being sent back

  • Like 1
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.