• Sign in to Neowin Faster!

    Create an account on Neowin to contribute and support the site.

OS X on external TV with HDMI - high latency

Recommended Posts

x-byte    94

This is something that have been nagging me for a while on my macbook pro (mid2014 13"). Why is the latency on a TV so high. It is actually useless.

 

I have tested this on 3 different TV's with different settings. Turned on/off PC/game/any settings on the TV that I can think of. These are completely different TV's from different manufacturer (Samsung, Phillips, Sony). Also tried mDVI->HDMI adapter. Tried resolutions from 4k to 1152x648.

 

Connecting the Mac to a PC monitor works perfectly fine. No issues. Only TV's have this problem.

 

Any other Windows PC have absolutely no issues with this. So why is Mac so terrible at this thing? From searching on the web it shows really no proper reason why this happens.

 

What can be done to resolve this? Is it the Iris gpu that is the problem?

 

 

edit: forgot to add that I am currently running El Capitan. This problem was also on Yosemite.

Edited by x-byte

Share this post


Link to post
Share on other sites
chrisj1968    1,417

what is the theoretical throughput on an HDMI connection? my guess its outrageous. But it would have to be a driver issue.. (are there drivers in OSX?) usually drivers would affect this.

Share this post


Link to post
Share on other sites
x-byte    94

Throughput is not the problem. Since it works on monitors with no issues. Even on 4k resolution.

 

It must to be some type of issue on how Mac talks to a TV compared to a PC monitor. So, is there a way to eliminate this "check".? 

 

Share this post


Link to post
Share on other sites
+virtorio    3,131

The lag is almost certainty being introduced by the TV. Go into the menus and see if there is any kind of "Game" or "PC" mode you can switch it to.

  • Like 1

Share this post


Link to post
Share on other sites
x-byte    94
3 minutes ago, virtorio said:

The lag is almost certainty being introduced by the TV. Go into the menus and see if there is any kind of "Game" or "PC" mode you can switch it to.

Like I wrote in the OP, I have done that on all 3 TV's. One of them doesn't even have the option.

And why do all Window PC's works flawlessly on the same TV's? So no, this is a OS X issue for sure.

Share this post


Link to post
Share on other sites
User6060    351

I've never seen latency on my MBA '13 when connecting to a TV's HDMI input. 

 

Are we talking about seconds or miliseconds? How are you defining latency? is the audio and video out of sync?

 

have you thought about resetting pram 

Share this post


Link to post
Share on other sites
Obi-Wan Kenobi    1,119

This might sound stupid, but check your cable(s), and the connector(s). Make sure they're all making really strong contact. If you see corrosion on any cable, you can safely clean it off (most of the time) with a pencil eraser. It can't hurt to check. ;) Re-seat anything that might've been moved/jiggled/re-configured. I know that TV's aren't the best option with computers of any sort, heck, in my vista-testing days, I'd often move my PC from one room to another, just to hook it up to a TV, and would often be disappointed too. My last suggestion? Un-plug/remove batteries from everything. Hook everything back up. Connect HDMI to TV first, and turn TV on. Then turn on the Mac. See if that helps, maybe?

Share this post


Link to post
Share on other sites
x-byte    94
20 hours ago, Co_Co said:

I've never seen latency on my MBA '13 when connecting to a TV's HDMI input. 

 

Are we talking about seconds or miliseconds? How are you defining latency? is the audio and video out of sync?

 

have you thought about resetting pram 

The picture/audio is delayed by about 100ms or so. Mouse is also delayed. On the MBP the animations and mouse works fine. 

 

I'll try to reset pram later today.

 

20 hours ago, Obi-Wan Kenobi said:

This might sound stupid, but check your cable(s), and the connector(s). Make sure they're all making really strong contact. If you see corrosion on any cable, you can safely clean it off (most of the time) with a pencil eraser. It can't hurt to check. ;) Re-seat anything that might've been moved/jiggled/re-configured. I know that TV's aren't the best option with computers of any sort, heck, in my vista-testing days, I'd often move my PC from one room to another, just to hook it up to a TV, and would often be disappointed too. My last suggestion? Un-plug/remove batteries from everything. Hook everything back up. Connect HDMI to TV first, and turn TV on. Then turn on the Mac. See if that helps, maybe?

I have tested on multiple TV's and with about 10 or so cables. Also tested on multiple monitors from 1080p to 4k. On monitors everything is fine.

And since it works flawless on a Windows PC the problem is the mac, not the devices/cables.

Share this post


Link to post
Share on other sites
x-byte    94

Resetting didn't work.

 

Search everywhere for solutions but nothing so far. 

Share this post


Link to post
Share on other sites
x-byte    94

Sorry for the quick bump.

 

There was actually a new update to my TV. I haven't gotten any notifications due to it had lost the network. Not been using it for other than chrome cast lately. So I never noticed.

 

Did an update now it it works. Sorry for wasting some of your time. 

  • Like 2

Share this post


Link to post
Share on other sites
User6060    351

^ so random 

Share this post


Link to post
Share on other sites
guz2k    0

Whoa! I have a Samsun TV about two years old and it was lagging bad. I switched to "Game Mode" and it's the lag I was experiencing is virtually gone.

 

Thanks guys!

Share this post


Link to post
Share on other sites
guz2k    0
On 5/1/2016 at 8:21 AM, x-byte said:

Sorry for the quick bump.

 

There was actually a new update to my TV. I haven't gotten any notifications due to it had lost the network. Not been using it for other than chrome cast lately. So I never noticed.

 

Did an update now it it works. Sorry for wasting some of your time. 

Definitely not a waste of time, you found a solution, right? Updating worked, so someone else in the future will stumble upon your fix and be apple to try that in their quest for answers.

 

Have a great day, brotha

 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.