high sierra and veracrypt , can't mount my partition anymore

Recommended Posts

drugo    4

hi

i was an happy el capitan user and an happy sierra user

i guess i did a mistake to update to high sierra , not only for veracypt but for other softwares issues

 

well i had a parition encrypted with veracypt , it doesn't work anymore with high sierra

i download the last version of veracypt and fuse ,nothing when i try to mount the volume i got the fuse error

 

i tried with a friend laptop (with el capitan) i was able to mount it very quickly

 

is there a way to mount my external hard disk under high sierra?

can somebody try and confirm ?

and to be honest , i don't know really how better is high sierra compared to sierra

thanks

Share this post


Link to post
Share on other sites
Circaflex    3,068

You aren't the only one with this issue see here, https://github.com/osxfuse/osxfuse/issues/425. It seems the issue is stemming from FUSE. According to this, https://github.com/veracrypt/VeraCrypt/issues/216, you can still mount the partition if you know the device name. See the last post in that thread.

 

On another forum found here, https://sourceforge.net/p/veracrypt/discussion/technical/thread/52491da6/?limit=25, said he found a solution.

 

 

Quote

Thank you Mounir for your reply after investigating the matter in-depth. I found out during the upgrade to High Sierra,VeracryptVeracrypt voulem was mounted as a result it got corrupted somhow. Therefore, i managed to  image and mount the drive than Veracrypt only worked after upgrading it 1.21 and reinstalling osxfuse with the support layer option is checked. As I was able to see list of drives yet Veracrypt msg highlighted to use the supported layer option within osxfuse. Just wanted to share my experience with all of you.

Once again thank you Mounir for your reply.

 

I would probably do the following:

 

Use your friends Mac and backup whatever was on this partition.

I would then hook the drive up to your machine with High Sierra and start completely over with Veracrypt. Wipe the drive and set everything back up using High Sierra if you have enough extra storage space for the backup of that partition.

  • Thanks 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.