• Sign in to Neowin Faster!

    Create an account on Neowin to contribute and support the site.

  • 0
Sign in to follow this  

DOmain issue all of a sudden

Question

patseguin    1,292

Running a Windows Server 2008 domain with Windows 10 clients. No problems and no changes at all. I rebooted my workstation today and suddenly I can't connect to the domain.

 

I left the domain and am trying to rejoin and I get this:

 

The following error occurred when DNS was queried for the service location (SRV) resource record used to locate an Active Directory Domain Controller (AD DC) for domain "cwp.local":

The error was: "DNS name does not exist."
(error code 0x0000232B RCODE_NAME_ERROR)

The query was for the SRV record for _ldap._tcp.dc._msdcs.cwp.local

Common causes of this error include the following:

- The DNS SRV records required to locate a AD DC for the domain are not registered in DNS. These records are registered with a DNS server automatically when a AD DC is added to a domain. They are updated by the AD DC at set intervals. This computer is configured to use DNS servers with the following IP addresses:

192.168.10.2

- One or more of the following zones do not include delegation to its child zone:

cwp.local
local
. (the root zone)

 

Can anyone offer some help? My business is at a standstill because of this.

Share this post


Link to post
Share on other sites

4 answers to this question

Recommended Posts

  • 0
PsYcHoKiLLa    2,319

https://support.node4.co.uk/index.php?/Knowledgebase/Article/View/59/1/error-code-0x0000232b-rcode_name_error-when-trying-to-carry-out-a-domain-join
 

Quote

 


 

Error code 0x0000232B RCODE_NAME_ERROR means that the PC is not able to find an Active Directory Domain Controller to authenticate against, so you need to tell the PC where to it can find the DNS server.


1) Open Network and Sharing Center form Control Panel
2) Click "Change Adapter Settings"
3) Right click on the network adapter your using and click "properties"
4) Click "Internet Protocol Version 4 (TCP/IPv4)" and click "properties"
5) On the General tab - click "Use the following DNS server addresses"
6) Add the IP address of your DNS server to the "Preferred DNS server" field
7) Click OK and close out the networking
 

 

Share this post


Link to post
Share on other sites
  • 0
+BudMan    3,458
51 minutes ago, patseguin said:

This computer is configured to use DNS servers with the following IP addresses:

192.168.10.2 

Is that your DC or server in your AD running DNS?  if not then yeah your going to have issues.  All members of a AD need to point to AD for dns - and ONLY ad for DNS... Pointing to some other dns that can not resolve all your DNS records is going to make for a bad day.

Share this post


Link to post
Share on other sites
  • 0
sc302    1,723

meh he figured it out..

Share this post


Link to post
Share on other sites
  • 0
patseguin    1,292
On 6/29/2018 at 11:20 AM, sc302 said:

meh he figured it out..

Yep. I spent 2 hours trying things then tried unchecking ipv6 in my adapter settings and it fixed it. Not sure why it only just now became a problem, but maybe a win 10 update caused it?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.