• 0

Odd issue with a cell phone and WiFi


Go to solution Solved by Ready2018,

Question

jnelsoninjax

The issue is very straightforward, but I can not figure out why it is not working. The cell phone is a Samsung j5 and it can connect just fine to the home networks WiFi, but when I go out with it to work (Amazon) it can not detect that there is an open WiFi network there, whereas my Motorola can see and connect to the WiFi with no issues. The WiFi network requires you to 'connect' i.e. press the button that you agree to the agreement, now on the Motorola, I only have to this once, and afterwords it reconnects with no issues. I have even tried opening the web browser (Samsung's and Firefox) and it does not trigger the connection to the WiFi. According the IT department Google changed some security protocols about 2 months ago and that has been causing issues with the way the cell phones automatically connect to the WiFi network and they (IT) stated that the method for fixing this was to open Firefox and go to the address 1.1.1.1 and it should make the cell phone see the wireless connection, however in this case it does not, it simply goes to the DNS site at 1.1.1.1 via the 4G mobile connection, ignoring anything WiFi. Is this an issue with the cell phone, Google, or the WiFi network?

Link to post
Share on other sites

16 answers to this question

Recommended Posts

  • 1
Ready2018
3 minutes ago, jnelsoninjax said:

The issue is very straightforward, but I can not figure out why it is not working. The cell phone is a Samsung j5 and it can connect just fine to the home networks WiFi, but when I go out with it to work (Amazon) it can not detect that there is an open WiFi network there, whereas my Motorola can see and connect to the WiFi with no issues. The WiFi network requires you to 'connect' i.e. press the button that you agree to the agreement, now on the Motorola, I only have to this once, and afterwords it reconnects with no issues. I have even tried opening the web browser (Samsung's and Firefox) and it does not trigger the connection to the WiFi. According the IT department Google changed some security protocols about 2 months ago and that has been causing issues with the way the cell phones automatically connect to the WiFi network and they (IT) stated that the method for fixing this was to open Firefox and go to the address 1.1.1.1 and it should make the cell phone see the wireless connection, however in this case it does not, it simply goes to the DNS site at 1.1.1.1 via the 4G mobile connection, ignoring anything WiFi. Is this an issue with the cell phone, Google, or the WiFi network?

As the J5 can't see the wifi, it's possible that your work place has upgraded it's wifi to 5 ghz and stopped using 2.4 ghz. As the J5 isn't compatible with 5 ghz wifi then you won't be able to use their wifi if that's the case.

Link to post
Share on other sites
  • 1
adrynalyne
11 minutes ago, jnelsoninjax said:

You are correct! I did not realize that the J5 did not see 5 ghz, that would be the issue. Don't most WiFi networks support both 2.4 and 5?

I think you meant wifi chipsets?

 

I've found with Android handsets in the past, only certain channels can be seen. It seems reasonable that if its a budget handset, it might not see 5ghz at all because they cheaped out on the wifi.

Link to post
Share on other sites
  • 0
jnelsoninjax
1 hour ago, Ready2018 said:

As the J5 can't see the wifi, it's possible that your work place has upgraded it's wifi to 5 ghz and stopped using 2.4 ghz. As the J5 isn't compatible with 5 ghz wifi then you won't be able to use their wifi if that's the case.

You are correct! I did not realize that the J5 did not see 5 ghz, that would be the issue. Don't most WiFi networks support both 2.4 and 5?

Link to post
Share on other sites
  • 0
farmeunit
48 minutes ago, jnelsoninjax said:

You are correct! I did not realize that the J5 did not see 5 ghz, that would be the issue. Don't most WiFi networks support both 2.4 and 5?

Most networks support both,  but it's possible to disable one.   You get much less interference and have more channels available on 5Ghz, and it's possible they just disabled the 2.4Ghz for that reason.  5Ghz has been around forever, so they could just be supporting it.  That being said, not sure how going to specific IP would make it see the network.   It could see it being a splash page to accept user agreement and have access to internet, though.

Link to post
Share on other sites
  • 0
+BudMan
On 9/2/2018 at 1:58 PM, jnelsoninjax said:

open Firefox and go to the address 1.1.1.1

Yeah your IT dept should fix that - cloudflare took over the 1.1.1 awhile ago

 

inetnum:        1.1.1.0 - 1.1.1.255
netname:        APNIC-LABS
descr:          APNIC and Cloudflare DNS Resolver project

https://blog.cloudflare.com/fixing-reachability-to-1-1-1-1-globally/

 

It use to be unassigned so yeah it was used where it should of never been used - cisco being one of the worst in the bunch..

 

I would suggest you get with your IT to fix that for sure. Use of 1.1.1.1 is no longer viable solution for cisco and their WLC and portal pages, etc.

 

While your at it you could ask them to re-enable 2.4 support.. But yeah your going to find more or and more locations dropping support for that.. If I didn't have ###### IOT devices that only use 2.4 I would not have it on my home wifi..   Might be time to update your hardware ;)

 

 

Link to post
Share on other sites
  • 0
jnelsoninjax
7 hours ago, BudMan said:

Yeah your IT dept should fix that - cloudflare took over the 1.1.1 awhile ago

 

inetnum:        1.1.1.0 - 1.1.1.255
netname:        APNIC-LABS
descr:          APNIC and Cloudflare DNS Resolver project

https://blog.cloudflare.com/fixing-reachability-to-1-1-1-1-globally/

 

It use to be unassigned so yeah it was used where it should of never been used - cisco being one of the worst in the bunch..

 

I would suggest you get with your IT to fix that for sure. Use of 1.1.1.1 is no longer viable solution for cisco and their WLC and portal pages, etc.

 

While your at it you could ask them to re-enable 2.4 support.. But yeah your going to find more or and more locations dropping support for that.. If I didn't have ###### IOT devices that only use 2.4 I would not have it on my home wifi..   Might be time to update your hardware ;)

 

 

Well the employer is Amazon, so who knows if they will even listen to me! I will ask them about 2.4

Link to post
Share on other sites
  • 0
jnelsoninjax

So I ran into one of the IT guys at work this morning and asked him about the 2,4 GHZ network, and was told that is enabled, you just have to add it manually, when I asked him if that simply meant that the SSID was not broadcasting, he said no, it was, but it has to be manually added. Does this make any sense? The biggest issue is that I can not take the cell phone past the break room, so I would have to get the IT guys to come to me and show me how to do it.

Link to post
Share on other sites
  • 0
Jim K

To me it just sounds like they have the SSID hidden (when they said to add it manually).  Maybe when you previously connected your Motorola they didn't and it has just remembered the network?

 

You just need to find the name of it ... in Android under Wi-Fi hit "Add Network" and enter the SSID under "Network Name"

 

Have you tried to manually add it?

 

...or just work while at work and internet when at home. ? 

Link to post
Share on other sites
  • 0
jnelsoninjax
1 hour ago, Jim K said:

To me it just sounds like they have the SSID hidden (when they said to add it manually).  Maybe when you previously connected your Motorola they didn't and it has just remembered the network?

 

You just need to find the name of it ... in Android under Wi-Fi hit "Add Network" and enter the SSID under "Network Name"

 

Have you tried to manually add it?

 

...or just work while at work and internet when at home. ? 

@Jim K The Motorola sees and connects just fine, it's the Samsung J5 that apparently only supports 2.4 GHZ networks, that is the problem. As far as manually adding it, I would need to know the name on the network, correct? On the Motorola I have two networks, a Amzn-Guest and Amzn-internet. I'm guessing that it if I add one of these to the Samsung it might detect it? As for work at work and internet at home, you are correct, but there are a few things that might need to be checked on that requires the internet, otherwise, like I stated before, no cell phone can go on to the floor, unless it is a registered one belonging to managers or approved others.

Link to post
Share on other sites
  • 0
+BudMan

That "Amazon" IT is using 1.1.1.1 and now not broadcasting SSID is very disheartening to the level of competence for Amazon.. Is this some local location that is not following corp standards and just cowboy it?  Both of these scenarios do not reflect understanding..

 

Use of 1.1.1.1 by cisco wlc has always been borked..  And when you see it - instantly tells you, ok the IT here is lacking! ;)  And since the address space is now no longer bogon its even more of a indication.  They really don't care all that much about doing something correctly.  And if they are not broadcasting some SSID, they are saying hey we don't really get how this wifi stuff works.  But this will keep grandma from connecting to out super secret wifi network ;)

  • Like 1
Link to post
Share on other sites
  • 0
jnelsoninjax
12 hours ago, BudMan said:

That "Amazon" IT is using 1.1.1.1 and now not broadcasting SSID is very disheartening to the level of competence for Amazon.. Is this some local location that is not following corp standards and just cowboy it?  Both of these scenarios do not reflect understanding..

 

Use of 1.1.1.1 by cisco wlc has always been borked..  And when you see it - instantly tells you, ok the IT here is lacking! ;)  And since the address space is now no longer bogon its even more of a indication.  They really don't care all that much about doing something correctly.  And if they are not broadcasting some SSID, they are saying hey we don't really get how this wifi stuff works.  But this will keep grandma from connecting to out super secret wifi network ;)

Yeah, apparently only the 2.4 GHZ network is not broadcasting it's SSID, the 5 GHZ works just fine. I asked the IT guys why the 2.4 is not enabled and he said it is enabled but only older devices use it, so they don't have it on, but now it is simply not broadcasting the SSID...

Link to post
Share on other sites
  • 0
Mindovermaster
5 hours ago, jnelsoninjax said:

Yeah, apparently only the 2.4 GHZ network is not broadcasting it's SSID, the 5 GHZ works just fine. I asked the IT guys why the 2.4 is not enabled and he said it is enabled but only older devices use it, so they don't have it on, but now it is simply not broadcasting the SSID...

What, if it's not broadcasting an SSID, then it's not "enabled"...

Link to post
Share on other sites
  • 0
Circaflex
2 hours ago, Mindovermaster said:

What, if it's not broadcasting an SSID, then it's not "enabled"...

Sure it is, the network, you just manually have to add the SSID.

Link to post
Share on other sites
  • 0
Mindovermaster
6 hours ago, Circaflex said:

Sure it is, the network, you just manually have to add the SSID.

Never heard of that, huh...

Link to post
Share on other sites
  • 0
xendrome
58 minutes ago, Mindovermaster said:

Never heard of that, huh...

You can turn off broadcasting SSIDs in most WAP/routers.

  • Like 1
Link to post
Share on other sites
  • 0
+BudMan

While you can disable broadcasting of an SSID it is completely utterly borked.. And has been listed as one of the "dumbest" ways to attempt to secure a wifi network for YEARS and YEARS..  Nobody that manages the wifi and actually understands what they are doing would ever do such a thing!!

 

That dead horse has been beaten to death what 10 years ago ;)

 

To be honest that wifi router makers still have it as an option is pathetic..   It doesn't actually hide anything

socalledhidden.thumb.png.7bc86cd74232ef0d1e47e8bfc6dd039e.png

 

Anyone with the ability to google, and some basic skills can find the ssid even when they are not broadcasted..

 

Above the ones my different AP can see..  Example

https://www.acrylicwifi.com/en/blog/hidden-ssid-wifi-how-to-know-name-of-network-without-ssid/

 

This was posted in 2005.. 13 years ago

https://www.zdnet.com/article/the-six-dumbest-ways-to-secure-a-wireless-lan/

 

Not broadcasting your SSID listed right under mac filtering ;)

 

SSID hiding: There is no such thing as "SSID hiding". You're only hiding SSID beaconing on the Access Point. There are 4 other mechanisms that also broadcast the SSID over the 2.4 or 5 GHz spectrum. The 4 mechanisms are; probe requests, probe responses, association requests, and re-association requests. Essentially, youre talking about hiding 1 of 5 SSID broadcast mechanisms. Nothing is hidden and all youve achieved is cause problems for Wi-Fi roaming when a client jumps from AP to AP. Hidden SSIDs also makes wireless LANs less user friendly. You dont need to take my word for it. Just ask Robert Moskowitz who is the Senior Technical Director of ICSA Labs in his white paper .

 

  • Like 2
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.